summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-28 04:29:13 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-28 04:29:13 +0000
commit37f87f4c312a6eb1c45e71f9e3cbb614cc45987d (patch)
tree4a821fc49c31361cf5dc93af6d17728e7a8cb3e4 /games-action/d2x
parentMarked amd64. First fsv tag for amd64. (Manifest recommit) (diff)
downloadgentoo-2-37f87f4c312a6eb1c45e71f9e3cbb614cc45987d.tar.gz
gentoo-2-37f87f4c312a6eb1c45e71f9e3cbb614cc45987d.tar.bz2
gentoo-2-37f87f4c312a6eb1c45e71f9e3cbb614cc45987d.zip
QA - fix use invocation
Diffstat (limited to 'games-action/d2x')
-rw-r--r--games-action/d2x/ChangeLog6
-rw-r--r--games-action/d2x/d2x-0.2.5-r1.ebuild6
-rw-r--r--games-action/d2x/d2x-0.2.5.ebuild6
3 files changed, 13 insertions, 5 deletions
diff --git a/games-action/d2x/ChangeLog b/games-action/d2x/ChangeLog
index b33583b38497..93bac7d10689 100644
--- a/games-action/d2x/ChangeLog
+++ b/games-action/d2x/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/d2x
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.5 2004/06/26 17:52:01 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.6 2004/06/28 04:25:14 agriffis Exp $
+
+ 27 Jun 2004; Aron Griffis <agriffis@gentoo.org> d2x-0.2.5-r1.ebuild,
+ d2x-0.2.5.ebuild:
+ QA - fix use invocation
*d2x-0.2.5-r1 (26 Jun 2004)
diff --git a/games-action/d2x/d2x-0.2.5-r1.ebuild b/games-action/d2x/d2x-0.2.5-r1.ebuild
index 8a6561a603dc..a86d98243771 100644
--- a/games-action/d2x/d2x-0.2.5-r1.ebuild
+++ b/games-action/d2x/d2x-0.2.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r1.ebuild,v 1.1 2004/06/26 17:52:01 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r1.ebuild,v 1.2 2004/06/28 04:25:14 agriffis Exp $
inherit flag-o-matic eutils games
@@ -62,7 +62,9 @@ src_compile() {
# in gr, thus when they go to link they cause redefine errors ...
# we build each by it self, save the binary file, clean up, and start over
mkdir my-bins
- for ren in sdl $(use opengl) $(use svga) $(use ggi) ; do
+ for ren in sdl $(useq opengl && echo opengl) \
+ $(useq svga && echo svga) $(useq ggi && echo ggi)
+ do
[ "${ren}" == "sdl" ] \
&& renconf="" \
|| renconf="--with-${ren}"
diff --git a/games-action/d2x/d2x-0.2.5.ebuild b/games-action/d2x/d2x-0.2.5.ebuild
index d27205324260..d13679c9bfd6 100644
--- a/games-action/d2x/d2x-0.2.5.ebuild
+++ b/games-action/d2x/d2x-0.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5.ebuild,v 1.6 2004/06/24 21:54:04 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5.ebuild,v 1.7 2004/06/28 04:25:14 agriffis Exp $
inherit flag-o-matic eutils games
@@ -41,7 +41,9 @@ src_compile() {
# in gr, thus when they go to link they cause redefine errors ...
# we build each by it self, save the binary file, clean up, and start over
mkdir my-bins
- for ren in sdl $(use opengl) $(use svga) $(use ggi) ; do
+ for ren in sdl $(useq opengl && echo opengl) \
+ $(useq svga && echo svga) $(useq ggi && echo ggi)
+ do
[ "${ren}" == "sdl" ] \
&& renconf="" \
|| renconf="--with-${ren}"