summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-02-13 01:19:58 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-02-13 01:19:58 +0000
commit63cb0f439a367114ab93dc479c28381fd314a0be (patch)
tree56ae1286ebab85aebf9ae588a2121edb2ef55971 /games-action/atanks/atanks-2.1.ebuild
parentMarked ppc stable. (diff)
downloadgentoo-2-63cb0f439a367114ab93dc479c28381fd314a0be.tar.gz
gentoo-2-63cb0f439a367114ab93dc479c28381fd314a0be.tar.bz2
gentoo-2-63cb0f439a367114ab93dc479c28381fd314a0be.zip
Version bump
(Portage version: 2.1.2-r9)
Diffstat (limited to 'games-action/atanks/atanks-2.1.ebuild')
-rw-r--r--games-action/atanks/atanks-2.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-action/atanks/atanks-2.1.ebuild b/games-action/atanks/atanks-2.1.ebuild
new file mode 100644
index 000000000000..48031961b9cc
--- /dev/null
+++ b/games-action/atanks/atanks-2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-2.1.ebuild,v 1.1 2007/02/13 01:19:58 nyhm Exp $
+
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="Worms and Scorched Earth-like game"
+HOMEPAGE="http://atanks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/allegro"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^CC/s:g++:$(tc-getCXX):" \
+ -e '/^CFLAGS/s:-g::' \
+ -e 's:CFLAGS:CXXFLAGS:' \
+ -e '/^LDFLAGS/s:=:+=:' \
+ -e "s:DATA_DIR=.*:DATA_DIR=\\\\\"${GAMES_DATADIR}/${PN}\\\\\":" \
+ src/Makefile \
+ || die "sed failed"
+ emake clean
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *.dat *.txt || die "doins failed"
+ dodoc BUGS Changelog README TODO
+ prepgamesdirs
+}