summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-01-13 18:41:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-01-13 18:41:28 +0000
commiteed5037c8b29273735488fe42e7b693b6a285228 (patch)
treea1e9fa529eb7c46309522545bf15bfb17225d6c4 /eclass
parentinitial commit (diff)
downloadgentoo-2-eed5037c8b29273735488fe42e7b693b6a285228.tar.gz
gentoo-2-eed5037c8b29273735488fe42e7b693b6a285228.tar.bz2
gentoo-2-eed5037c8b29273735488fe42e7b693b6a285228.zip
Support packages that use GNUmakefile.am sa automake start file. Patch by Luca Bruno in bug #205606.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/autotools.eclass19
1 files changed, 13 insertions, 6 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index b817d3ed44b1..d61cf6cf545b 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.69 2008/01/07 02:54:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.70 2008/01/13 18:41:28 flameeyes Exp $
#
# Maintainer: base-system@gentoo.org
#
@@ -140,7 +140,7 @@ _elibtoolize() {
lttest="$(autotools_check_macro "AC_PROG_LIBTOOL")$(autotools_check_macro "AM_PROG_LIBTOOL")"
[[ -n $lttest ]] || return 0
- [[ -f Makefile.am ]] && opts="--automake"
+ [[ -f GNUmakefile.am || -f Makefile.am ]] && opts="--automake"
[[ "${USERLAND}" == "Darwin" ]] && LIBTOOLIZE="glibtoolize"
autotools_run_tool ${LIBTOOLIZE:-libtoolize} "$@" ${opts}
@@ -168,16 +168,23 @@ eautoconf() {
eautomake() {
local extra_opts
+ local makefile_name
+
+ if [[ -f GNUmakefile.am ]]; then
+ makefile_name="GNUmakefile"
+ elif [[ -f Makefile.am ]]; then
+ makefile_name="Makefile"
+ else
+ return 0
+ fi
- [[ -f Makefile.am ]] || return 0
-
- if [[ -z ${FROM_EAUTORECONF} && -f Makefile.in ]]; then
+ if [[ -z ${FROM_EAUTORECONF} && -f ${makefile_name}.in ]]; then
local used_automake
local installed_automake
installed_automake=$(automake --version | head -n 1 | \
sed -e 's:.*(GNU automake) ::')
- used_automake=$(head -n 1 < Makefile.in | \
+ used_automake=$(head -n 1 < ${makefile_name}.in | \
sed -e 's:.*by automake \(.*\) from .*:\1:')
if [[ ${installed_automake} != ${used_automake} ]]; then