summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-18 22:48:10 +0000
committerMichał Górny <mgorny@gentoo.org>2013-09-18 22:48:10 +0000
commit4a0244cb16b7c0c07e8c3d2e6f8ee2c890840933 (patch)
treea853fc835e72a4feaa9fd9d97baeab4ddee51630 /eclass
parentSupport both emul-linux and multilib dependencies. Bug #485330 with patch fro... (diff)
downloadgentoo-2-4a0244cb16b7c0c07e8c3d2e6f8ee2c890840933.tar.gz
gentoo-2-4a0244cb16b7c0c07e8c3d2e6f8ee2c890840933.tar.bz2
gentoo-2-4a0244cb16b7c0c07e8c3d2e6f8ee2c890840933.zip
Fix accepting arguments in distutils_install_for_testing.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog5
-rw-r--r--eclass/distutils-r1.eclass4
2 files changed, 6 insertions, 3 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index 275defdbdf6a..d5836fd222ba 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for eclass directory
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.977 2013/09/18 18:47:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.978 2013/09/18 22:48:10 mgorny Exp $
+
+ 18 Sep 2013; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
+ Fix accepting arguments in distutils_install_for_testing.
18 Sep 2013; Michał Górny <mgorny@gentoo.org> python.eclass:
Add a note not to add new Python versions to python.eclass.
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index d51ce44ea69a..dad6eed33dd6 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.80 2013/09/17 17:33:39 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.81 2013/09/18 22:48:10 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -305,7 +305,7 @@ distutils_install_for_testing() {
fi
mkdir -p "${libdir}" || die
- esetup.py "${add_args[@]}"
+ esetup.py "${add_args[@]}" "${@}"
}
# @FUNCTION: _distutils-r1_disable_ez_setup