summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-02-20 02:54:21 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-02-20 02:54:21 +0000
commit0be3cc8e07c50b0b94e4d0202c1693678038684f (patch)
tree91bc6473d6015c92443fafb5e6d48c9e5fe09551 /eclass
parentRe-do init script. (diff)
downloadgentoo-2-0be3cc8e07c50b0b94e4d0202c1693678038684f.tar.gz
gentoo-2-0be3cc8e07c50b0b94e4d0202c1693678038684f.tar.bz2
gentoo-2-0be3cc8e07c50b0b94e4d0202c1693678038684f.zip
Remove my WANT_AUTOMAKE=none overloading in eautomake and instead introduce AT_NOEACLOCAL, AT_NOEAUTOCONF, AT_NOEAUTOMAKE that work the same as AT_NOELIBTOOLIZE. Should fix bug #404555.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog7
-rw-r--r--eclass/autotools.eclass43
2 files changed, 36 insertions, 14 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index 699c3764bc45..95e2d023b982 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for eclass directory
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.136 2012/02/15 18:41:24 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.137 2012/02/20 02:54:21 robbat2 Exp $
+
+ 20 Feb 2012; Robin H. Johnson <robbat2@gentoo.org> autotools.eclass:
+ Remove my WANT_AUTOMAKE=none overloading in eautomake and instead introduce
+ AT_NOEACLOCAL, AT_NOEAUTOCONF, AT_NOEAUTOMAKE that work the same as
+ AT_NOELIBTOOLIZE. Should fix bug #404555.
15 Feb 2012; Joerg Bornkessel <hd_brummy@gentoo.org> vdr-plugin.eclass:
move media-tv to virtual/linuxtv-dvb-headers, bug #403929
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index 63ae0c4bbd5e..6e16ab0a2d61 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.121 2012/02/13 17:26:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.122 2012/02/20 02:54:21 robbat2 Exp $
# @ECLASS: autotools.eclass
# @MAINTAINER:
@@ -98,6 +98,27 @@ unset _automake_atom _autoconf_atom
# Additional options to pass to automake during
# eautoreconf call.
+# @ECLASS-VARIABLE: AT_NOEACLOCAL
+# @DEFAULT_UNSET
+# @DESCRIPTION:
+# Don't run eaclocal command if set to 'yes',
+# useful when eaclocal needs to be ran with
+# particular options
+
+# @ECLASS-VARIABLE: AT_NOEAUTOCONF
+# @DEFAULT_UNSET
+# @DESCRIPTION:
+# Don't run eautoconf command if set to 'yes',
+# useful when eautoconf needs to be ran with
+# particular options
+
+# @ECLASS-VARIABLE: AT_NOEAUTOMAKE
+# @DEFAULT_UNSET
+# @DESCRIPTION:
+# Don't run eautomake command if set to 'yes',
+# useful when eautomake needs to be ran with
+# particular options
+
# @ECLASS-VARIABLE: AT_NOELIBTOOLIZE
# @DEFAULT_UNSET
# @DESCRIPTION:
@@ -142,18 +163,20 @@ eautoreconf() {
auxdir=$(autotools_get_auxdir)
- einfo "Running eautoreconf in '${PWD}' ..."
- [[ -n ${auxdir} ]] && mkdir -p ${auxdir}
- eaclocal
+ if [[ ${AT_NOEACLOCAL} != "yes" ]]; then
+ einfo "Running eautoreconf in '${PWD}' ..."
+ [[ -n ${auxdir} ]] && mkdir -p ${auxdir}
+ eaclocal
+ fi
[[ ${CHOST} == *-darwin* ]] && g=g
if ${LIBTOOLIZE:-${g}libtoolize} -n --install >& /dev/null ; then
_elibtoolize --copy --force --install
else
_elibtoolize --copy --force
fi
- eautoconf
- eautoheader
- FROM_EAUTORECONF="yes" eautomake ${AM_OPTS}
+ [[ ${AT_NOEAUTOCONF} != "yes" ]] && eautoconf
+ [[ ${AT_NOEAUTOHEADER} != "yes" ]] && eautoheader
+ [[ ${AT_NOEAUTOMAKE} != "yes" ]] && FROM_EAUTORECONF="yes" eautomake ${AM_OPTS}
[[ ${AT_NOELIBTOOLIZE} == "yes" ]] && return 0
@@ -254,12 +277,6 @@ eautomake() {
local extra_opts
local makefile_name
- # Some packages might need to skip automake
- # OpenLDAP is a good example. It does not use automake (all the .in files are
- # handwritten), but it does AM_INIT_AUTOMAKE in configure.in, for all the
- # other macros involved
- [[ ${WANT_AUTOMAKE} == "none" ]] && return 0
-
# Run automake if:
# - a Makefile.am type file exists
# - the configure script is using the AM_INIT_AUTOMAKE directive