summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2005-05-15 20:30:04 +0000
committerJohn Mylchreest <johnm@gentoo.org>2005-05-15 20:30:04 +0000
commitd1db1b78afd49e8915c30330199cbdab507f530d (patch)
treeed72ae9eb0670034bff55a865ff4dcdd7af50fb2 /eclass/kernel-2.eclass
parentmoved to app-mobilephone/gsmlib (diff)
downloadgentoo-2-d1db1b78afd49e8915c30330199cbdab507f530d.tar.gz
gentoo-2-d1db1b78afd49e8915c30330199cbdab507f530d.tar.bz2
gentoo-2-d1db1b78afd49e8915c30330199cbdab507f530d.zip
Ignore KBUILD_OUTPUT for linux-headers. Fixes bug #92620
Diffstat (limited to 'eclass/kernel-2.eclass')
-rw-r--r--eclass/kernel-2.eclass6
1 files changed, 5 insertions, 1 deletions
diff --git a/eclass/kernel-2.eclass b/eclass/kernel-2.eclass
index 70ac53726270..8a7230a7ca44 100644
--- a/eclass/kernel-2.eclass
+++ b/eclass/kernel-2.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kernel-2.eclass,v 1.124 2005/05/09 17:20:11 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kernel-2.eclass,v 1.125 2005/05/15 20:30:04 johnm Exp $
# Description: kernel.eclass rewrite for a clean base regarding the 2.6
# series of kernel with back-compatibility for 2.4
@@ -321,6 +321,10 @@ unpack_fix_docbook() {
# Compile Functions
#==============================================================
compile_headers() {
+ # Since KBUILD_OUTPUT shouldnt be used when compiling headers, lets unset it
+ # if it exists.
+ [[ -n ${KBUILD_OUTPUT} ]] && unset KBUILD_OUTPUT
+
# if we couldnt obtain HOSTCFLAGS from the Makefile,
# then set it to something sane
local HOSTCFLAGS=$(getfilevar HOSTCFLAGS ${S}/Makefile)