summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-09-05 04:34:53 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-09-05 04:34:53 +0000
commitdb9bba870b278841033837dc9e7a8ad986fc8963 (patch)
treefa16e67ac59bc88d2ddae0dc91bd12fb57b3dbc2 /eclass/commonbox.eclass
parentfew more run-time fixes (diff)
downloadgentoo-2-db9bba870b278841033837dc9e7a8ad986fc8963.tar.gz
gentoo-2-db9bba870b278841033837dc9e7a8ad986fc8963.tar.bz2
gentoo-2-db9bba870b278841033837dc9e7a8ad986fc8963.zip
commonbox stuff fixed -- menu in /usr/share/commonbox/menu now, and nls stuff in /usr/share/locale; also sh-utils has a new patch
Diffstat (limited to 'eclass/commonbox.eclass')
-rw-r--r--eclass/commonbox.eclass47
1 files changed, 29 insertions, 18 deletions
diff --git a/eclass/commonbox.eclass b/eclass/commonbox.eclass
index 1194b734f37e..ff5700bce17b 100644
--- a/eclass/commonbox.eclass
+++ b/eclass/commonbox.eclass
@@ -1,7 +1,7 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2
# Author: Seemant Kulleen <seemant@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/commonbox.eclass,v 1.8 2002/09/04 12:18:42 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/commonbox.eclass,v 1.9 2002/09/05 04:34:53 seemant Exp $
# The commonbox eclass is designed to allow easier installation of the box
# window managers such as blackbox and fluxbox and commonbox
@@ -14,7 +14,8 @@ INHERITED="$INHERITED $ECLASS"
EXPORT_FUNCTIONS src_unpack src_compile src_install pkg_postinst
-DEPEND="x11-misc/commonbox-utils
+DEPEND="sys-apps/supersed
+ x11-misc/commonbox-utils
x11-themes/commonbox-styles"
RDEPEND="nls? ( sys-devel/gettext )"
@@ -33,22 +34,30 @@ commonbox_src_unpack() {
unpack ${A}
- cd ${S}
- cp Makefile.am Makefile.am.orig
- sed 's/data //' Makefile.am.orig > Makefile.am
+ ssed -i 's:data ::' ${S}/Makefile.am
- cd ${S}/util
- cp Makefile.am Makefile.am.orig
- sed -e 's/bsetbg//' \
- -e 's/bsetroot//' \
- Makefile.am.orig > Makefile.am
+ ssed -i \
+ -e 's:bsetbg::' \
+ -e 's:bsetroot::' \
+ ${S}/util/Makefile.am
+ ssed -i \
+ -e 's:bsetroot.1::' \
+ -e 's:bsetbg.1::' \
+ ${S}/doc/Makefile.am
- cd ${S}/doc
- cp Makefile.am Makefile.am.orig
- sed -e "s:bsetroot.1::" \
- -e "s:bsetbg.1::" \
- Makefile.am.orig > Makefile.am
+ for i in `find ${S} -name 'Makefile.am'`
+ do
+ ssed -i 's:$(pkgdatadir)/nls:/usr/share/locale:' ${i}
+ done
+
+ for i in `find ${S}/nls -name 'Makefile.am'`
+ do
+ ssed -i \
+ -e "s:blackbox.cat:${MYBIN}.cat:g" \
+ -e "s:${PN}.cat:${MYBIN}.cat:g" \
+ ${i}
+ done
einfo ${MYBIN}
@@ -81,7 +90,7 @@ commonbox_src_compile() {
${myconf} || die
emake \
- pkgdatadir=/usr/share/commonbox/${MYBIN} || die
+ pkgdatadir=/usr/share/commonbox || die
}
@@ -89,8 +98,8 @@ commonbox_src_compile() {
commonbox_src_install() {
dodir /usr/share/commonbox
- einstall \
- pkgdatadir=${D}/usr/share/commonbox/${MYBIN} || die
+
+ make DESTDIR=${D} install || die
# move the ${PN} binary to ${MYBIN}
@@ -137,4 +146,6 @@ commonbox_pkg_postinst() {
einfo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
einfo
fi
+
+ commonbox-menugen -kg
}