summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-08-10 12:28:59 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-08-10 12:28:59 +0000
commit955bed78b9b912ed1031f3def758258628fa803b (patch)
treede0320156fd10e268b195f4a08b92a5f610f75e6 /dev-vcs
parentVersion bump (diff)
downloadgentoo-2-955bed78b9b912ed1031f3def758258628fa803b.tar.gz
gentoo-2-955bed78b9b912ed1031f3def758258628fa803b.tar.bz2
gentoo-2-955bed78b9b912ed1031f3def758258628fa803b.zip
version bump for bug 330153 by Tim Harder <radhermit AT gmail DOT com>
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/bzr/ChangeLog8
-rw-r--r--dev-vcs/bzr/bzr-2.2.0.ebuild132
-rw-r--r--dev-vcs/bzr/files/bzr-2.2.0-no-pyrex-citon.patch33
3 files changed, 172 insertions, 1 deletions
diff --git a/dev-vcs/bzr/ChangeLog b/dev-vcs/bzr/ChangeLog
index 4fde50b1ddd8..5110ef959f82 100644
--- a/dev-vcs/bzr/ChangeLog
+++ b/dev-vcs/bzr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/bzr
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/ChangeLog,v 1.7 2010/07/14 20:06:15 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/ChangeLog,v 1.8 2010/08/10 12:28:59 fauli Exp $
+
+*bzr-2.2.0 (10 Aug 2010)
+
+ 10 Aug 2010; Christian Faulhammer <fauli@gentoo.org> +bzr-2.2.0.ebuild,
+ +files/bzr-2.2.0-no-pyrex-citon.patch:
+ version bump for bug 330153 by Tim Harder <radhermit AT gmail DOT com>
14 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
bzr-2.1.2.ebuild:
diff --git a/dev-vcs/bzr/bzr-2.2.0.ebuild b/dev-vcs/bzr/bzr-2.2.0.ebuild
new file mode 100644
index 000000000000..9fcc2a956ae8
--- /dev/null
+++ b/dev-vcs/bzr/bzr-2.2.0.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/bzr-2.2.0.ebuild,v 1.1 2010/08/10 12:28:59 fauli Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit bash-completion distutils elisp-common eutils versionator
+
+MY_P=${PN}-${PV}
+SERIES=$(get_version_component_range 1-2)
+
+DESCRIPTION="Bazaar is a next generation distributed version control system."
+HOMEPAGE="http://bazaar-vcs.org/"
+#SRC_URI="http://bazaar-vcs.org/releases/src/${MY_P}.tar.gz"
+SRC_URI="http://launchpad.net/bzr/${SERIES}/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="curl doc emacs +sftp test"
+
+# Disable until https://bugs.launchpad.net/bzr/+bug/392127 is fixed
+RESTRICT="test"
+
+RDEPEND="|| ( dev-lang/python:2.7[xml] dev-lang/python:2.6[xml] dev-lang/python:2.5[xml] dev-python/celementtree )
+ curl? ( dev-python/pycurl )
+ sftp? ( dev-python/paramiko )"
+
+DEPEND="emacs? ( virtual/emacs )
+ test? (
+ ${RDEPEND}
+ dev-python/medusa
+ dev-python/subunit
+ dev-python/testtools
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="doc/*.txt"
+PYTHON_MODNAME="bzrlib"
+SITEFILE="71bzr-gentoo.el"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Don't regenerate .c files from .pyx when pyrex is found.
+ epatch "${FILESDIR}/${PN}-2.2.0-no-pyrex-citon.patch"
+ # Don't run lock permission tests when running as root
+ epatch "${FILESDIR}/${PN}-0.90-tests-fix_root.patch"
+ # Fix permission errors when run under directories with setgid set.
+ epatch "${FILESDIR}/${PN}-0.90-tests-sgid.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use emacs; then
+ elisp-compile contrib/emacs/bzr-mode.el || die
+ fi
+}
+
+src_test() {
+ # Some tests expect the usual pyc compiling behaviour.
+ python_enable_pyc
+
+ # Define tests which are known to fail below.
+ local skip_tests="("
+ # https://bugs.launchpad.net/bzr/+bug/456471
+ skip_tests+="bzrlib.tests.blackbox.test_version.*|"
+ # https://bugs.launchpad.net/bzr/+bug/392127
+ skip_tests+="test_http.*"
+ skip_tests+=")"
+ if [[ -n ${skip_tests} ]]; then
+ einfo "Skipping tests known to fail: ${skip_tests}"
+ fi
+
+ testing() {
+ LC_ALL="C" "$(PYTHON -A)" bzr --no-plugins selftest ${skip_tests:+-x} ${skip_tests}
+ }
+ python_execute_function testing
+
+ # Just to make sure we don't hit any errors on later stages.
+ python_disable_pyc
+}
+
+src_install() {
+ distutils_src_install --install-data "${EPREFIX}/usr/share"
+
+ if use doc; then
+ docinto developers
+ dodoc doc/developers/* || die
+ for doc in mini-tutorial tutorials user-{guide,reference}; do
+ docinto $doc
+ dodoc doc/en/$doc/* || die
+ done
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} contrib/emacs/*.el* || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ # don't add automatically to the load-path, so the sitefile
+ # can do a conditional loading
+ touch "${ED}${SITELISP}/${PN}/.nosearch"
+ fi
+
+ dobashcompletion contrib/bash/bzr
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ bash-completion_pkg_postinst
+
+ if use emacs; then
+ elisp-site-regen
+ elog "If you are using a GNU Emacs version greater than 22.1, bzr support"
+ elog "is already included. This ebuild does not automatically activate bzr support"
+ elog "in versions below, but prepares it in a way you can load it from your ~/.emacs"
+ elog "file by adding"
+ elog " (load \"bzr-mode\")"
+ fi
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ use emacs && elisp-site-regen
+}
diff --git a/dev-vcs/bzr/files/bzr-2.2.0-no-pyrex-citon.patch b/dev-vcs/bzr/files/bzr-2.2.0-no-pyrex-citon.patch
new file mode 100644
index 000000000000..010b6a718a0e
--- /dev/null
+++ b/dev-vcs/bzr/files/bzr-2.2.0-no-pyrex-citon.patch
@@ -0,0 +1,33 @@
+--- setup.py.orig 2010-08-10 14:15:41.542138016 +0200
++++ setup.py 2010-08-10 14:16:08.731137806 +0200
+@@ -168,28 +168,9 @@
+ from distutils.errors import CCompilerError, DistutilsPlatformError
+ from distutils.extension import Extension
+ ext_modules = []
+-try:
+- try:
+- from Pyrex.Distutils import build_ext
+- from Pyrex.Compiler.Version import version as pyrex_version
+- except ImportError:
+- print("No Pyrex, trying Cython...")
+- from Cython.Distutils import build_ext
+- from Cython.Compiler.Version import version as pyrex_version
+-except ImportError:
+- have_pyrex = False
+- # try to build the extension from the prior generated source.
+- print("")
+- print("The python package 'Pyrex' is not available."
+- " If the .c files are available,")
+- print("they will be built,"
+- " but modifying the .pyx files will not rebuild them.")
+- print("")
+- from distutils.command.build_ext import build_ext
+-else:
+- have_pyrex = True
+- pyrex_version_info = tuple(map(int, pyrex_version.split('.')))
+
++have_pyrex = False
++from distutils.command.build_ext import build_ext
+
+ class build_ext_if_possible(build_ext):
+