summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-03-07 03:20:57 +0000
committerTim Harder <radhermit@gentoo.org>2011-03-07 03:20:57 +0000
commit912329e2a85a86a5a43e999d4155c18a64568a82 (patch)
tree3a57b386a84931a0c76a4dfbc39731913945ff53 /dev-vcs
parentInitial commit (diff)
downloadgentoo-2-912329e2a85a86a5a43e999d4155c18a64568a82.tar.gz
gentoo-2-912329e2a85a86a5a43e999d4155c18a64568a82.tar.bz2
gentoo-2-912329e2a85a86a5a43e999d4155c18a64568a82.zip
Version bump. Update to EAPI 4 and add myself as a maintainer.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tig/ChangeLog10
-rw-r--r--dev-vcs/tig/metadata.xml4
-rw-r--r--dev-vcs/tig/tig-0.17.ebuild27
3 files changed, 39 insertions, 2 deletions
diff --git a/dev-vcs/tig/ChangeLog b/dev-vcs/tig/ChangeLog
index fe8a36a2ffc9..64112c182759 100644
--- a/dev-vcs/tig/ChangeLog
+++ b/dev-vcs/tig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/tig
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.4 2010/11/09 22:04:34 radhermit Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.5 2011/03/07 03:20:57 radhermit Exp $
+
+*tig-0.17 (07 Mar 2011)
+
+ 07 Mar 2011; Tim Harder <radhermit@gentoo.org> +tig-0.17.ebuild,
+ metadata.xml:
+ Version bump. Update to EAPI 4 and add myself as a maintainer.
*tig-0.16.2 (09 Nov 2010)
diff --git a/dev-vcs/tig/metadata.xml b/dev-vcs/tig/metadata.xml
index 7468e5f984c3..7e53d2326075 100644
--- a/dev-vcs/tig/metadata.xml
+++ b/dev-vcs/tig/metadata.xml
@@ -6,4 +6,8 @@
<email>gregkh@gentoo.org</email>
<name>Greg Kroah-Hartman</name>
</maintainer>
+<maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+</maintainer>
</pkgmetadata>
diff --git a/dev-vcs/tig/tig-0.17.ebuild b/dev-vcs/tig/tig-0.17.ebuild
new file mode 100644
index 000000000000..4b1a721c726e
--- /dev/null
+++ b/dev-vcs/tig/tig-0.17.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-0.17.ebuild,v 1.1 2011/03/07 03:20:57 radhermit Exp $
+
+EAPI=4
+
+inherit bash-completion
+
+DESCRIPTION="Tig: text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc BUGS NEWS TODO
+ dohtml manual.html README.html
+ dobashcompletion contrib/tig-completion.bash
+}