summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-01-19 10:30:16 +0000
committerMike Frysinger <vapier@gentoo.org>2014-01-19 10:30:16 +0000
commit82969872a5d5721fba2ba69772ecc1a327793c7e (patch)
treeef438df2929255303c0ac3849029342b15d31c61 /dev-vcs
parentStable for ppc64, wrt bug #496632 (diff)
downloadgentoo-2-82969872a5d5721fba2ba69772ecc1a327793c7e.tar.gz
gentoo-2-82969872a5d5721fba2ba69772ecc1a327793c7e.tar.bz2
gentoo-2-82969872a5d5721fba2ba69772ecc1a327793c7e.zip
Fix cross-compiling due to AC_TRY_RUN.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cvs/ChangeLog8
-rw-r--r--dev-vcs/cvs/cvs-1.12.12-r10.ebuild9
-rw-r--r--dev-vcs/cvs/cvs-1.12.12-r6.ebuild9
-rw-r--r--dev-vcs/cvs/cvs-1.12.12-r7.ebuild9
-rw-r--r--dev-vcs/cvs/cvs-1.12.12-r8.ebuild9
-rw-r--r--dev-vcs/cvs/cvs-1.12.12-r9.ebuild9
-rw-r--r--dev-vcs/cvs/cvs-1.12.13-r1.ebuild9
-rw-r--r--dev-vcs/cvs/cvs-1.12.13-r2.ebuild9
-rw-r--r--dev-vcs/cvs/cvs-1.12.13.1-r1.ebuild9
-rw-r--r--dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild9
-rw-r--r--dev-vcs/cvs/cvs-1.12.13.1.ebuild9
11 files changed, 77 insertions, 21 deletions
diff --git a/dev-vcs/cvs/ChangeLog b/dev-vcs/cvs/ChangeLog
index c43d71d4b9ec..16832f20d8d5 100644
--- a/dev-vcs/cvs/ChangeLog
+++ b/dev-vcs/cvs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/cvs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/ChangeLog,v 1.13 2014/01/19 10:21:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/ChangeLog,v 1.14 2014/01/19 10:30:16 vapier Exp $
+
+ 19 Jan 2014; Mike Frysinger <vapier@gentoo.org> cvs-1.12.12-r10.ebuild,
+ cvs-1.12.12-r6.ebuild, cvs-1.12.12-r7.ebuild, cvs-1.12.12-r8.ebuild,
+ cvs-1.12.12-r9.ebuild, cvs-1.12.13-r1.ebuild, cvs-1.12.13-r2.ebuild,
+ cvs-1.12.13.1-r1.ebuild, cvs-1.12.13.1-r2.ebuild, cvs-1.12.13.1.ebuild:
+ Fix cross-compiling due to AC_TRY_RUN.
19 Jan 2014; Mike Frysinger <vapier@gentoo.org> cvs-1.11.23.ebuild,
cvs-1.12.12-r10.ebuild, cvs-1.12.12-r6.ebuild, cvs-1.12.12-r7.ebuild,
diff --git a/dev-vcs/cvs/cvs-1.12.12-r10.ebuild b/dev-vcs/cvs/cvs-1.12.12-r10.ebuild
index 6899cefdb0fa..dd75326c888d 100644
--- a/dev-vcs/cvs/cvs-1.12.12-r10.ebuild
+++ b/dev-vcs/cvs/cvs-1.12.12-r10.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.12-r10.ebuild,v 1.3 2014/01/19 10:21:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.12-r10.ebuild,v 1.4 2014/01/19 10:30:16 vapier Exp $
EAPI=3
-inherit eutils pam
+inherit eutils pam toolchain-funcs
DESCRIPTION="Concurrent Versions System - source code revision control tools"
HOMEPAGE="http://www.nongnu.org/cvs/"
@@ -44,6 +44,11 @@ src_prepare() {
}
src_configure() {
+ if tc-is-cross-compiler ; then
+ # Sane defaults when cross-compiling (as these tests want to
+ # try and execute code).
+ export cvs_cv_func_printf_ptr="yes"
+ fi
econf \
--with-external-zlib \
--with-tmpdir=/tmp \
diff --git a/dev-vcs/cvs/cvs-1.12.12-r6.ebuild b/dev-vcs/cvs/cvs-1.12.12-r6.ebuild
index c24660bcfe69..c3f1ba4f2cbb 100644
--- a/dev-vcs/cvs/cvs-1.12.12-r6.ebuild
+++ b/dev-vcs/cvs/cvs-1.12.12-r6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.12-r6.ebuild,v 1.3 2014/01/19 10:21:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.12-r6.ebuild,v 1.4 2014/01/19 10:30:16 vapier Exp $
-inherit eutils pam
+inherit eutils pam toolchain-funcs
DESCRIPTION="Concurrent Versions System - source code revision control tools"
HOMEPAGE="http://www.nongnu.org/cvs/"
@@ -36,6 +36,11 @@ src_unpack() {
}
src_compile() {
+ if tc-is-cross-compiler ; then
+ # Sane defaults when cross-compiling (as these tests want to
+ # try and execute code).
+ export cvs_cv_func_printf_ptr="yes"
+ fi
econf \
--with-external-zlib \
--with-tmpdir=/tmp \
diff --git a/dev-vcs/cvs/cvs-1.12.12-r7.ebuild b/dev-vcs/cvs/cvs-1.12.12-r7.ebuild
index 8f7b73457eb4..82595956864d 100644
--- a/dev-vcs/cvs/cvs-1.12.12-r7.ebuild
+++ b/dev-vcs/cvs/cvs-1.12.12-r7.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.12-r7.ebuild,v 1.2 2014/01/19 10:21:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.12-r7.ebuild,v 1.3 2014/01/19 10:30:16 vapier Exp $
EAPI=3
-inherit eutils pam
+inherit eutils pam toolchain-funcs
DESCRIPTION="Concurrent Versions System - source code revision control tools"
HOMEPAGE="http://www.nongnu.org/cvs/"
@@ -40,6 +40,11 @@ src_prepare() {
}
src_configure() {
+ if tc-is-cross-compiler ; then
+ # Sane defaults when cross-compiling (as these tests want to
+ # try and execute code).
+ export cvs_cv_func_printf_ptr="yes"
+ fi
econf \
--with-external-zlib \
--with-tmpdir=/tmp \
diff --git a/dev-vcs/cvs/cvs-1.12.12-r8.ebuild b/dev-vcs/cvs/cvs-1.12.12-r8.ebuild
index 7a3516042b08..437120876804 100644
--- a/dev-vcs/cvs/cvs-1.12.12-r8.ebuild
+++ b/dev-vcs/cvs/cvs-1.12.12-r8.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.12-r8.ebuild,v 1.2 2014/01/19 10:21:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.12-r8.ebuild,v 1.3 2014/01/19 10:30:16 vapier Exp $
EAPI=3
-inherit eutils pam
+inherit eutils pam toolchain-funcs
DESCRIPTION="Concurrent Versions System - source code revision control tools"
HOMEPAGE="http://www.nongnu.org/cvs/"
@@ -41,6 +41,11 @@ src_prepare() {
}
src_configure() {
+ if tc-is-cross-compiler ; then
+ # Sane defaults when cross-compiling (as these tests want to
+ # try and execute code).
+ export cvs_cv_func_printf_ptr="yes"
+ fi
econf \
--with-external-zlib \
--with-tmpdir=/tmp \
diff --git a/dev-vcs/cvs/cvs-1.12.12-r9.ebuild b/dev-vcs/cvs/cvs-1.12.12-r9.ebuild
index 85bbe931e737..c1a920da3af0 100644
--- a/dev-vcs/cvs/cvs-1.12.12-r9.ebuild
+++ b/dev-vcs/cvs/cvs-1.12.12-r9.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.12-r9.ebuild,v 1.4 2014/01/19 10:21:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.12-r9.ebuild,v 1.5 2014/01/19 10:30:16 vapier Exp $
EAPI=3
-inherit eutils pam
+inherit eutils pam toolchain-funcs
DESCRIPTION="Concurrent Versions System - source code revision control tools"
HOMEPAGE="http://www.nongnu.org/cvs/"
@@ -43,6 +43,11 @@ src_prepare() {
}
src_configure() {
+ if tc-is-cross-compiler ; then
+ # Sane defaults when cross-compiling (as these tests want to
+ # try and execute code).
+ export cvs_cv_func_printf_ptr="yes"
+ fi
econf \
--with-external-zlib \
--with-tmpdir=/tmp \
diff --git a/dev-vcs/cvs/cvs-1.12.13-r1.ebuild b/dev-vcs/cvs/cvs-1.12.13-r1.ebuild
index 0987c75119a4..86f97e292177 100644
--- a/dev-vcs/cvs/cvs-1.12.13-r1.ebuild
+++ b/dev-vcs/cvs/cvs-1.12.13-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.13-r1.ebuild,v 1.2 2014/01/19 10:21:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.13-r1.ebuild,v 1.3 2014/01/19 10:30:16 vapier Exp $
EAPI=3
-inherit eutils pam
+inherit eutils pam toolchain-funcs
DESCRIPTION="Concurrent Versions System - source code revision control tools"
HOMEPAGE="http://www.nongnu.org/cvs/"
@@ -50,6 +50,11 @@ src_configure() {
ewarn "The server and proxy code are enabled as they are required for tests."
myconf="--enable-server --enable-proxy"
fi
+ if tc-is-cross-compiler ; then
+ # Sane defaults when cross-compiling (as these tests want to
+ # try and execute code).
+ export cvs_cv_func_printf_ptr="yes"
+ fi
econf \
--with-external-zlib \
--with-tmpdir=/tmp \
diff --git a/dev-vcs/cvs/cvs-1.12.13-r2.ebuild b/dev-vcs/cvs/cvs-1.12.13-r2.ebuild
index 42ffbb45448d..54820a012219 100644
--- a/dev-vcs/cvs/cvs-1.12.13-r2.ebuild
+++ b/dev-vcs/cvs/cvs-1.12.13-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.13-r2.ebuild,v 1.2 2014/01/19 10:21:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.13-r2.ebuild,v 1.3 2014/01/19 10:30:16 vapier Exp $
EAPI=3
-inherit eutils pam
+inherit eutils pam toolchain-funcs
DESCRIPTION="Concurrent Versions System - source code revision control tools"
HOMEPAGE="http://www.nongnu.org/cvs/"
@@ -51,6 +51,11 @@ src_configure() {
ewarn "The server and proxy code are enabled as they are required for tests."
myconf="--enable-server --enable-proxy"
fi
+ if tc-is-cross-compiler ; then
+ # Sane defaults when cross-compiling (as these tests want to
+ # try and execute code).
+ export cvs_cv_func_printf_ptr="yes"
+ fi
econf \
--with-external-zlib \
--with-tmpdir=/tmp \
diff --git a/dev-vcs/cvs/cvs-1.12.13.1-r1.ebuild b/dev-vcs/cvs/cvs-1.12.13.1-r1.ebuild
index 5e3cccfbf4f0..937bf67cce16 100644
--- a/dev-vcs/cvs/cvs-1.12.13.1-r1.ebuild
+++ b/dev-vcs/cvs/cvs-1.12.13.1-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.13.1-r1.ebuild,v 1.3 2014/01/19 10:21:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.13.1-r1.ebuild,v 1.4 2014/01/19 10:30:16 vapier Exp $
EAPI=3
-inherit eutils pam versionator
+inherit eutils pam toolchain-funcs versionator
DESCRIPTION="Concurrent Versions System - source code revision control tools"
HOMEPAGE="http://www.nongnu.org/cvs/"
@@ -69,6 +69,11 @@ src_configure() {
ewarn "The server and proxy code are enabled as they are required for tests."
myconf="--enable-server --enable-proxy"
fi
+ if tc-is-cross-compiler ; then
+ # Sane defaults when cross-compiling (as these tests want to
+ # try and execute code).
+ export cvs_cv_func_printf_ptr="yes"
+ fi
econf \
--with-external-zlib \
--with-tmpdir=/tmp \
diff --git a/dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild b/dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild
index 46514b83b5b2..1dbf7262c5cb 100644
--- a/dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild
+++ b/dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild,v 1.2 2014/01/19 10:21:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild,v 1.3 2014/01/19 10:30:16 vapier Exp $
EAPI=3
-inherit eutils pam versionator
+inherit eutils pam toolchain-funcs versionator
DESCRIPTION="Concurrent Versions System - source code revision control tools"
HOMEPAGE="http://www.nongnu.org/cvs/"
@@ -70,6 +70,11 @@ src_configure() {
ewarn "The server and proxy code are enabled as they are required for tests."
myconf="--enable-server --enable-proxy"
fi
+ if tc-is-cross-compiler ; then
+ # Sane defaults when cross-compiling (as these tests want to
+ # try and execute code).
+ export cvs_cv_func_printf_ptr="yes"
+ fi
econf \
--with-external-zlib \
--with-tmpdir=/tmp \
diff --git a/dev-vcs/cvs/cvs-1.12.13.1.ebuild b/dev-vcs/cvs/cvs-1.12.13.1.ebuild
index 1234ebbb2a3d..f5b7e37bdb8d 100644
--- a/dev-vcs/cvs/cvs-1.12.13.1.ebuild
+++ b/dev-vcs/cvs/cvs-1.12.13.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.13.1.ebuild,v 1.2 2014/01/19 10:21:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.13.1.ebuild,v 1.3 2014/01/19 10:30:16 vapier Exp $
EAPI=3
-inherit eutils pam versionator
+inherit eutils pam toolchain-funcs versionator
DESCRIPTION="Concurrent Versions System - source code revision control tools"
HOMEPAGE="http://www.nongnu.org/cvs/"
@@ -66,6 +66,11 @@ src_configure() {
ewarn "The server and proxy code are enabled as they are required for tests."
myconf="--enable-server --enable-proxy"
fi
+ if tc-is-cross-compiler ; then
+ # Sane defaults when cross-compiling (as these tests want to
+ # try and execute code).
+ export cvs_cv_func_printf_ptr="yes"
+ fi
econf \
--with-external-zlib \
--with-tmpdir=/tmp \