summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-08-30 11:19:41 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-08-30 11:19:41 +0000
commit704df82dc09fa17cc6f59351615728bd14582d68 (patch)
treeae9a5374e18ac71115c88a763de5e963ea6e7b5e /dev-vcs
parentChange version scheme (diff)
downloadgentoo-2-704df82dc09fa17cc6f59351615728bd14582d68.tar.gz
gentoo-2-704df82dc09fa17cc6f59351615728bd14582d68.tar.bz2
gentoo-2-704df82dc09fa17cc6f59351615728bd14582d68.zip
Stop static libraries from being built entirely, instead of deleting them after the fact as suggested by Rafał "galtgendo" Mużyło in bug #380891. Removed old ebuild.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/subversion/ChangeLog10
-rw-r--r--dev-vcs/subversion/subversion-1.6.17-r5.ebuild (renamed from dev-vcs/subversion/subversion-1.6.17-r3.ebuild)46
2 files changed, 37 insertions, 19 deletions
diff --git a/dev-vcs/subversion/ChangeLog b/dev-vcs/subversion/ChangeLog
index 1d31f8d1cb3b..d1d18ce0be33 100644
--- a/dev-vcs/subversion/ChangeLog
+++ b/dev-vcs/subversion/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-vcs/subversion
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.54 2011/08/27 11:19:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.55 2011/08/30 11:19:41 chainsaw Exp $
+
+*subversion-1.6.17-r5 (30 Aug 2011)
+
+ 30 Aug 2011; Tony Vroon <chainsaw@gentoo.org> -subversion-1.6.17-r3.ebuild,
+ +subversion-1.6.17-r5.ebuild:
+ Stop static libraries from being built entirely, instead of deleting them
+ after the fact as suggested by Rafał "galtgendo" Mużyło in bug #380891.
+ Removed old ebuild.
27 Aug 2011; Raúl Porcel <armin76@gentoo.org> subversion-1.6.17.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #369065
diff --git a/dev-vcs/subversion/subversion-1.6.17-r3.ebuild b/dev-vcs/subversion/subversion-1.6.17-r5.ebuild
index a9d977e08715..847bb8d0bd73 100644
--- a/dev-vcs/subversion/subversion-1.6.17-r3.ebuild
+++ b/dev-vcs/subversion/subversion-1.6.17-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.6.17-r3.ebuild,v 1.2 2011/08/23 08:12:07 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.6.17-r5.ebuild,v 1.1 2011/08/30 11:19:41 chainsaw Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
@@ -62,15 +62,22 @@ want_apache
pkg_setup() {
if use berkdb; then
+ local apu_bdb_version="$(${EPREFIX}/usr/bin/apu-1-config --includes \
+ | grep -Eoe '-I${EPREFIX}/usr/include/db[[:digit:]]\.[[:digit:]]' \
+ | sed 's:.*b::')"
einfo
if [[ -z "${SVN_BDB_VERSION}" ]]; then
- SVN_BDB_VERSION="$(db_ver_to_slot "$(db_findver sys-libs/db 2>/dev/null)")"
- einfo "SVN_BDB_VERSION variable isn't set. You can set it to enforce using of specific version of Berkeley DB."
+ if [[ -n "${apu_bdb_version}" ]]; then
+ SVN_BDB_VERSION="${apu_bdb_version}"
+ einfo "Matching db version to apr-util"
+ else
+ SVN_BDB_VERSION="$(db_ver_to_slot "$(db_findver sys-libs/db 2>/dev/null)")"
+ einfo "SVN_BDB_VERSION variable isn't set. You can set it to enforce using of specific version of Berkeley DB."
+ fi
fi
einfo "Using: Berkeley DB ${SVN_BDB_VERSION}"
einfo
- local apu_bdb_version="$(scanelf -nq "${EROOT}usr/$(get_libdir)/libaprutil-1.so.0" | grep -Eo "libdb-[[:digit:]]+\.[[:digit:]]+" | sed -e "s/libdb-\(.*\)/\1/")"
if [[ -n "${apu_bdb_version}" && "${SVN_BDB_VERSION}" != "${apu_bdb_version}" ]]; then
eerror "APR-Util is linked against Berkeley DB ${apu_bdb_version}, but you are trying"
eerror "to build Subversion with support for Berkeley DB ${SVN_BDB_VERSION}."
@@ -159,6 +166,7 @@ src_configure() {
--enable-local-library-preloading \
--disable-mod-activation \
--disable-neon-version-check \
+ --disable-static \
--with-sqlite="${EPREFIX}/usr"
}
@@ -199,7 +207,7 @@ src_compile() {
fi
if use perl; then
- emake -j1 swig-pl || die "Building of Subversion SWIG Perl bindings failed"
+ emake swig-pl || die "Building of Subversion SWIG Perl bindings failed"
fi
if use ruby; then
@@ -247,7 +255,7 @@ src_install() {
swig_python_bindings_installation() {
rm -f subversion/bindings/swig/python
ln -s python-${PYTHON_ABI} subversion/bindings/swig/python
- emake -j1 \
+ emake \
DESTDIR="${D}" \
PYTHON_VERSION="$(python_get_version)" \
swig_pydir="${EPREFIX}$(python_get_sitedir)/libsvn" \
@@ -265,17 +273,17 @@ src_install() {
fi
if use perl; then
- emake -j1 DESTDIR="${D}" INSTALLDIRS="vendor" install-swig-pl || die "Installation of Subversion SWIG Perl bindings failed"
+ emake DESTDIR="${D}" INSTALLDIRS="vendor" install-swig-pl || die "Installation of Subversion SWIG Perl bindings failed"
fixlocalpod
find "${ED}" "(" -name .packlist -o -name "*.bs" ")" -print0 | xargs -0 rm -fr
fi
if use ruby; then
- emake -j1 DESTDIR="${D}" install-swig-rb || die "Installation of Subversion SWIG Ruby bindings failed"
+ emake DESTDIR="${D}" install-swig-rb || die "Installation of Subversion SWIG Ruby bindings failed"
fi
if use java; then
- emake -j1 DESTDIR="${D}" install-javahl || die "Installation of Subversion JavaHL library failed"
+ emake DESTDIR="${D}" install-javahl || die "Installation of Subversion JavaHL library failed"
java-pkg_regso "${ED}"usr/$(get_libdir)/libsvnjavahl*.so
java-pkg_dojar "${ED}"usr/$(get_libdir)/svn-javahl/svn-javahl.jar
rm -fr "${ED}"usr/$(get_libdir)/svn-javahl/*.jar
@@ -361,7 +369,7 @@ EOF
fi
fi
- find "${D}" '(' -name '*.la' -o -name '*.a' ')' -print0 | xargs -0 rm -f
+ find "${D}" '(' -name '*.la' ')' -print0 | xargs -0 rm -f
}
pkg_preinst() {
@@ -421,16 +429,18 @@ pkg_postrm() {
}
pkg_config() {
- einfo "Initializing the database in ${EROOT}${SVN_REPOS_LOC}..."
- if [[ -e "${EROOT}${SVN_REPOS_LOC}/repos" ]]; then
+ # Remember: Don't use ${EROOT}${SVN_REPOS_LOC} since ${SVN_REPOS_LOC}
+ # already has EPREFIX in it
+ einfo "Initializing the database in ${ROOT}${SVN_REPOS_LOC}..."
+ if [[ -e "${ROOT}${SVN_REPOS_LOC}/repos" ]]; then
echo "A Subversion repository already exists and I will not overwrite it."
- echo "Delete \"${EROOT}${SVN_REPOS_LOC}/repos\" first if you're sure you want to have a clean version."
+ echo "Delete \"${ROOT}${SVN_REPOS_LOC}/repos\" first if you're sure you want to have a clean version."
else
- mkdir -p "${EROOT}${SVN_REPOS_LOC}/conf"
+ mkdir -p "${ROOT}${SVN_REPOS_LOC}/conf"
einfo "Populating repository directory..."
# Create initial repository.
- "${EROOT}usr/bin/svnadmin" create "${EROOT}${SVN_REPOS_LOC}/repos"
+ "${EROOT}usr/bin/svnadmin" create "${ROOT}${SVN_REPOS_LOC}/repos"
einfo "Setting repository permissions..."
SVNSERVE_USER="$(. "${EROOT}etc/conf.d/svnserve"; echo "${SVNSERVE_USER}")"
@@ -444,8 +454,8 @@ pkg_config() {
enewgroup "${SVNSERVE_GROUP}"
enewuser "${SVNSERVE_USER}" -1 -1 "${SVN_REPOS_LOC}" "${SVNSERVE_GROUP}"
fi
- chown -Rf "${SVNSERVE_USER}:${SVNSERVE_GROUP}" "${EROOT}${SVN_REPOS_LOC}/repos"
- chmod -Rf go-rwx "${EROOT}${SVN_REPOS_LOC}/conf"
- chmod -Rf o-rwx "${EROOT}${SVN_REPOS_LOC}/repos"
+ chown -Rf "${SVNSERVE_USER}:${SVNSERVE_GROUP}" "${ROOT}${SVN_REPOS_LOC}/repos"
+ chmod -Rf go-rwx "${ROOT}${SVN_REPOS_LOC}/conf"
+ chmod -Rf o-rwx "${ROOT}${SVN_REPOS_LOC}/repos"
fi
}