summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2013-05-18 13:48:38 +0000
committerFabio Erculiani <lxnay@gentoo.org>2013-05-18 13:48:38 +0000
commit3311ddd5cbbc6f63c750707d044a4a39fd27bce8 (patch)
tree19492630175ed4e3780fdb226a5d2b58715061ec /dev-vcs
parentbump (diff)
downloadgentoo-2-3311ddd5cbbc6f63c750707d044a4a39fd27bce8.tar.gz
gentoo-2-3311ddd5cbbc6f63c750707d044a4a39fd27bce8.tar.bz2
gentoo-2-3311ddd5cbbc6f63c750707d044a4a39fd27bce8.zip
add systemd unit supporting socket activation to 1.8.21 and 9999, fix bug #468846
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/ChangeLog7
-rw-r--r--dev-vcs/git/files/git-daemon.socket9
-rw-r--r--dev-vcs/git/files/git-daemon_at.service13
-rw-r--r--dev-vcs/git/git-1.8.2.1.ebuild6
-rw-r--r--dev-vcs/git/git-9999.ebuild6
5 files changed, 36 insertions, 5 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index 0ed3caccbabb..ebd0eb4767c6 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.199 2013/04/19 13:38:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.200 2013/05/18 13:48:37 lxnay Exp $
+
+ 18 May 2013; Fabio Erculiani <lxnay@gentoo.org> git-1.8.2.1.ebuild,
+ git-9999.ebuild, +files/git-daemon.socket, +files/git-daemon_at.service:
+ add systemd unit supporting socket activation to 1.8.21 and 9999, fix bug
+ #468846
19 Apr 2013; Mike Frysinger <vapier@gentoo.org> git-1.8.2.1.ebuild:
Add missing pthreads linkage for svn-fe #466178 by Mike Gilbert.
diff --git a/dev-vcs/git/files/git-daemon.socket b/dev-vcs/git/files/git-daemon.socket
new file mode 100644
index 000000000000..3dec01d21653
--- /dev/null
+++ b/dev-vcs/git/files/git-daemon.socket
@@ -0,0 +1,9 @@
+[Unit]
+Description=Git Activation Socket
+
+[Socket]
+ListenStream=9418
+Accept=true
+
+[Install]
+WantedBy=sockets.target
diff --git a/dev-vcs/git/files/git-daemon_at.service b/dev-vcs/git/files/git-daemon_at.service
new file mode 100644
index 000000000000..2a080d4e7d8f
--- /dev/null
+++ b/dev-vcs/git/files/git-daemon_at.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Git Repositories Server Daemon
+Documentation=man:git-daemon(1)
+
+[Service]
+User=nobody
+Group=nobody
+EnvironmentFile=/etc/conf.d/git-daemon
+# Ignore non-zero exit status, access error makes git-daemon return them
+ExecStart=-/usr/libexec/git-core/git-daemon --inetd --base-path=/var/git --verbose $GITDAEMON_OPTS
+StandardInput=socket
+StandardOutput=inherit
+StandardError=journal
diff --git a/dev-vcs/git/git-1.8.2.1.ebuild b/dev-vcs/git/git-1.8.2.1.ebuild
index 6be08118e88e..f0aa42e3500e 100644
--- a/dev-vcs/git/git-1.8.2.1.ebuild
+++ b/dev-vcs/git/git-1.8.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.8.2.1.ebuild,v 1.3 2013/04/19 13:38:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.8.2.1.ebuild,v 1.4 2013/05/18 13:48:37 lxnay Exp $
EAPI=4
@@ -11,7 +11,7 @@ PYTHON_DEPEND="python? 2"
[[ ${PV} == *9999 ]] && SCM="git-2"
EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
-inherit toolchain-funcs eutils elisp-common perl-module bash-completion-r1 python ${SCM}
+inherit toolchain-funcs eutils elisp-common perl-module bash-completion-r1 python systemd ${SCM}
MY_PV="${PV/_rc/.rc}"
MY_P="${PN}-${MY_PV}"
@@ -480,6 +480,8 @@ src_install() {
if use !prefix ; then
newinitd "${FILESDIR}"/git-daemon.initd git-daemon
newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+ systemd_newunit "${FILESDIR}/git-daemon_at.service" "git-daemon@.service"
+ systemd_dounit "${FILESDIR}/git-daemon.socket"
fi
fixlocalpod
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 341c2cffd3a7..5ff1e04b0965 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.41 2013/02/22 17:57:16 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.42 2013/05/18 13:48:38 lxnay Exp $
EAPI=4
@@ -11,7 +11,7 @@ PYTHON_DEPEND="python? 2"
[[ ${PV} == *9999 ]] && SCM="git-2"
EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
-inherit toolchain-funcs eutils elisp-common perl-module bash-completion-r1 python ${SCM}
+inherit toolchain-funcs eutils elisp-common perl-module bash-completion-r1 python systemd ${SCM}
MY_PV="${PV/_rc/.rc}"
MY_P="${PN}-${MY_PV}"
@@ -470,6 +470,8 @@ src_install() {
newinitd "${FILESDIR}"/git-daemon.initd git-daemon
newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+ systemd_newunit "${FILESDIR}/git-daemon_at.service" "git-daemon@.service"
+ systemd_dounit "${FILESDIR}/git-daemon.socket"
fixlocalpod
}