summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-04-13 08:32:27 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-04-13 08:32:27 +0000
commit2034a0a58fba6ff41f0bc975930869b4ca5a18ca (patch)
treef65a37b6e7a505c67a84a47db705b64bfa19a566 /dev-vcs
parentStable for alpha, wrt bug #545204 (diff)
downloadgentoo-2-2034a0a58fba6ff41f0bc975930869b4ca5a18ca.tar.gz
gentoo-2-2034a0a58fba6ff41f0bc975930869b4ca5a18ca.tar.bz2
gentoo-2-2034a0a58fba6ff41f0bc975930869b4ca5a18ca.zip
Fix dependency for swig
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/subversion/ChangeLog8
-rw-r--r--dev-vcs/subversion/subversion-1.8.13.ebuild9
2 files changed, 13 insertions, 4 deletions
diff --git a/dev-vcs/subversion/ChangeLog b/dev-vcs/subversion/ChangeLog
index e83c8c415ca9..691f3b708909 100644
--- a/dev-vcs/subversion/ChangeLog
+++ b/dev-vcs/subversion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/subversion
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.223 2015/04/09 12:58:45 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.224 2015/04/13 08:32:27 polynomial-c Exp $
+
+ 13 Apr 2015; Lars Wendler <polynomial-c@gentoo.org> subversion-1.8.13.ebuild:
+ Fix dependency for swig.
+
+ 13 Apr 2015; Lars Wendler <polynomial-c@gentoo.org> subversion-1.8.13.ebuild:
+ Added dev-lang/swig to DEPEND.
*subversion-1.8.13 (09 Apr 2015)
diff --git a/dev-vcs/subversion/subversion-1.8.13.ebuild b/dev-vcs/subversion/subversion-1.8.13.ebuild
index 3dee077dcb07..8f983e9f3c85 100644
--- a/dev-vcs/subversion/subversion-1.8.13.ebuild
+++ b/dev-vcs/subversion/subversion-1.8.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.8.13.ebuild,v 1.1 2015/04/09 12:58:45 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.8.13.ebuild,v 1.2 2015/04/13 08:32:27 polynomial-c Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -46,15 +46,18 @@ RDEPEND="${COMMON_DEPEND}
perl? ( dev-perl/URI )"
# Note: ctypesgen doesn't need PYTHON_USEDEP, it's used once
DEPEND="${COMMON_DEPEND}
- test? ( ${PYTHON_DEPS} )
!!<sys-apps/sandbox-1.6
ctypes-python? ( dev-python/ctypesgen )
doc? ( app-doc/doxygen )
gnome-keyring? ( virtual/pkgconfig )
+ http? ( virtual/pkgconfig )
java? ( >=virtual/jdk-1.5 )
kde? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
- http? ( virtual/pkgconfig )"
+ perl? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+ ruby? ( dev-lang/swig )
+ test? ( ${PYTHON_DEPS} )"
REQUIRED_USE="
ctypes-python? ( ${PYTHON_REQUIRED_USE} )