summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-07-29 07:45:09 +0000
committerJustin Lecher <jlec@gentoo.org>2015-07-29 07:45:09 +0000
commit05b532b1d4cbd2b487a039c56204e90cdd3b6d47 (patch)
treeba4ad25ab0df6ff1c7f118b78e1ad9f72b114923 /dev-vcs
parentDrop obsolete patches (diff)
downloadgentoo-2-05b532b1d4cbd2b487a039c56204e90cdd3b6d47.tar.gz
gentoo-2-05b532b1d4cbd2b487a039c56204e90cdd3b6d47.tar.bz2
gentoo-2-05b532b1d4cbd2b487a039c56204e90cdd3b6d47.zip
Version Bump, bug #554456; thanks Coacher for all the work
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-cola/ChangeLog10
-rw-r--r--dev-vcs/git-cola/files/git-cola-2.2.1-disable-live-tests.patch22
-rw-r--r--dev-vcs/git-cola/files/git-cola-2.2.1-update-git-config-in-tests.patch13
-rw-r--r--dev-vcs/git-cola/git-cola-2.2.1.ebuild98
4 files changed, 142 insertions, 1 deletions
diff --git a/dev-vcs/git-cola/ChangeLog b/dev-vcs/git-cola/ChangeLog
index ec2db4121739..333ba5ca07d1 100644
--- a/dev-vcs/git-cola/ChangeLog
+++ b/dev-vcs/git-cola/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-vcs/git-cola
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.49 2015/05/27 17:00:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.50 2015/07/29 07:45:09 jlec Exp $
+
+*git-cola-2.2.1 (29 Jul 2015)
+
+ 29 Jul 2015; Justin Lecher <jlec@gentoo.org>
+ +files/git-cola-2.2.1-disable-live-tests.patch,
+ +files/git-cola-2.2.1-update-git-config-in-tests.patch,
+ +git-cola-2.2.1.ebuild:
+ Version Bump, bug #554456; thanks Coacher for all the work
27 May 2015; Justin Lecher <jlec@gentoo.org> -files/1.3.8-disable-tests.patch,
-files/1.8.1-system-ssh-askpass.patch, -files/1.9.1-disable-tests.patch:
diff --git a/dev-vcs/git-cola/files/git-cola-2.2.1-disable-live-tests.patch b/dev-vcs/git-cola/files/git-cola-2.2.1-disable-live-tests.patch
new file mode 100644
index 000000000000..2ebdc9880d1e
--- /dev/null
+++ b/dev-vcs/git-cola/files/git-cola-2.2.1-disable-live-tests.patch
@@ -0,0 +1,22 @@
+diff --git a/test/git_test.py b/test/git_test.py
+index 9f812b2..ff7da24 100644
+--- a/test/git_test.py
++++ b/test/git_test.py
+@@ -53,17 +53,6 @@ class GitCommandTest(unittest.TestCase):
+ version = self.git.version()[STDOUT]
+ self.failUnless(version.startswith('git version'))
+
+- def test_tag(self):
+- """Test running 'git tag'"""
+- tags = self.git.tag()[STDOUT].splitlines()
+- self.failUnless( 'v1.0.0' in tags )
+-
+- def test_show(self):
+- """Test running 'git show'"""
+- sha = '1b9742bda5d26a4f250fa64657f66ed20624a084'
+- contents = self.git.show(sha)[STDOUT].splitlines()
+- self.failUnless(contents[0] == '/build')
+-
+ def test_stdout(self):
+ """Test overflowing the stdout buffer"""
+ # Write to stdout only
diff --git a/dev-vcs/git-cola/files/git-cola-2.2.1-update-git-config-in-tests.patch b/dev-vcs/git-cola/files/git-cola-2.2.1-update-git-config-in-tests.patch
new file mode 100644
index 000000000000..96271d05548c
--- /dev/null
+++ b/dev-vcs/git-cola/files/git-cola-2.2.1-update-git-config-in-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/test/helper.py b/test/helper.py
+index 006a5b1..64d0dfc 100644
+--- a/test/helper.py
++++ b/test/helper.py
+@@ -87,6 +87,8 @@ class GitRepositoryTestCase(TmpPathTestCase):
+
+ def initialize_repo(self):
+ self.git('init')
++ self.git('config', '--local', 'user.name', 'Your Name')
++ self.git('config', '--local', 'user.email', 'you@example.com')
+ self.touch('A', 'B')
+ self.git('add', 'A', 'B')
+
diff --git a/dev-vcs/git-cola/git-cola-2.2.1.ebuild b/dev-vcs/git-cola/git-cola-2.2.1.ebuild
new file mode 100644
index 000000000000..f1b7c316bfcc
--- /dev/null
+++ b/dev-vcs/git-cola/git-cola-2.2.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-2.2.1.ebuild,v 1.1 2015/07/29 07:45:09 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+DISTUTILS_SINGLE_IMPL=true
+
+inherit distutils-r1 readme.gentoo virtualx
+
+DESCRIPTION="The highly caffeinated git GUI"
+HOMEPAGE="https://git-cola.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-vcs/git"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ python_targets_python2_7? ( dev-python/sphinxtogithub[$(python_gen_usedep 'python2*')] )
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-disable-live-tests.patch
+ "${FILESDIR}"/${P}-update-git-config-in-tests.patch
+)
+
+python_prepare_all() {
+ rm share/git-cola/bin/*askpass* || die
+
+ # remove broken tests
+ rm test/i18n_test.py || die
+
+ # don't install docs into wrong location
+ sed -i -e '/doc/d' setup.py || die
+
+ # fix doc directory reference
+ sed -i \
+ -e "s/'doc', 'git-cola'/'doc', '${PF}'/" \
+ cola/resources.py || die
+
+ # fix ssh-askpass directory reference
+ sed -i -e 's/resources\.share/resources\.prefix/' cola/app.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ cd share/doc/${PN}/ || die
+ if use doc; then
+ emake all
+ else
+ sed \
+ -e '/^install:/s:install-html::g' \
+ -e '/^install:/s:install-man::g' \
+ -i Makefile || die
+ fi
+}
+
+python_test() {
+ PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" \
+ VIRTUALX_COMMAND="nosetests --verbose --with-id --with-doctest \
+ --exclude=sphinxtogithub" \
+ virtualmake
+}
+
+src_install() {
+ distutils-r1_src_install
+}
+
+python_install_all() {
+ cd share/doc/${PN}/ || die
+ emake \
+ DESTDIR="${D}" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ prefix="${EPREFIX}/usr" \
+ install
+
+ python_fix_shebang "${ED}/usr/share/git-cola/bin/git-xbase"
+ python_optimize "${ED}/usr/share/git-cola/lib/cola"
+
+ use doc || HTML_DOCS=( "${FILESDIR}"/index.html )
+
+ distutils-r1_python_install_all
+ readme.gentoo_create_doc
+}