summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-11-10 11:28:22 +0000
committerSebastian Pipping <sping@gentoo.org>2011-11-10 11:28:22 +0000
commit800566626c1cb0bda87801bd7c022269ca98a3b5 (patch)
tree61517b387325222f3fae8b54241e855fc755e6df /dev-vcs/svn2git
parenthttp://my.opera.com/desktopteam/blog/2011/11/10/tunny-beta (diff)
downloadgentoo-2-800566626c1cb0bda87801bd7c022269ca98a3b5.tar.gz
gentoo-2-800566626c1cb0bda87801bd7c022269ca98a3b5.tar.bz2
gentoo-2-800566626c1cb0bda87801bd7c022269ca98a3b5.zip
dev-vcs/svn2git: Bump to 1.0.5
(Portage version: 2.1.10.32/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/svn2git')
-rw-r--r--dev-vcs/svn2git/ChangeLog8
-rw-r--r--dev-vcs/svn2git/files/svn2git-1.0.5-version.patch14
-rw-r--r--dev-vcs/svn2git/svn2git-1.0.5.ebuild47
-rw-r--r--dev-vcs/svn2git/svn2git-9999.ebuild4
4 files changed, 70 insertions, 3 deletions
diff --git a/dev-vcs/svn2git/ChangeLog b/dev-vcs/svn2git/ChangeLog
index 4767b8e0946f..6841f28067b4 100644
--- a/dev-vcs/svn2git/ChangeLog
+++ b/dev-vcs/svn2git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/svn2git
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/ChangeLog,v 1.13 2011/09/21 08:30:34 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/ChangeLog,v 1.14 2011/11/10 11:28:22 sping Exp $
+
+*svn2git-1.0.5 (10 Nov 2011)
+
+ 10 Nov 2011; Sebastian Pipping <sping@gentoo.org> +svn2git-1.0.5.ebuild,
+ +files/svn2git-1.0.5-version.patch, svn2git-9999.ebuild:
+ Bump to 1.0.5, looks trivial
21 Sep 2011; Michał Górny <mgorny@gentoo.org> svn2git-9999.ebuild:
Migrate to git-2.
diff --git a/dev-vcs/svn2git/files/svn2git-1.0.5-version.patch b/dev-vcs/svn2git/files/svn2git-1.0.5-version.patch
new file mode 100644
index 000000000000..7247f4b96e7a
--- /dev/null
+++ b/dev-vcs/svn2git/files/svn2git-1.0.5-version.patch
@@ -0,0 +1,14 @@
+--- src/src.pro 2011-01-11 09:27:21.530166986 +0100
++++ src/src.pro 2011-01-11 09:30:55.743128934 +0100
+@@ -7,10 +7,7 @@
+ APR_INCLUDE = /usr/include/apr-1
+ exists(local-config.pri):include(local-config.pri)
+
+-VERSION = $$system(git --no-pager show --pretty=oneline --no-notes | head -1 | cut -b-40)
+- !isEmpty(VERSION){
+- VERSION = $${VERSION}
+- }
++VERSION = "1.0.5"
+
+ VERSTR = '\\"$${VERSION}\\"' # place quotes around the version string
+ DEFINES += VER=\"$${VERSTR}\" # create a VER macro containing the version string
diff --git a/dev-vcs/svn2git/svn2git-1.0.5.ebuild b/dev-vcs/svn2git/svn2git-1.0.5.ebuild
new file mode 100644
index 000000000000..b931f36cbc6f
--- /dev/null
+++ b/dev-vcs/svn2git/svn2git-1.0.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-1.0.5.ebuild,v 1.1 2011/11/10 11:28:22 sping Exp $
+
+EAPI="2"
+
+inherit eutils qt4-r2
+[ "$PV" == "9999" ] && inherit git
+
+DESCRIPTION="Tool for one-time conversion from svn to git."
+HOMEPAGE="http://gitorious.org/svn2git/svn2git"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="git://gitorious.org/svn2git/svn2git.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://gitorious.org/${PN}/${PN}/archive-tarball/${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+# KEYWORDS way up
+
+DEPEND="dev-vcs/subversion
+ x11-libs/qt-core"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+S=${WORKDIR}/${PN}-${PN}
+
+src_prepare() {
+ # Note: patching order matters
+ epatch "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch
+ if [[ "$PV" != "9999" ]]; then
+ epatch "${FILESDIR}"/${P}-version.patch
+ fi
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ insinto /usr/share/${PN}/samples
+ doins samples/*.rules || die 'doins failed'
+ dobin svn-all-fast-export || die 'dobin failed'
+ dosym svn-all-fast-export /usr/bin/svn2git || die 'dosym failed'
+}
diff --git a/dev-vcs/svn2git/svn2git-9999.ebuild b/dev-vcs/svn2git/svn2git-9999.ebuild
index 8f3eba1e6d38..a4b6ebeb6705 100644
--- a/dev-vcs/svn2git/svn2git-9999.ebuild
+++ b/dev-vcs/svn2git/svn2git-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-9999.ebuild,v 1.7 2011/09/21 08:30:34 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-9999.ebuild,v 1.8 2011/11/10 11:28:22 sping Exp $
EAPI="2"
@@ -34,7 +34,7 @@ src_prepare() {
# Note: patching order matters
epatch "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch
if [[ "$PV" != "9999" ]]; then
- epatch "${FILESDIR}"/${PN}-1.0.4-version.patch
+ epatch "${FILESDIR}"/${P}-version.patch
fi
qt4-r2_src_prepare