summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-04 12:32:40 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-04 12:32:40 +0000
commit7a1ee775894917ca8ff539113e28b0a531e959a2 (patch)
treef15488349c7afd739d9c76a21a379ea081621828 /dev-vcs/rapidsvn
parentUpstream moved tarball for 2.4.1 (diff)
downloadgentoo-2-7a1ee775894917ca8ff539113e28b0a531e959a2.tar.gz
gentoo-2-7a1ee775894917ca8ff539113e28b0a531e959a2.tar.bz2
gentoo-2-7a1ee775894917ca8ff539113e28b0a531e959a2.zip
dev-vcs/rapidsvn: Snapshot of svn to add a version compatible with svn-1.7*, #398777
(Portage version: 2.2.0_alpha109/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/rapidsvn')
-rw-r--r--dev-vcs/rapidsvn/ChangeLog8
-rw-r--r--dev-vcs/rapidsvn/files/rapidsvn-0.12.1_pre8247-svncpp_link.patch12
-rw-r--r--dev-vcs/rapidsvn/rapidsvn-0.12.1_pre8247.ebuild93
3 files changed, 112 insertions, 1 deletions
diff --git a/dev-vcs/rapidsvn/ChangeLog b/dev-vcs/rapidsvn/ChangeLog
index b5bac37964a6..bbbb729b7155 100644
--- a/dev-vcs/rapidsvn/ChangeLog
+++ b/dev-vcs/rapidsvn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/rapidsvn
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/rapidsvn/ChangeLog,v 1.10 2012/05/21 20:03:34 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/rapidsvn/ChangeLog,v 1.11 2012/06/04 12:32:40 jlec Exp $
+
+*rapidsvn-0.12.1_pre8247 (04 Jun 2012)
+
+ 04 Jun 2012; Justin Lecher <jlec@gentoo.org> +rapidsvn-0.12.1_pre8247.ebuild,
+ +files/rapidsvn-0.12.1_pre8247-svncpp_link.patch:
+ Snapshot of svn to add a version compatible with svn-1.7*, #398777
21 May 2012; Samuli Suominen <ssuominen@gentoo.org> rapidsvn-0.12.0.ebuild:
inherit eutils for make_desktop_entry
diff --git a/dev-vcs/rapidsvn/files/rapidsvn-0.12.1_pre8247-svncpp_link.patch b/dev-vcs/rapidsvn/files/rapidsvn-0.12.1_pre8247-svncpp_link.patch
new file mode 100644
index 000000000000..da858583670d
--- /dev/null
+++ b/dev-vcs/rapidsvn/files/rapidsvn-0.12.1_pre8247-svncpp_link.patch
@@ -0,0 +1,12 @@
+Index: src/svncpp/Makefile.am
+===================================================================
+--- libsvncpp/Makefile.am
++++ libsvncpp/Makefile.am
+@@ -27,3 +27,7 @@
+ url.cpp \
+ wc.cpp
+
++libsvncpp_la_LIBADD= $(SVN_LIBS) \
++ $(NEON_LIBS) \
++ $(APR_LIBS) \
++ -lstdc++
diff --git a/dev-vcs/rapidsvn/rapidsvn-0.12.1_pre8247.ebuild b/dev-vcs/rapidsvn/rapidsvn-0.12.1_pre8247.ebuild
new file mode 100644
index 000000000000..12fd5fa68d22
--- /dev/null
+++ b/dev-vcs/rapidsvn/rapidsvn-0.12.1_pre8247.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/rapidsvn/rapidsvn-0.12.1_pre8247.ebuild,v 1.1 2012/06/04 12:32:40 jlec Exp $
+
+EAPI=4
+
+WANT_AUTOCONF="2.5"
+WX_GTK_VER=2.8
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils fdo-mime flag-o-matic libtool versionator wxwidgets
+
+MY_PV=$(get_version_component_range 1-2)
+MY_REL="1"
+
+DESCRIPTION="Cross-platform GUI front-end for the Subversion revision system"
+HOMEPAGE="http://rapidsvn.tigris.org/"
+#SRC_URI="http://www.rapidsvn.org/download/release/${MY_PV}/${P}-${MY_REL}.tar.gz"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+COMMON_DEP="
+ dev-libs/apr
+ dev-libs/apr-util
+ dev-vcs/subversion
+ x11-libs/wxGTK:2.8[X]"
+DEPEND="${COMMON_DEP}
+ doc? (
+ dev-libs/libxslt
+ app-text/docbook-sgml-utils
+ app-doc/doxygen
+ app-text/docbook-xsl-stylesheets )"
+RDEPEND="${COMMON_DEP}"
+
+#S="${WORKDIR}/${P}-${MY_REL}"
+
+PATCHES=( "${FILESDIR}/${P}-svncpp_link.patch" )
+AUTOTOOLS_IN_SOURCE_BUILD=1
+DOCS=( HACKING.txt TRANSLATIONS )
+
+pkg_setup() {
+ wxwidgets_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=( --with-wx-config=${WX_CONFIG} )
+
+ if use doc; then
+ myeconfargs+=( --with-manpage=yes )
+ else
+ myeconfargs+=(
+ --without-xsltproc
+ --with-manpage=no
+ --without-doxygen
+ --without-dot )
+ fi
+
+ append-flags $( "${EPREFIX}"/usr/bin/apr-1-config --cppflags )
+
+ myeconfargs+=(
+ --with-svn-lib="${EPREFIX}"/usr/$(get_libdir)
+ --with-svn-include="${EPREFIX}"/usr/include
+ --with-apr-config="${EPREFIX}/usr/bin/apr-1-config"
+ --with-apu-config="${EPREFIX}/usr/bin/apu-1-config"
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ doicon src/res/rapidsvn.ico
+ make_desktop_entry rapidsvn "RapidSVN ${PV}" \
+ "${EPREFIX}/usr/share/pixmaps/rapidsvn.ico" \
+ "RevisionControl;Development"
+
+ if use doc ; then
+ dohtml "${S}"/doc/svncpp/html/*
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}