summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-01-26 21:06:09 +0000
committerJohannes Huber <johu@gentoo.org>2015-01-26 21:06:09 +0000
commit2e3819f17e75775327e1c097685d2e6904fbe667 (patch)
tree723a42091b331b4459a72e6431a887c6d357f7a2 /dev-vcs/git-flow
parentVersion bump (diff)
downloadgentoo-2-2e3819f17e75775327e1c097685d2e6904fbe667.tar.gz
gentoo-2-2e3819f17e75775327e1c097685d2e6904fbe667.tar.bz2
gentoo-2-2e3819f17e75775327e1c097685d2e6904fbe667.zip
Version bump, switch to active fork project, bug #537870. Thanks to Jochen Radmacher <jradmacher@gmx.de>.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'dev-vcs/git-flow')
-rw-r--r--dev-vcs/git-flow/ChangeLog12
-rw-r--r--dev-vcs/git-flow/files/git-flow-1.8.0-unbundle-shflags.patch25
-rw-r--r--dev-vcs/git-flow/git-flow-1.8.0.ebuild51
-rw-r--r--dev-vcs/git-flow/metadata.xml2
4 files changed, 87 insertions, 3 deletions
diff --git a/dev-vcs/git-flow/ChangeLog b/dev-vcs/git-flow/ChangeLog
index 4f53eee798c7..806160ef0d66 100644
--- a/dev-vcs/git-flow/ChangeLog
+++ b/dev-vcs/git-flow/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-vcs/git-flow
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-flow/ChangeLog,v 1.3 2014/08/15 19:58:26 johu Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-flow/ChangeLog,v 1.4 2015/01/26 21:06:09 johu Exp $
+
+*git-flow-1.8.0 (26 Jan 2015)
+
+ 26 Jan 2015; Johannes Huber <johu@gentoo.org>
+ +files/git-flow-1.8.0-unbundle-shflags.patch, +git-flow-1.8.0.ebuild,
+ metadata.xml:
+ Version bump, switch to active fork project, bug #537870. Thanks to Jochen
+ Radmacher <jradmacher@gmx.de>.
15 Aug 2014; Johannes Huber <johu@gentoo.org> git-flow-0.4.1.ebuild:
amd64 stable, bug #518412
diff --git a/dev-vcs/git-flow/files/git-flow-1.8.0-unbundle-shflags.patch b/dev-vcs/git-flow/files/git-flow-1.8.0-unbundle-shflags.patch
new file mode 100644
index 000000000000..6e96d541d411
--- /dev/null
+++ b/dev-vcs/git-flow/files/git-flow-1.8.0-unbundle-shflags.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile b/Makefile
+index 0718bbb..f488922 100644
+--- a/Makefile
++++ b/Makefile
+@@ -43,7 +43,6 @@ SCRIPT_FILES+=git-flow-version
+ SCRIPT_FILES+=git-flow-log
+ SCRIPT_FILES+=git-flow-config
+ SCRIPT_FILES+=gitflow-common
+-SCRIPT_FILES+=gitflow-shFlags
+
+ # Hook files
+ HOOK_FILES=$(wildcard hooks/*)
+diff --git a/git-flow b/git-flow
+index 7a962d2..2ba70ba 100755
+--- a/git-flow
++++ b/git-flow
+@@ -111,7 +111,7 @@ main() {
+ fi
+
+ # Use the shFlags project to parse the command line arguments
+- . "$GITFLOW_DIR/gitflow-shFlags"
++ . /usr/share/misc/shflags
+ FLAGS_PARENT="git flow"
+
+ # Load common functionality
diff --git a/dev-vcs/git-flow/git-flow-1.8.0.ebuild b/dev-vcs/git-flow/git-flow-1.8.0.ebuild
new file mode 100644
index 000000000000..c2e896fdaf05
--- /dev/null
+++ b/dev-vcs/git-flow/git-flow-1.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-flow/git-flow-1.8.0.ebuild,v 1.1 2015/01/26 21:06:09 johu Exp $
+
+EAPI=5
+
+MY_PN="${PN/-/}"
+COMP_PN="${PN}-completion"
+COMP_PV="0.5.1"
+COMP_P="${COMP_PN}-${COMP_PV}"
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Git extensions to provide high-level repository operations for Vincent Driessen's branching model"
+HOMEPAGE="https://github.com/petervanderdoes/gitflow"
+SRC_URI="https://github.com/petervanderdoes/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/petervanderdoes/${COMP_PN}/archive/${COMP_PV}.tar.gz -> ${COMP_P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-util/shflags
+ dev-vcs/git
+"
+
+DOCS=( AUTHORS Changes.mdown README.mdown )
+
+PATCHES=( "${FILESDIR}/${P}-unbundle-shflags.patch" )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ [[ ${PATCHES[@]} ]] && epatch "${PATCHES[@]}"
+ debug-print "$FUNCNAME: applying user patches"
+ epatch_user
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ emake prefix="${D}/usr" install
+
+ [[ ${DOCS[@]} ]] && dodoc "${DOCS[@]}"
+
+ newbashcomp "${WORKDIR}/${COMP_P}/${COMP_PN}.bash" ${PN}
+}
diff --git a/dev-vcs/git-flow/metadata.xml b/dev-vcs/git-flow/metadata.xml
index 4f5a42ecea3d..b0bdac33b655 100644
--- a/dev-vcs/git-flow/metadata.xml
+++ b/dev-vcs/git-flow/metadata.xml
@@ -6,6 +6,6 @@
<name>Johannes Huber</name>
</maintainer>
<upstream>
- <remote-id type="github">nvie/gitflow</remote-id>
+ <remote-id type="github">petervanderdoes/gitflow</remote-id>
</upstream>
</pkgmetadata>