summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-12-13 14:19:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-12-13 14:19:53 +0000
commit72ec25606d9e7452baa98628dd300a0345a1a5c2 (patch)
tree54a8f90b4a33bc8396edccbd5d80abe18e9abad8 /dev-vcs/fossil
parentStable for HPPA (bug #493850). (diff)
downloadgentoo-2-72ec25606d9e7452baa98628dd300a0345a1a5c2.tar.gz
gentoo-2-72ec25606d9e7452baa98628dd300a0345a1a5c2.tar.bz2
gentoo-2-72ec25606d9e7452baa98628dd300a0345a1a5c2.zip
non-maintainer version bump per rafaelmartins
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-vcs/fossil')
-rw-r--r--dev-vcs/fossil/ChangeLog8
-rw-r--r--dev-vcs/fossil/fossil-20130911114349.ebuild46
-rw-r--r--dev-vcs/fossil/metadata.xml1
3 files changed, 54 insertions, 1 deletions
diff --git a/dev-vcs/fossil/ChangeLog b/dev-vcs/fossil/ChangeLog
index fb272d3d6775..44b9b73c3174 100644
--- a/dev-vcs/fossil/ChangeLog
+++ b/dev-vcs/fossil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/fossil
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.16 2013/07/18 10:50:47 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.17 2013/12/13 14:19:53 mr_bones_ Exp $
+
+*fossil-20130911114349 (13 Dec 2013)
+
+ 13 Dec 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +fossil-20130911114349.ebuild, metadata.xml:
+ non-maintainer version bump per rafaelmartins
18 Jul 2013; Aaron W. Swenson <titanofold@gentoo.org>
-fossil-20111213135356.ebuild, -fossil-20121022124804.ebuild:
diff --git a/dev-vcs/fossil/fossil-20130911114349.ebuild b/dev-vcs/fossil/fossil-20130911114349.ebuild
new file mode 100644
index 000000000000..e102ad4e724d
--- /dev/null
+++ b/dev-vcs/fossil/fossil-20130911114349.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/fossil-20130911114349.ebuild,v 1.1 2013/12/13 14:19:53 mr_bones_ Exp $
+
+EAPI=5
+MY_P=${PN}-src-${PV}
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple, high-reliability, source control management, and more"
+HOMEPAGE="http://www.fossil-scm.org/"
+SRC_URI="http://www.fossil-scm.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="json +lineedit sqlite +ssl tcl"
+
+DEPEND="sys-libs/zlib
+ lineedit? ( || ( sys-libs/readline:0= dev-libs/libedit ) )
+ ssl? ( dev-libs/openssl )
+ sqlite? ( dev-db/sqlite:3 )
+ tcl? ( dev-lang/tcl )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # this is not an autotools situation so don't make it seem like one
+ # --with-tcl: works
+ # --without-tcl: dies
+ local myconf='--with-zlib'
+
+ myconf+=" --lineedit=$(usex lineedit 1 0)"
+ myconf+=" --with-openssl=$(usex ssl auto none)"
+ use json && myconf+=' --json'
+ use sqlite && myconf+=' --disable-internal-sqlite'
+ use tcl && myconf+=' --with-tcl --with-tcl-stubs'
+ tc-export CC
+ ./configure ${myconf} || die
+}
+
+src_install() {
+ dobin fossil
+}
diff --git a/dev-vcs/fossil/metadata.xml b/dev-vcs/fossil/metadata.xml
index 2f2983e43e30..af4a9e3be69d 100644
--- a/dev-vcs/fossil/metadata.xml
+++ b/dev-vcs/fossil/metadata.xml
@@ -12,6 +12,7 @@
</maintainer>
<use>
<flag name="json">Enable the JSON API of Fossil's wiki</flag>
+ <flag name="lineedit">Enable line-editing with libedit or readline</flag>
<flag name="sqlite">
Use the system SQLite instead of the bundled one
</flag>