summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-03-25 14:58:21 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-03-25 14:58:21 +0000
commit275e43895b0ce5f2d863f4fa2a163292a2810d31 (patch)
tree5f1361d0efd51115266114fe998c64d72b42d125 /dev-vcs/bzr/files
parentRaise gtk-doc{,-am} dependencies. Fixes bug 311085 (diff)
downloadgentoo-2-275e43895b0ce5f2d863f4fa2a163292a2810d31.tar.gz
gentoo-2-275e43895b0ce5f2d863f4fa2a163292a2810d31.tar.bz2
gentoo-2-275e43895b0ce5f2d863f4fa2a163292a2810d31.zip
version bump
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'dev-vcs/bzr/files')
-rw-r--r--dev-vcs/bzr/files/bzr-2.1.1-no-pyrex-citon.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-vcs/bzr/files/bzr-2.1.1-no-pyrex-citon.patch b/dev-vcs/bzr/files/bzr-2.1.1-no-pyrex-citon.patch
new file mode 100644
index 000000000000..02d6d833c2c3
--- /dev/null
+++ b/dev-vcs/bzr/files/bzr-2.1.1-no-pyrex-citon.patch
@@ -0,0 +1,33 @@
+--- setup.py.orig 2010-03-25 15:54:31.031989804 +0100
++++ setup.py 2010-03-25 15:55:24.943965524 +0100
+@@ -166,27 +166,9 @@
+ from distutils.errors import CCompilerError, DistutilsPlatformError
+ from distutils.extension import Extension
+ ext_modules = []
+-try:
+- try:
+- from Pyrex.Distutils import build_ext
+- from Pyrex.Compiler.Version import version as pyrex_version
+- except ImportError:
+- print "No Pyrex, trying Cython..."
+- from Cython.Distutils import build_ext
+- from Cython.Compiler.Version import version as pyrex_version
+-except ImportError:
+- have_pyrex = False
+- # try to build the extension from the prior generated source.
+- print
+- print ("The python package 'Pyrex' is not available."
+- " If the .c files are available,")
+- print ("they will be built,"
+- " but modifying the .pyx files will not rebuild them.")
+- print
+- from distutils.command.build_ext import build_ext
+-else:
+- have_pyrex = True
+- pyrex_version_info = tuple(map(int, pyrex_version.split('.')))
++
++have_pyrex = False
++from distutils.command.build_ext import build_ext
+
+
+ class build_ext_if_possible(build_ext):