summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-21 14:59:13 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-21 14:59:13 +0000
commitd700112538efa34785504351a7b78e00fcdd9b98 (patch)
treeb3503d005a95058a473e2c75bad3157209651394 /dev-util
parentwhitespace (diff)
downloadgentoo-2-d700112538efa34785504351a7b78e00fcdd9b98.tar.gz
gentoo-2-d700112538efa34785504351a7b78e00fcdd9b98.tar.bz2
gentoo-2-d700112538efa34785504351a7b78e00fcdd9b98.zip
Bump
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mono-tools/ChangeLog9
-rw-r--r--dev-util/mono-tools/mono-tools-2.6.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/dev-util/mono-tools/ChangeLog b/dev-util/mono-tools/ChangeLog
index b643dbccf360..41efe51a8d59 100644
--- a/dev-util/mono-tools/ChangeLog
+++ b/dev-util/mono-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/mono-tools
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/ChangeLog,v 1.65 2009/09/27 17:00:36 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/ChangeLog,v 1.66 2010/02/21 14:59:13 patrick Exp $
+
+*mono-tools-2.6 (21 Feb 2010)
+
+ 21 Feb 2010; Patrick Lauer <patrick@gentoo.org> +mono-tools-2.6.ebuild:
+ Bump
27 Sep 2009; nixnut <nixnut@gentoo.org> mono-tools-2.4.2-r1.ebuild:
ppc stable #284306
diff --git a/dev-util/mono-tools/mono-tools-2.6.ebuild b/dev-util/mono-tools/mono-tools-2.6.ebuild
new file mode 100644
index 000000000000..fc279071b493
--- /dev/null
+++ b/dev-util/mono-tools/mono-tools-2.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/mono-tools-2.6.ebuild,v 1.1 2010/02/21 14:59:13 patrick Exp $
+
+EAPI=2
+
+inherit go-mono mono autotools
+
+DESCRIPTION="Set of useful Mono related utilities"
+HOMEPAGE="http://www.mono-project.com/"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="webkit gtkhtml +xulrunner"
+
+RDEPEND="=virtual/monodoc-${GO_MONO_REL_PV}*
+ >=dev-dotnet/gtk-sharp-2.12.6
+ >=dev-dotnet/glade-sharp-2.12.6
+ >=dev-dotnet/gconf-sharp-2
+ gtkhtml? ( >=dev-dotnet/gtkhtml-sharp-2.24.0 )
+ webkit? ( >=dev-dotnet/webkit-sharp-0.2-r1 )
+ xulrunner? ( =dev-dotnet/gluezilla-${PV} )
+ "
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.19"
+
+PATCHES=( "${FILESDIR}/${PN}-2.4-html-renderer-fixes.patch" )
+
+#Fails parallel make.
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+ if ! use webkit && ! use gtkhtml && ! use xulrunner
+ then
+ die "You must USE either webkit, gtkhtml or xulrunner"
+ fi
+}
+
+src_prepare() {
+ go-mono_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-dependency-tracking \
+ --disable-gecko \
+ $(use_enable gtkhtml) \
+ $(use_enable webkit) \
+ $(use_enable xulrunner monowebbrowser) \
+ || die "configure failed"
+}
+
+src_install() {
+ go-mono_src_install
+ # Defunct .desktop file, see bug 266694
+ find "${D}" -type f -name 'mprof-heap-viewer.desktop' -exec rm -f '{}' '+' || die "removal of mprof-heap-viewer.desktop failed"
+}