summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-25 20:11:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-25 20:11:55 +0000
commitaf4fef2eda9bd0934919391aa02f985513902d68 (patch)
tree36590b76c541f717d912405c9afcd82e5ff05224 /dev-util
parentVersion bump. (diff)
downloadgentoo-2-af4fef2eda9bd0934919391aa02f985513902d68.tar.gz
gentoo-2-af4fef2eda9bd0934919391aa02f985513902d68.tar.bz2
gentoo-2-af4fef2eda9bd0934919391aa02f985513902d68.zip
Version bump (bug #316861). Use Python 2 (bug #364837).
(Portage version: 2.2.0_alpha30_p2/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gquilt/ChangeLog10
-rw-r--r--dev-util/gquilt/gquilt-0.25.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-util/gquilt/ChangeLog b/dev-util/gquilt/ChangeLog
index b7616c8a46ae..a68a2a90fb9c 100644
--- a/dev-util/gquilt/ChangeLog
+++ b/dev-util/gquilt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/gquilt
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gquilt/ChangeLog,v 1.17 2010/05/08 20:51:06 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gquilt/ChangeLog,v 1.18 2011/04/25 20:11:55 arfrever Exp $
+
+*gquilt-0.25 (25 Apr 2011)
+
+ 25 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +gquilt-0.25.ebuild:
+ Version bump (bug #316861). Use Python 2 (bug #364837).
08 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
gquilt-0.21.ebuild:
diff --git a/dev-util/gquilt/gquilt-0.25.ebuild b/dev-util/gquilt/gquilt-0.25.ebuild
new file mode 100644
index 000000000000..a2dcc26a9ed2
--- /dev/null
+++ b/dev-util/gquilt/gquilt-0.25.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gquilt/gquilt-0.25.ebuild,v 1.1 2011/04/25 20:11:55 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="A Python/GTK wrapper for quilt"
+HOMEPAGE="http://gquilt.sourceforge.net/ http://sourceforge.net/projects/gquilt/"
+SRC_URI="mirror://sourceforge/gquilt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygtk:2
+ dev-util/quilt"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="gquilt_pkg"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ distutils_src_prepare
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ distutils_src_install
+
+ dobin ${PN} || die "dobin failed"
+
+ insinto /usr/share/applications
+ doins gquilt.desktop || die "doins failed"
+}