summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-11-16 15:40:30 +0000
committerMichał Górny <mgorny@gentoo.org>2014-11-16 15:40:30 +0000
commita753e54ee2a59b30190a029b9cc61dff2ae83e74 (patch)
tree4a77db0184930ddeb9eea2bd5489f50b85d5c8bb /dev-util
parentRemove old versions of openvpn (diff)
downloadgentoo-2-a753e54ee2a59b30190a029b9cc61dff2ae83e74.tar.gz
gentoo-2-a753e54ee2a59b30190a029b9cc61dff2ae83e74.tar.bz2
gentoo-2-a753e54ee2a59b30190a029b9cc61dff2ae83e74.zip
Use python-single-r1 and a run-time dependency on Python since bjam links to libpython. Backport the conversion into non-masked 1.55.0 branch.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/boost-build/ChangeLog9
-rw-r--r--dev-util/boost-build/boost-build-1.55.0-r1.ebuild131
-rw-r--r--dev-util/boost-build/boost-build-1.56.0.ebuild17
3 files changed, 150 insertions, 7 deletions
diff --git a/dev-util/boost-build/ChangeLog b/dev-util/boost-build/ChangeLog
index 88c75fadb5d7..d46bf16a40ce 100644
--- a/dev-util/boost-build/ChangeLog
+++ b/dev-util/boost-build/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/boost-build
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.131 2014/11/12 08:42:59 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.132 2014/11/16 15:40:30 mgorny Exp $
+
+*boost-build-1.55.0-r1 (16 Nov 2014)
+
+ 16 Nov 2014; Michał Górny <mgorny@gentoo.org> +boost-build-1.55.0-r1.ebuild,
+ boost-build-1.56.0.ebuild:
+ Use python-single-r1 and a run-time dependency on Python since bjam links to
+ libpython. Backport the conversion into non-masked 1.55.0 branch.
12 Nov 2014; Sergey Popov <pinkbyte@gentoo.org> boost-build-1.55.0.ebuild:
Stable on amd64, wrt bug #525286
diff --git a/dev-util/boost-build/boost-build-1.55.0-r1.ebuild b/dev-util/boost-build/boost-build-1.55.0-r1.ebuild
new file mode 100644
index 000000000000..7a30d5086902
--- /dev/null
+++ b/dev-util/boost-build/boost-build-1.55.0-r1.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.55.0-r1.ebuild,v 1.1 2014/11/16 15:40:30 mgorny Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils flag-o-matic multilib python-single-r1 toolchain-funcs versionator
+
+MY_PV=$(replace_all_version_separators _)
+
+DESCRIPTION="A system for large project software construction, which is simple to use and powerful"
+HOMEPAGE="http://www.boost.org/doc/tools/build/index.html"
+SRC_URI="mirror://sourceforge/boost/boost_${MY_PV}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT=0
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples python test"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ !<dev-libs/boost-1.34.0
+ !<=dev-util/boost-build-1.35.0-r1"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/diffutils )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( python )"
+
+S="${WORKDIR}/boost_${MY_PV}/tools/build/v2"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build/v2 || die "unpacking tar failed"
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${PN}-1.48.0-disable_python_rpath.patch" \
+ "${FILESDIR}/${PN}-1.50.0-respect-c_ld-flags.patch" \
+ "${FILESDIR}/${PN}-1.49.0-darwin-gentoo-toolchain.patch" \
+ "${FILESDIR}/${PN}-1.52.0-darwin-no-python-framework.patch" \
+ "${FILESDIR}/${PN}-1.54.0-fix-test.patch" \
+ "${FILESDIR}/${PN}-1.54.0-support_dots_in_python-buildid.patch"
+
+ # Remove stripping option
+ # Fix python components build on multilib systems, bug #496446
+ cd "${S}/engine" || die
+ sed -i \
+ -e 's|-s\b||' \
+ -e "/libpython/s/lib ]/$(get_libdir) ]/" \
+ build.jam || die "sed failed"
+
+ # Force regeneration
+ rm jambase.c || die
+
+ # This patch allows us to fully control optimization
+ # and stripping flags when bjam is used as build-system
+ # We simply extend the optimization and debug-symbols feature
+ # with empty dummies called 'none'
+ cd "${S}" || die
+ sed -i \
+ -e 's/\(off speed space\)/\1 none/' \
+ -e 's/\(debug-symbols : on off\)/\1 none/' \
+ tools/builtin.jam || die "sed failed"
+
+ epatch_user
+}
+
+src_configure() {
+ if use python; then
+ # replace versions by user-selected one (TODO: fix this when slot-op
+ # deps are available to always match the best version available)
+ sed -i \
+ -e "s|2.7 2.6 2.5 2.4 2.3 2.2|${EPYTHON#python}|" \
+ engine/build.jam || die "sed failed"
+ fi
+}
+
+src_compile() {
+ cd engine || die
+
+ local toolset
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ toolset=darwin
+ else
+ # Using boost's generic toolset here, which respects CC and CFLAGS
+ toolset=cc
+ fi
+
+ CC=$(tc-getCC) ./build.sh ${toolset} -d+2 $(use_with python python "${EROOT}"/usr) || die "building bjam failed"
+}
+
+src_install() {
+ dobin engine/bin.*/{bjam,b2}
+
+ insinto /usr/share/boost-build
+ doins -r "${FILESDIR}/site-config.jam" \
+ boost-build.jam bootstrap.jam build-system.jam user-config.jam *.py \
+ build kernel options tools util
+
+ rm "${ED}/usr/share/boost-build/build/project.ann.py" || die "removing faulty python file failed"
+ if ! use python; then
+ find "${ED}/usr/share/boost-build" -iname "*.py" -delete || die "removing experimental python files failed"
+ fi
+
+ dodoc changes.txt hacking.txt release_procedure.txt \
+ notes/build_dir_option.txt notes/relative_source_paths.txt
+
+ if use examples; then
+ dodoc -r example
+ docompress -x "/usr/share/doc/${PF}/example"
+ fi
+}
+
+src_test() {
+ cd test || die
+
+ export TMP="${T}"
+
+ DO_DIFF="${PREFIX}/usr/bin/diff" ${PYTHON} test_all.py
+
+ if [[ -s test_results.txt ]]; then
+ eerror "At least one test failed: $(<test_results.txt)"
+ die "tests failed"
+ fi
+}
diff --git a/dev-util/boost-build/boost-build-1.56.0.ebuild b/dev-util/boost-build/boost-build-1.56.0.ebuild
index 1544955f3307..e4616214c3bf 100644
--- a/dev-util/boost-build/boost-build-1.56.0.ebuild
+++ b/dev-util/boost-build/boost-build-1.56.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.56.0.ebuild,v 1.1 2014/08/15 07:57:24 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.56.0.ebuild,v 1.2 2014/11/16 15:40:30 mgorny Exp $
EAPI="5"
PYTHON_COMPAT=( python2_7 )
-inherit eutils flag-o-matic multilib python-any-r1 toolchain-funcs versionator
+inherit eutils flag-o-matic multilib python-single-r1 toolchain-funcs versionator
MY_PV="$(replace_all_version_separators _)"
@@ -18,16 +18,21 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-aix ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="examples python test"
-RDEPEND="!<dev-libs/boost-1.34.0
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ !<dev-libs/boost-1.34.0
!<=dev-util/boost-build-1.35.0-r1"
DEPEND="${RDEPEND}
- python? ( ${PYTHON_DEPS} )
test? ( sys-apps/diffutils )"
-REQUIRED_USE="test? ( python )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( python )"
S="${WORKDIR}/boost_${MY_PV}/tools/build/src"
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
src_unpack() {
tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build || die "unpacking tar failed"
}
@@ -73,7 +78,7 @@ src_configure() {
# replace versions by user-selected one (TODO: fix this when slot-op
# deps are available to always match the best version available)
sed -i \
- -e "s|2.7 2.6 2.5 2.4 2.3 2.2|${EPYTHON##python}|" \
+ -e "s|2.7 2.6 2.5 2.4 2.3 2.2|${EPYTHON#python}|" \
engine/build.jam || die "sed failed"
fi
}