summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-21 17:00:33 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-21 17:00:33 +0000
commit99e5ce31e06d7ce284b57299d28c8188c379453a (patch)
tree6d004d6c640380540db4a5344893016b0c9c9383 /dev-util
parentppc stable, bug #128107 (diff)
downloadgentoo-2-99e5ce31e06d7ce284b57299d28c8188c379453a.tar.gz
gentoo-2-99e5ce31e06d7ce284b57299d28c8188c379453a.tar.bz2
gentoo-2-99e5ce31e06d7ce284b57299d28c8188c379453a.zip
Add patch to allow linking with --as-needed. Bug #130199.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cppunit/ChangeLog6
-rw-r--r--dev-util/cppunit/cppunit-1.10.2.ebuild9
-rw-r--r--dev-util/cppunit/files/cppunit-1.10.2-asneeded.patch10
3 files changed, 22 insertions, 3 deletions
diff --git a/dev-util/cppunit/ChangeLog b/dev-util/cppunit/ChangeLog
index e0e156e65ba2..77f8e2c5dabb 100644
--- a/dev-util/cppunit/ChangeLog
+++ b/dev-util/cppunit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/cppunit
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/ChangeLog,v 1.15 2006/04/02 13:24:25 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/ChangeLog,v 1.16 2006/04/21 17:00:33 flameeyes Exp $
+
+ 21 Apr 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/cppunit-1.10.2-asneeded.patch, cppunit-1.10.2.ebuild:
+ Add patch to allow linking with --as-needed. Bug #130199.
02 Apr 2006; George Shapovalov <george@gentoo.org> cppunit-1.10.2.ebuild:
fixed dependencies - graphviz is only needed for docs(#125723). Thanks to
diff --git a/dev-util/cppunit/cppunit-1.10.2.ebuild b/dev-util/cppunit/cppunit-1.10.2.ebuild
index 0de6d8365fd6..297b60e2e872 100644
--- a/dev-util/cppunit/cppunit-1.10.2.ebuild
+++ b/dev-util/cppunit/cppunit-1.10.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-1.10.2.ebuild,v 1.12 2006/04/02 13:24:25 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-1.10.2.ebuild,v 1.13 2006/04/21 17:00:33 flameeyes Exp $
-inherit eutils
+inherit eutils autotools
DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
HOMEPAGE="http://cppunit.sourceforge.net/"
@@ -16,11 +16,16 @@ RESTRICT="test"
DEPEND="doc? ( app-doc/doxygen
media-gfx/graphviz )"
+RDEPEND=""
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-m4.patch
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+ AT_M4DIR="${S}/config" eautomake
+
+ elibtoolize
}
src_compile() {
diff --git a/dev-util/cppunit/files/cppunit-1.10.2-asneeded.patch b/dev-util/cppunit/files/cppunit-1.10.2-asneeded.patch
new file mode 100644
index 000000000000..068414f33580
--- /dev/null
+++ b/dev-util/cppunit/files/cppunit-1.10.2-asneeded.patch
@@ -0,0 +1,10 @@
+Index: cppunit-1.10.2/src/cppunit/Makefile.am
+===================================================================
+--- cppunit-1.10.2.orig/src/cppunit/Makefile.am
++++ cppunit-1.10.2/src/cppunit/Makefile.am
+@@ -64,4 +64,5 @@ libcppunit_la_SOURCES = \
+ libcppunit_la_LDFLAGS= \
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
+ -release $(LT_RELEASE)
++libcppunit_la_LIBADD = $(LIBADD_DL)
+