summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-06-22 14:28:54 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-06-22 14:28:54 +0000
commit92dbec3101d03124b2764baa24df6310b9896afa (patch)
treee327f5584aa192e0779093e4f817a3f084877c8f /dev-util
parentupdated patchset (diff)
downloadgentoo-2-92dbec3101d03124b2764baa24df6310b9896afa.tar.gz
gentoo-2-92dbec3101d03124b2764baa24df6310b9896afa.tar.bz2
gentoo-2-92dbec3101d03124b2764baa24df6310b9896afa.zip
Version bump to 2.0_rc48. Closing bug #137252.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catalyst/ChangeLog9
-rw-r--r--dev-util/catalyst/catalyst-2.0_rc48.ebuild95
-rw-r--r--dev-util/catalyst/files/catalyst-2.0_rc48-slot.patch30
-rw-r--r--dev-util/catalyst/files/digest-catalyst-2.0_rc483
4 files changed, 136 insertions, 1 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index cb57bf0a3215..5de6a886e8d5 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/catalyst
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.150 2006/06/09 00:49:16 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.151 2006/06/22 14:28:54 wolf31o2 Exp $
+
+*catalyst-2.0_rc48 (22 Jun 2006)
+
+ 22 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ -files/catalyst-2.0_rc47-slot.patch, +files/catalyst-2.0_rc48-slot.patch,
+ -catalyst-2.0_rc47.ebuild, +catalyst-2.0_rc48.ebuild:
+ Version bump to 2.0_rc48. Closing bug #137252.
*catalyst-2.0_rc47 (09 Jun 2006)
diff --git a/dev-util/catalyst/catalyst-2.0_rc48.ebuild b/dev-util/catalyst/catalyst-2.0_rc48.ebuild
new file mode 100644
index 000000000000..a55f9b6a45e9
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0_rc48.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0_rc48.ebuild,v 1.1 2006/06/22 14:28:54 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo Linux official release metatool"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
+SRC_URI="http://dev.gentoo.org/~wolf31o2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ccache cdr"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ amd64? ( sys-apps/setarch )
+ ppc64? ( sys-apps/setarch )
+ ccache? ( dev-util/ccache )
+ cdr? (
+ virtual/cdrtools
+ ia64? ( sys-fs/dosfstools )
+ app-misc/zisofs-tools
+ >=sys-fs/squashfs-tools-2.1 )"
+# examples? (
+# dev-util/livecd-kconfigs
+# dev-util/livecd-specs )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-slot.patch
+}
+
+src_install() {
+ ewarn "This version of the ebuild is slotted to allow side-by-side"
+ ewarn "installation with catalyst 1.x for use on build servers. The final"
+ ewarn "version of this ebuild will not be slotted, as catalyst 2.0 is to"
+ ewarn "supercede catalyst 1.x in every way. It is currently slotted for"
+ ewarn "testing purposes only."
+ insinto /usr/lib/${PN}2/arch
+ doins arch/* || die "copying arch/*"
+ insinto /usr/lib/${PN}2/modules
+ doins modules/* || die "copying modules/*"
+ insinto /usr/lib/${PN}2/livecd/cdtar
+ doins livecd/cdtar/* || die "copying cdtar/*"
+ insinto /usr/lib/${PN}2/livecd/files
+ doins livecd/files/* || die "copying files/*"
+ for x in targets/*; do
+ exeinto /usr/lib/${PN}2/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ exeinto /usr/lib/${PN}2
+ newexe catalyst catalyst2 || die "copying catalyst"
+ dodir /usr/bin
+ dosym /usr/lib/${PN}2/catalyst2 /usr/bin/catalyst2
+ insinto /etc/catalyst2
+ newins files/catalyst.conf catalyst2.conf
+ DOCDESTTREE="." dohtml -A spec,msg,example -r examples files
+ dodoc README ChangeLog ChangeLog.old AUTHORS
+ newman files/catalyst.1 catalyst2.1
+ # This will go away in the future
+ dosed "s:/usr/lib/catalyst:/usr/lib/catalyst2:" \
+ /etc/catalyst2/catalyst2.conf
+ dosed "s:/var/tmp/catalyst:/var/tmp/catalyst2:" \
+ /etc/catalyst2/catalyst2.conf
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst2/catalyst2.conf
+}
+
+pkg_postinst() {
+ echo
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}
diff --git a/dev-util/catalyst/files/catalyst-2.0_rc48-slot.patch b/dev-util/catalyst/files/catalyst-2.0_rc48-slot.patch
new file mode 100644
index 000000000000..6e5af809c81a
--- /dev/null
+++ b/dev-util/catalyst/files/catalyst-2.0_rc48-slot.patch
@@ -0,0 +1,30 @@
+diff -urN catalyst-2.0_rc48.orig/catalyst catalyst-2.0_rc44/catalyst
+--- catalyst-2.0_rc48.orig/catalyst 2005-12-20 07:07:45.000000000 -0500
++++ catalyst-2.0_rc48/catalyst 2005-12-20 07:09:19.000000000 -0500
+@@ -51,10 +51,10 @@
+ myconf={}
+ config_file=""
+
+- confdefaults={ "storedir":"/var/tmp/catalyst",\
+- "sharedir":"/usr/share/catalyst","distdir":"/usr/portage/distfiles",\
++ confdefaults={ "storedir":"/var/tmp/catalyst2",\
++ "sharedir":"/usr/share/catalyst2","distdir":"/usr/portage/distfiles",\
+ "portdir":"/usr/portage","options":"",\
+- "snapshot_cache":"/var/tmp/catalyst/snapshot_cache",\
++ "snapshot_cache":"/var/tmp/catalyst2/snapshot_cache",\
+ "hash_function":"crc32"}
+
+ # first, try the one passed (presumably from the cmdline)
+@@ -69,9 +69,9 @@
+ sys.exit(1)
+
+ # next, try the default location
+- elif os.path.exists("/etc/catalyst/catalyst.conf"):
+- print "Using default Catalyst configuration file, /etc/catalyst/catalyst.conf"
+- config_file="/etc/catalyst/catalyst.conf"
++ elif os.path.exists("/etc/catalyst2/catalyst2.conf"):
++ print "Using default Catalyst configuration file, /etc/catalyst2/catalyst2.conf"
++ config_file="/etc/catalyst2/catalyst2.conf"
+
+ # can't find a config file (we are screwed), so bail out
+ else:
diff --git a/dev-util/catalyst/files/digest-catalyst-2.0_rc48 b/dev-util/catalyst/files/digest-catalyst-2.0_rc48
new file mode 100644
index 000000000000..fb1dba4215de
--- /dev/null
+++ b/dev-util/catalyst/files/digest-catalyst-2.0_rc48
@@ -0,0 +1,3 @@
+MD5 df6e5ac26fa96a5a72c43d92d672a0dc catalyst-2.0_rc48.tar.bz2 891178
+RMD160 785c08975a7cebda0d7d69590dc26f9fae93599e catalyst-2.0_rc48.tar.bz2 891178
+SHA256 2c0da2996a59c4e9452c6aa61a989a23f09dd10f834718de6b7e038e99049351 catalyst-2.0_rc48.tar.bz2 891178