summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2006-11-04 17:33:35 +0000
committerBryan Østergaard <kloeri@gentoo.org>2006-11-04 17:33:35 +0000
commit89b0aa55879f611ab772e14703eaae5d4ebe1424 (patch)
treee06dd13f7f9f26c8d233e716d6f121b9c3ee4d89 /dev-util
parentVersion bump. (diff)
downloadgentoo-2-89b0aa55879f611ab772e14703eaae5d4ebe1424.tar.gz
gentoo-2-89b0aa55879f611ab772e14703eaae5d4ebe1424.tar.bz2
gentoo-2-89b0aa55879f611ab772e14703eaae5d4ebe1424.zip
Version bump, bug 153648.
(Portage version: 2.1.2_rc1-r3)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/spe/ChangeLog7
-rw-r--r--dev-util/spe/files/digest-spe-0.8.3c3
-rw-r--r--dev-util/spe/spe-0.8.3c.ebuild55
3 files changed, 64 insertions, 1 deletions
diff --git a/dev-util/spe/ChangeLog b/dev-util/spe/ChangeLog
index a8e67caa8f4d..aecbb6ee33e3 100644
--- a/dev-util/spe/ChangeLog
+++ b/dev-util/spe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/spe
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/spe/ChangeLog,v 1.26 2006/09/12 19:55:38 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/spe/ChangeLog,v 1.27 2006/11/04 17:33:35 kloeri Exp $
+
+*spe-0.8.3c (04 Nov 2006)
+
+ 04 Nov 2006; Bryan Østergaard <kloeri@gentoo.org> +spe-0.8.3c.ebuild:
+ Version bump, bug 153648.
12 Sep 2006; Bryan Østergaard <kloeri@gentoo.org> spe-0.8.2.ebuild:
Stable on x86.
diff --git a/dev-util/spe/files/digest-spe-0.8.3c b/dev-util/spe/files/digest-spe-0.8.3c
new file mode 100644
index 000000000000..2befeb6d06b2
--- /dev/null
+++ b/dev-util/spe/files/digest-spe-0.8.3c
@@ -0,0 +1,3 @@
+MD5 40683a8d8c00beabf41973bc6fb846d4 SPE-0.8.3.c-wx2.6.1.0.tar.gz 870359
+RMD160 ffff498716b3d9b3a85bd5a67b88fce1cd3f5c4d SPE-0.8.3.c-wx2.6.1.0.tar.gz 870359
+SHA256 82e193eb778e04008eb32c0ac4de36ad5cd2718b9a11b0fb0163a8d074d9b14e SPE-0.8.3.c-wx2.6.1.0.tar.gz 870359
diff --git a/dev-util/spe/spe-0.8.3c.ebuild b/dev-util/spe/spe-0.8.3c.ebuild
new file mode 100644
index 000000000000..370ee1b61f92
--- /dev/null
+++ b/dev-util/spe/spe-0.8.3c.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/spe/spe-0.8.3c.ebuild,v 1.1 2006/11/04 17:33:35 kloeri Exp $
+
+inherit distutils eutils
+
+MY_P="SPE-0.8.3.c-wx2.6.1.0"
+DESCRIPTION="Python IDE with Blender support"
+HOMEPAGE="http://www.stani.be/python/spe/blog/"
+SRC_URI="http://download.berlios.de/python/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+S=${WORKDIR}/${MY_P}
+
+DEPEND=">=virtual/python-2.3
+ app-arch/unzip"
+
+RDEPEND=">=dev-python/wxpython-2.6.1.0
+ >=dev-util/wxglade-0.3.2
+ >=dev-python/pychecker-0.8.13
+ ${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ chmod -R go-w ${S}/*
+}
+
+src_install() {
+ distutils_src_install
+ distutils_python_version
+ SITEPATH="/usr/lib/python${PYVER}/site-packages"
+
+ dobin spe
+ rm -rf "${D}${SITEPATH}/_spe/plugins/wxGlade"
+ rm -rf "${D}${SITEPATH}/_spe/plugins/pychecker"
+ ln -svf "../../wxglade" "${D}${SITEPATH}/_spe/plugins/wxGlade"
+ dodir "${SITEPATH}/wxglade"
+ touch "${D}${SITEPATH}/wxglade/__init__.py"
+ ln -svf "../../pychecker" "${D}${SITEPATH}/_spe/plugins/pychecker"
+}
+
+pkg_postinst() {
+ distutils_python_version
+ SPEPATH="/usr/lib/python${PYVER}/site-packages"
+
+ einfo
+ einfo "To be able to use spe in blender, be sure that the path where spe is"
+ einfo "installed ($SPEPATH) is included in your PYTHONPATH"
+ einfo "environment variable. See the installation section in the manual for"
+ einfo "more information ($SPEPATH/_spe/doc/manual.pdf)."
+ einfo
+}