summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2003-12-22 00:18:18 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2003-12-22 00:18:18 +0000
commit885074e23e7fc9fa61797410bfe2473ecc64f471 (patch)
treed97dfeadb928d6d623c9ab52c36a41f3a25bd97a /dev-util
parentMarked stable on hppa. (diff)
downloadgentoo-2-885074e23e7fc9fa61797410bfe2473ecc64f471.tar.gz
gentoo-2-885074e23e7fc9fa61797410bfe2473ecc64f471.tar.bz2
gentoo-2-885074e23e7fc9fa61797410bfe2473ecc64f471.zip
Attempts to fix #34721.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/eclipse-sdk/ChangeLog9
-rw-r--r--dev-util/eclipse-sdk/eclipse-sdk-2.1.2-r1.ebuild8
2 files changed, 13 insertions, 4 deletions
diff --git a/dev-util/eclipse-sdk/ChangeLog b/dev-util/eclipse-sdk/ChangeLog
index 73ba45d232a6..9345de165fc1 100644
--- a/dev-util/eclipse-sdk/ChangeLog
+++ b/dev-util/eclipse-sdk/ChangeLog
@@ -1,11 +1,16 @@
# ChangeLog for dev-util/eclipse-sdk
# Copyright 2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/ChangeLog,v 1.7 2003/12/11 19:02:18 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/ChangeLog,v 1.8 2003/12/22 00:18:18 karltk Exp $
+ 21 Dec 2003; Karl Trygve Kalleberg <karltk@gentoo.org>
+ eclipse-sdk-2.1.2-r1.ebuild:
+ Fixed compilation with IBM JDK, tries to fix #37421. Must test it
+ on ppc.
+
*eclipse-sdk-3.0.0_pre5 (11 Dec 2003)
11 Dec 2003; Karl Trygve Kalleberg <karltk@gentoo.org>
- eclipse-sdk-3.0.0_pre5:
+ eclipse-sdk-3.0.0_pre5:
Added experimental upstream version, thanks to submission by David
Love <dlove@nighton.net>. Fixes #35416. Don't use it if you don't mean
it; this is highly volatile stuff.
diff --git a/dev-util/eclipse-sdk/eclipse-sdk-2.1.2-r1.ebuild b/dev-util/eclipse-sdk/eclipse-sdk-2.1.2-r1.ebuild
index fac4eba257d9..fd0c0876817c 100644
--- a/dev-util/eclipse-sdk/eclipse-sdk-2.1.2-r1.ebuild
+++ b/dev-util/eclipse-sdk/eclipse-sdk-2.1.2-r1.ebuild
@@ -52,6 +52,10 @@ src_compile() {
# for KDE. Apparently the motif build also supports KDE when
# this is done - I could be wrong though.
+ if [ ! -z "`java-config --java-version | grep IBM`" ] ; then
+ ANT_EXTRA_OPTS="-Dbootclasspath=`java-config --jdk-home`/jre/lib/core.jar"
+ fi
+
gtk_launcher_src_dir="${WORKDIR}/plugins/platform-launcher/library/gtk"
motif_launch_src_dir="${WORKDIR}/plugins/platform-launcher/library/motif"
gtk_swt_src_dir=${WORKDIR}/plugins/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library
@@ -94,13 +98,13 @@ src_compile() {
override_motif_target=
if [ "${gtk}" = "y" ] ; then
einfo "Building GTK+ frontend"
- ant -buildfile build.xml -Dos=linux -Dws=gtk
+ ant -buildfile build.xml -Dos=linux -Dws=gtk ${ANT_EXTRA_OPTS}
#only do a compile/install for motif... Don't do a buildDoc. This will save time...
override_motif_target=compile install
fi
if [ "${motif}" = "y" ] ; then
einfo "Building Motif frontend"
- ant -buildfile ${override_motif_target} build.xml -Dos=linux -Dws=motif
+ ant -buildfile ${override_motif_target} build.xml -Dos=linux -Dws=motif ${ANT_EXTRA_OPTS}
fi
# remove all .so files shipped with the tarball