summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2013-07-31 04:34:00 +0000
committerMatt Turner <mattst88@gentoo.org>2013-07-31 04:34:00 +0000
commit6dd9399c689eaf0a9bbad2ee61ae42288d32d12e (patch)
tree20c50938fa968fc6eb8d67bcb0db148f66cdc989 /dev-util
parentVersion bump (diff)
downloadgentoo-2-6dd9399c689eaf0a9bbad2ee61ae42288d32d12e.tar.gz
gentoo-2-6dd9399c689eaf0a9bbad2ee61ae42288d32d12e.tar.bz2
gentoo-2-6dd9399c689eaf0a9bbad2ee61ae42288d32d12e.zip
Version bump to 2.0.13. Drop some git branch support code.
(Portage version: 2.1.12.2/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 974CA72A)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catalyst/ChangeLog9
-rw-r--r--dev-util/catalyst/catalyst-2.0.12.1.ebuild108
-rw-r--r--dev-util/catalyst/catalyst-2.0.12.2.ebuild12
-rw-r--r--dev-util/catalyst/catalyst-2.0.12.ebuild108
-rw-r--r--dev-util/catalyst/catalyst-2.0.13.ebuild (renamed from dev-util/catalyst/catalyst-2.0.11.ebuild)23
-rw-r--r--dev-util/catalyst/catalyst-9999.ebuild12
6 files changed, 18 insertions, 254 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index 36ee1202c7db..67bd936166c6 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/catalyst
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.263 2013/06/16 14:58:39 dolsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.264 2013/07/31 04:34:00 mattst88 Exp $
+
+*catalyst-2.0.13 (31 Jul 2013)
+
+ 31 Jul 2013; Matt Turner <mattst88@gentoo.org> +catalyst-2.0.13.ebuild,
+ -catalyst-2.0.11.ebuild, -catalyst-2.0.12.1.ebuild, -catalyst-2.0.12.ebuild,
+ catalyst-2.0.12.2.ebuild, catalyst-9999.ebuild:
+ Version bump to 2.0.13. Drop some git branch support code.
16 Jun 2013; Brian Dolbec <dolsen@gentoo.org> +catalyst-2.9999.ebuild,
-catalyst-3.9999.ebuild:
diff --git a/dev-util/catalyst/catalyst-2.0.12.1.ebuild b/dev-util/catalyst/catalyst-2.0.12.1.ebuild
deleted file mode 100644
index a5e63886fbc2..000000000000
--- a/dev-util/catalyst/catalyst-2.0.12.1.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.12.1.ebuild,v 1.2 2012/11/02 16:06:10 zerochaos Exp $
-
-# catalyst-9999 -> latest Git
-# catalyst-2.9999 -> catalyst_2 branch from Git
-# catalyst-3.9999 -> catalyst_3 branch from Git
-# catalyst-VER -> normal catalyst release
-
-EAPI=3
-PYTHON_DEPEND="2"
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
- inherit git-2
- SRC_URI=""
- S="${WORKDIR}/${PN}"
- KEYWORDS=""
-
- case ${PV} in
- 2.9999) EGIT_BRANCH="catalyst_2" ;;
- 3.9999) EGIT_BRANCH="catalyst_3" ;;
- esac
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2"
- KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-fi
-inherit eutils multilib python
-
-DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
-HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
-
-LICENSE="GPL-2"
-SLOT="0"
-RESTRICT=""
-IUSE="ccache kernel_linux"
-
-DEPEND="app-text/asciidoc"
-RDEPEND="app-arch/lbzip2
- app-crypt/shash
- virtual/cdrtools
- ccache? ( dev-util/ccache )
- ia64? ( sys-fs/dosfstools )
- kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
-
-pkg_setup() {
- if use ccache ; then
- einfo "Enabling ccache support for catalyst."
- else
- ewarn "By default, ccache support for catalyst is disabled."
- ewarn "If this is not what you intended,"
- ewarn "then you should add ccache to your USE."
- fi
- echo
- einfo "The template spec files are now installed by default. You can find"
- einfo "them under /usr/share/doc/${PF}/examples"
- einfo "and they are considered to be the authorative source of information"
- einfo "on catalyst."
- echo
- if [[ ${PV} == *9999* ]]; then
- ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
- ewarn "work-in-progress code. Be aware that it's likely that it will not"
- ewarn "be in a working state at any given point. Please do not file bugs"
- ewarn "until you have posted on the gentoo-catalyst mailing list and we"
- ewarn "have asked you to do so."
- fi
- python_set_active_version 2
-}
-
-src_prepare() {
- python_convert_shebangs 2 catalyst modules/catalyst_lock.py
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/${PN}
- exeinto /usr/$(get_libdir)/${PN}
- doexe catalyst || die "copying catalyst"
- if [[ ${PV} == 3.9999* ]]; then
- doins -r modules files || die "copying files"
- else
- doins -r arch modules livecd || die "copying files"
- fi
- for x in targets/*; do
- exeinto /usr/$(get_libdir)/${PN}/$x
- doexe $x/* || die "copying ${x}"
- done
- make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
- insinto /etc/catalyst
- doins files/catalyst.conf files/catalystrc || die "copying configuration"
- insinto /usr/share/doc/${PF}/examples
- doins examples/* || die
- dodoc README ChangeLog AUTHORS
- doman files/catalyst.1
- # Here is where we actually enable ccache
- use ccache && \
- dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
- /etc/catalyst/catalyst.conf
- dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
- /etc/catalyst/catalyst.conf
-}
-
-pkg_postinst() {
- einfo "You can find more information about catalyst by checking out the"
- einfo "catalyst project page at:"
- einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
- echo
-}
diff --git a/dev-util/catalyst/catalyst-2.0.12.2.ebuild b/dev-util/catalyst/catalyst-2.0.12.2.ebuild
index 47db917c3828..b4cfc0834061 100644
--- a/dev-util/catalyst/catalyst-2.0.12.2.ebuild
+++ b/dev-util/catalyst/catalyst-2.0.12.2.ebuild
@@ -1,11 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.12.2.ebuild,v 1.3 2013/01/31 15:01:43 jer Exp $
-
-# catalyst-9999 -> latest Git
-# catalyst-2.9999 -> catalyst_2 branch from Git
-# catalyst-3.9999 -> catalyst_3 branch from Git
-# catalyst-VER -> normal catalyst release
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.12.2.ebuild,v 1.4 2013/07/31 04:34:00 mattst88 Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -16,11 +11,6 @@ if [[ ${PV} == *9999* ]]; then
SRC_URI=""
S="${WORKDIR}/${PN}"
KEYWORDS=""
-
- case ${PV} in
- 2.9999) EGIT_BRANCH="catalyst_2" ;;
- 3.9999) EGIT_BRANCH="catalyst_3" ;;
- esac
else
SRC_URI="mirror://gentoo/${P}.tar.bz2
http://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2"
diff --git a/dev-util/catalyst/catalyst-2.0.12.ebuild b/dev-util/catalyst/catalyst-2.0.12.ebuild
deleted file mode 100644
index 8a7d40195a9f..000000000000
--- a/dev-util/catalyst/catalyst-2.0.12.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.12.ebuild,v 1.2 2012/11/02 16:06:10 zerochaos Exp $
-
-# catalyst-9999 -> latest Git
-# catalyst-2.9999 -> catalyst_2 branch from Git
-# catalyst-3.9999 -> catalyst_3 branch from Git
-# catalyst-VER -> normal catalyst release
-
-EAPI=3
-PYTHON_DEPEND="2"
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
- inherit git-2
- SRC_URI=""
- S="${WORKDIR}/${PN}"
- KEYWORDS=""
-
- case ${PV} in
- 2.9999) EGIT_BRANCH="catalyst_2" ;;
- 3.9999) EGIT_BRANCH="catalyst_3" ;;
- esac
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2"
- KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-fi
-inherit eutils multilib python
-
-DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
-HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
-
-LICENSE="GPL-2"
-SLOT="0"
-RESTRICT=""
-IUSE="ccache kernel_linux"
-
-DEPEND="app-text/asciidoc"
-RDEPEND="app-arch/lbzip2
- app-crypt/shash
- virtual/cdrtools
- ccache? ( dev-util/ccache )
- ia64? ( sys-fs/dosfstools )
- kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
-
-pkg_setup() {
- if use ccache ; then
- einfo "Enabling ccache support for catalyst."
- else
- ewarn "By default, ccache support for catalyst is disabled."
- ewarn "If this is not what you intended,"
- ewarn "then you should add ccache to your USE."
- fi
- echo
- einfo "The template spec files are now installed by default. You can find"
- einfo "them under /usr/share/doc/${PF}/examples"
- einfo "and they are considered to be the authorative source of information"
- einfo "on catalyst."
- echo
- if [[ ${PV} == *9999* ]]; then
- ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
- ewarn "work-in-progress code. Be aware that it's likely that it will not"
- ewarn "be in a working state at any given point. Please do not file bugs"
- ewarn "until you have posted on the gentoo-catalyst mailing list and we"
- ewarn "have asked you to do so."
- fi
- python_set_active_version 2
-}
-
-src_prepare() {
- python_convert_shebangs 2 catalyst modules/catalyst_lock.py
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/${PN}
- exeinto /usr/$(get_libdir)/${PN}
- doexe catalyst || die "copying catalyst"
- if [[ ${PV} == 3.9999* ]]; then
- doins -r modules files || die "copying files"
- else
- doins -r arch modules livecd || die "copying files"
- fi
- for x in targets/*; do
- exeinto /usr/$(get_libdir)/${PN}/$x
- doexe $x/* || die "copying ${x}"
- done
- make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
- insinto /etc/catalyst
- doins files/catalyst.conf files/catalystrc || die "copying configuration"
- insinto /usr/share/doc/${PF}/examples
- doins examples/* || die
- dodoc README ChangeLog AUTHORS
- doman files/catalyst.1
- # Here is where we actually enable ccache
- use ccache && \
- dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
- /etc/catalyst/catalyst.conf
- dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
- /etc/catalyst/catalyst.conf
-}
-
-pkg_postinst() {
- einfo "You can find more information about catalyst by checking out the"
- einfo "catalyst project page at:"
- einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
- echo
-}
diff --git a/dev-util/catalyst/catalyst-2.0.11.ebuild b/dev-util/catalyst/catalyst-2.0.13.ebuild
index 17a567c650fd..b311654bcc64 100644
--- a/dev-util/catalyst/catalyst-2.0.11.ebuild
+++ b/dev-util/catalyst/catalyst-2.0.13.ebuild
@@ -1,11 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.11.ebuild,v 1.2 2012/09/25 06:12:02 jmbsvicetto Exp $
-
-# catalyst-9999 -> latest Git
-# catalyst-2.9999 -> catalyst_2 branch from Git
-# catalyst-3.9999 -> catalyst_3 branch from Git
-# catalyst-VER -> normal catalyst release
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.13.ebuild,v 1.1 2013/07/31 04:34:00 mattst88 Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -16,11 +11,6 @@ if [[ ${PV} == *9999* ]]; then
SRC_URI=""
S="${WORKDIR}/${PN}"
KEYWORDS=""
-
- case ${PV} in
- 2.9999) EGIT_BRANCH="catalyst_2" ;;
- 3.9999) EGIT_BRANCH="catalyst_3" ;;
- esac
else
SRC_URI="mirror://gentoo/${P}.tar.bz2
http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2"
@@ -37,8 +27,11 @@ RESTRICT=""
IUSE="ccache kernel_linux"
DEPEND="app-text/asciidoc"
-RDEPEND="app-crypt/shash
+RDEPEND="app-arch/lbzip2
+ app-crypt/shash
virtual/cdrtools
+ x86? ( >=sys-boot/syslinux-3.72 )
+ amd64? ( >=sys-boot/syslinux-3.72 )
ccache? ( dev-util/ccache )
ia64? ( sys-fs/dosfstools )
kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
@@ -89,8 +82,8 @@ src_install() {
doins files/catalyst.conf files/catalystrc || die "copying configuration"
insinto /usr/share/doc/${PF}/examples
doins examples/* || die
- dodoc README ChangeLog AUTHORS
- doman files/catalyst.1
+ dodoc README AUTHORS
+ doman files/catalyst.1 files/catalyst-spec.5
# Here is where we actually enable ccache
use ccache && \
dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
diff --git a/dev-util/catalyst/catalyst-9999.ebuild b/dev-util/catalyst/catalyst-9999.ebuild
index 018b6695ff7c..f48fd24f732e 100644
--- a/dev-util/catalyst/catalyst-9999.ebuild
+++ b/dev-util/catalyst/catalyst-9999.ebuild
@@ -1,11 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-9999.ebuild,v 1.28 2013/04/13 07:04:57 mattst88 Exp $
-
-# catalyst-9999 -> latest Git
-# catalyst-2.9999 -> catalyst_2 branch from Git
-# catalyst-3.9999 -> catalyst_3 branch from Git
-# catalyst-VER -> normal catalyst release
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-9999.ebuild,v 1.29 2013/07/31 04:34:00 mattst88 Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -16,11 +11,6 @@ if [[ ${PV} == *9999* ]]; then
SRC_URI=""
S="${WORKDIR}/${PN}"
KEYWORDS=""
-
- case ${PV} in
- 2.9999) EGIT_BRANCH="catalyst_2" ;;
- 3.9999) EGIT_BRANCH="catalyst_3" ;;
- esac
else
SRC_URI="mirror://gentoo/${P}.tar.bz2
http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2"