summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-10-18 15:19:24 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-10-18 15:19:24 +0000
commit5729197a9a0c1b0c0c15dcc7990872ca61512ee0 (patch)
tree4ef0b3c1337924990e4791e7dfb8d3347ef6c29c /dev-util
parentMigrate to distutils-r1. Bug #522654 thanks to Ian Delaney (diff)
downloadgentoo-2-5729197a9a0c1b0c0c15dcc7990872ca61512ee0.tar.gz
gentoo-2-5729197a9a0c1b0c0c15dcc7990872ca61512ee0.tar.bz2
gentoo-2-5729197a9a0c1b0c0c15dcc7990872ca61512ee0.zip
Migrate to distutils-r1. Bug #522654 thanks to Ian Delaney
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot/ChangeLog8
-rw-r--r--dev-util/buildbot/buildbot-0.8.9-r1.ebuild110
-rw-r--r--dev-util/buildbot/buildbot-9999.ebuild49
3 files changed, 138 insertions, 29 deletions
diff --git a/dev-util/buildbot/ChangeLog b/dev-util/buildbot/ChangeLog
index 5d354176edce..6d09e7dc5414 100644
--- a/dev-util/buildbot/ChangeLog
+++ b/dev-util/buildbot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/buildbot
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.157 2014/10/02 20:29:51 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.158 2014/10/18 15:19:24 hwoarang Exp $
+
+*buildbot-0.8.9-r1 (18 Oct 2014)
+
+ 18 Oct 2014; Markos Chandras <hwoarang@gentoo.org> +buildbot-0.8.9-r1.ebuild,
+ buildbot-9999.ebuild:
+ Migrate to distutils-r1. Bug #522654 thanks to Ian Delaney
02 Oct 2014; Markos Chandras <hwoarang@gentoo.org> buildbot-0.8.9.ebuild:
amd64/x86 stable. Bug #521732
diff --git a/dev-util/buildbot/buildbot-0.8.9-r1.ebuild b/dev-util/buildbot/buildbot-0.8.9-r1.ebuild
new file mode 100644
index 000000000000..2e2fdf53a896
--- /dev/null
+++ b/dev-util/buildbot/buildbot-0.8.9-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.8.9-r1.ebuild,v 1.1 2014/10/18 15:19:24 hwoarang Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 readme.gentoo systemd user
+
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="BuildBot build automation system"
+HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc examples irc mail manhole test"
+
+RDEPEND=">=dev-python/jinja-2.1[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-migrate-0.8[${PYTHON_USEDEP}]
+ irc? ( dev-python/twisted-words[${PYTHON_USEDEP}] )
+ mail? ( dev-python/twisted-mail[${PYTHON_USEDEP}] )
+ manhole? ( dev-python/twisted-conch[${PYTHON_USEDEP}] )"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/twisted-mail[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ dev-python/twisted-words[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewuser buildbot
+
+ DOC_CONTENTS="The \"buildbot\" user and the \"buildmaster\" init script has been added
+ to support starting buildbot through Gentoo's init system. To use this,
+ set up your build master following the documentation, make sure the
+ resulting directories are owned by the \"buildbot\" user and point
+ \"${EROOT}etc/conf.d/buildmaster\" at the right location. The scripts can
+ run as a different user if desired. If you need to run more than one
+ build master, just copy the scripts."
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ #'man' target is currently broken
+ emake html
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman docs/buildbot.1
+
+ if use doc; then
+ dohtml -r docs/_build/html/
+ # TODO: install man pages
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r contrib docs/examples
+ fi
+
+ newconfd "${FILESDIR}/buildmaster.confd" buildmaster
+ newinitd "${FILESDIR}/buildmaster.initd" buildmaster
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ # In case of multiple masters, it's possible to edit web files
+ # so all master can share the changes. So protect them!
+ # If something else need to be protected, please open a bug
+ # on http://bugs.gentoo.org
+ local cp
+ add_config_protect() {
+ cp+=" $(python_get_sitedir)/${PN}/status/web"
+ }
+ python_execute_function -q add_config_protect
+ echo "CONFIG_PROTECT=\"${cp}\"" \
+ > 85${PN} || die
+ doenvd 85${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ elog
+ elog "Upstream recommends the following when upgrading:"
+ elog "Each time you install a new version of Buildbot, you should run the"
+ elog "\"buildbot upgrade-master\" command on each of your pre-existing build masters."
+ elog "This will add files and fix (or at least detect) incompatibilities between"
+ elog "your old config and the new code."
+}
diff --git a/dev-util/buildbot/buildbot-9999.ebuild b/dev-util/buildbot/buildbot-9999.ebuild
index fea3bc8fa158..555941650f3c 100644
--- a/dev-util/buildbot/buildbot-9999.ebuild
+++ b/dev-util/buildbot/buildbot-9999.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-9999.ebuild,v 1.6 2014/01/21 22:29:52 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-9999.ebuild,v 1.7 2014/10/18 15:19:24 hwoarang Exp $
EAPI="5"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-DISTUTILS_SRC_TEST="trial"
-DISTUTILS_DISABLE_TEST_DEPENDENCY="1"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
EGIT_REPO_URI="https://github.com/buildbot/${PN}.git"
[[ ${PV} = 9999 ]] && inherit git-2
-inherit distutils readme.gentoo user systemd
+inherit distutils-r1 readme.gentoo systemd user
MY_PV="${PV/_p/p}"
MY_P="${PN}-${MY_PV}"
@@ -29,31 +27,27 @@ else
fi
IUSE="doc examples irc mail manhole test"
-# sqlite3 module of Python 2.5 is not supported.
-RDEPEND=">=dev-python/jinja-2.1
- || ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )
- || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-python/pysqlite:2 )
- >=dev-python/twisted-core-8.0.0
- dev-python/twisted-web
- <dev-python/sqlalchemy-migrate-0.8
- irc? ( dev-python/twisted-words )
- mail? ( dev-python/twisted-mail )
- manhole? ( dev-python/twisted-conch )"
+RDEPEND=">=dev-python/jinja-2.1[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-migrate-0.8[${PYTHON_USEDEP}]
+ irc? ( dev-python/twisted-words[${PYTHON_USEDEP}] )
+ mail? ( dev-python/twisted-mail[${PYTHON_USEDEP}] )
+ manhole? ( dev-python/twisted-conch[${PYTHON_USEDEP}] )"
DEPEND="${DEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
- dev-python/python-dateutil
- dev-python/mock
- dev-python/twisted-mail
- dev-python/twisted-web
- dev-python/twisted-words
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/twisted-mail[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ dev-python/twisted-words[${PYTHON_USEDEP}]
)"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
- python_pkg_setup
enewuser buildbot
DOC_CONTENTS="The \"buildbot\" user and the \"buildmaster\" init script has been added
@@ -67,7 +61,7 @@ pkg_setup() {
src_compile() {
[[ ${PV} = 9999 ]] && cd master/
- distutils_src_compile
+ distutils-r1_src_compile
if use doc; then
einfo "Generation of documentation"
@@ -80,7 +74,7 @@ src_compile() {
src_install() {
[[ ${PV} = 9999 ]] && cd master/
- distutils_src_install
+ distutils-r1_src_install
doman docs/buildbot.1
@@ -116,7 +110,6 @@ src_install() {
pkg_postinst() {
[[ ${PV} = 9999 ]] && cd master/
- distutils_pkg_postinst
readme.gentoo_print_elog
elog
elog "Upstream recommends the following when upgrading:"