summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-21 12:41:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-21 12:41:45 +0000
commit52bc5cef36a9a6577c8f0a449ef579eb26ec7bbe (patch)
tree17656d2c20d5e8f347661d9fdedb9e483ad67508 /dev-util
parentamd64 stable, bug #306179 (diff)
downloadgentoo-2-52bc5cef36a9a6577c8f0a449ef579eb26ec7bbe.tar.gz
gentoo-2-52bc5cef36a9a6577c8f0a449ef579eb26ec7bbe.tar.bz2
gentoo-2-52bc5cef36a9a6577c8f0a449ef579eb26ec7bbe.zip
Bump, thanks to Priit Laes for porting the patches. Tests fail.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mono-debugger/ChangeLog10
-rw-r--r--dev-util/mono-debugger/files/mono-debugger-2.6-respect-cflags.patch34
-rw-r--r--dev-util/mono-debugger/files/mono-debugger-2.6-system-bfd.patch99
-rw-r--r--dev-util/mono-debugger/files/mono-debugger-2.6-system-libedit.patch91
-rw-r--r--dev-util/mono-debugger/mono-debugger-2.6.ebuild53
5 files changed, 286 insertions, 1 deletions
diff --git a/dev-util/mono-debugger/ChangeLog b/dev-util/mono-debugger/ChangeLog
index e43a5a83460a..299e2666fb36 100644
--- a/dev-util/mono-debugger/ChangeLog
+++ b/dev-util/mono-debugger/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/mono-debugger
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/ChangeLog,v 1.36 2010/02/05 09:52:13 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/ChangeLog,v 1.37 2010/02/21 12:41:45 patrick Exp $
+
+*mono-debugger-2.6 (21 Feb 2010)
+
+ 21 Feb 2010; Patrick Lauer <patrick@gentoo.org> +mono-debugger-2.6.ebuild,
+ +files/mono-debugger-2.6-respect-cflags.patch,
+ +files/mono-debugger-2.6-system-bfd.patch,
+ +files/mono-debugger-2.6-system-libedit.patch:
+ Bump, thanks to Priit Laes for porting the patches. Tests fail.
05 Feb 2010; Alexis Ballier <aballier@gentoo.org>
mono-debugger-2.4.2-r1.ebuild:
diff --git a/dev-util/mono-debugger/files/mono-debugger-2.6-respect-cflags.patch b/dev-util/mono-debugger/files/mono-debugger-2.6-respect-cflags.patch
new file mode 100644
index 000000000000..0f46b49e7c05
--- /dev/null
+++ b/dev-util/mono-debugger/files/mono-debugger-2.6-respect-cflags.patch
@@ -0,0 +1,34 @@
+From c396504c34d0e1648f7842c457b1db681b3b1b0b Mon Sep 17 00:00:00 2001
+From: Priit Laes <plaes@plaes.org>
+Date: Sun, 21 Feb 2010 14:04:48 +0200
+Subject: [PATCH 2/3] Respect cflags
+
+---
+ configure.in | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index e8ec185..ce0b609 100644
+--- a/configure.in
++++ b/configure.in
+@@ -106,7 +106,7 @@ AM_PROG_LIBTOOL
+ # not 64 bit clean in cross-compile
+ AC_CHECK_SIZEOF(void *, 4)
+
+-CFLAGS='-g -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Wshadow -Wpointer-arith -Wno-cast-qual -Wcast-align -Wwrite-strings -fno-strict-aliasing'
++CFLAGS="-g ${CFLAGS} -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Wshadow -Wpointer-arith -Wno-cast-qual -Wcast-align -Wwrite-strings -fno-strict-aliasing"
+
+ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
+ if test "x$PKG_CONFIG" = "xno"; then
+@@ -301,7 +301,7 @@ AM_CONDITIONAL(HAVE_XSP, test "x$with_xsp" = "xyes")
+ #not sure why, but I cannot get this test to pass on OS X.
+ if test x$platform != xi386darwin ; then
+ AC_MSG_CHECKING([Whether your Mono is working])
+-old_CFLAGS=$cflags
++old_CFLAGS=$CFLAGS
+ CFLAGS=$WRAPPER_CFLAGS
+ AC_TRY_COMPILE([#include <mono/metadata/mono-debug.h>
+ #include <mono/metadata/debug-mono-symfile.h>
+--
+1.7.0
+
diff --git a/dev-util/mono-debugger/files/mono-debugger-2.6-system-bfd.patch b/dev-util/mono-debugger/files/mono-debugger-2.6-system-bfd.patch
new file mode 100644
index 000000000000..14d757eb2189
--- /dev/null
+++ b/dev-util/mono-debugger/files/mono-debugger-2.6-system-bfd.patch
@@ -0,0 +1,99 @@
+From d9c203a8680e2e7088b29540fe64de08966bd86d Mon Sep 17 00:00:00 2001
+From: Priit Laes <plaes@plaes.org>
+Date: Sun, 21 Feb 2010 14:18:43 +0200
+Subject: [PATCH 3/3] Add option to use system bfd.
+
+---
+ backend/os/Makefile.am | 13 +++++++++++--
+ backend/os/bfdglue.c | 8 +++++++-
+ configure.in | 14 ++++++++++++++
+ 3 files changed, 32 insertions(+), 3 deletions(-)
+
+diff --git a/backend/os/Makefile.am b/backend/os/Makefile.am
+index 2a9f019..b4ca82c 100644
+--- a/backend/os/Makefile.am
++++ b/backend/os/Makefile.am
+@@ -1,15 +1,24 @@
++if !SYSTEM_LIBBFD
+ SUBDIRS = bfd
+
++libbfd_libs = bfd/opcodes/libopcodes.la bfd/libbfd.la
++libbfd_includes = -I$(srcdir)/bfd -I$(srcdir)/bfd/include -I$(srcdir)/bfd/opcodes
++else
++libbfd_libs = -lopcodes -lbfd
++libbfd_includes =
++endif
++
++
+ noinst_LTLIBRARIES = libmonodebuggerbfdglue.la
+
+ libmonodebuggerbfdglue_la_SOURCES = \
+ bfdglue.c \
+ bfdglue.h
+
+-libmonodebuggerbfdglue_la_LIBADD = bfd/opcodes/libopcodes.la bfd/libbfd.la @BASE_DEPENDENCIES_LIBS@
++libmonodebuggerbfdglue_la_LIBADD = $(libbfd_libs) @BASE_DEPENDENCIES_LIBS@
+ libmonodebuggerbfdglue_la_LDFLAGS = -no-undefined -module -export-dynamic -shared
+
+-INCLUDES = -I$(srcdir)/bfd -I$(srcdir)/bfd/include -I$(srcdir)/bfd/opcodes @BASE_DEPENDENCIES_CFLAGS@
++INCLUDES = $(libbfd_includes) @BASE_DEPENDENCIES_CFLAGS@
+
+ CLEANFILES = lib*.a lib*.dll
+
+diff --git a/backend/os/bfdglue.c b/backend/os/bfdglue.c
+index 9a741ac..e2138e7 100644
+--- a/backend/os/bfdglue.c
++++ b/backend/os/bfdglue.c
+@@ -1,3 +1,5 @@
++#include <config.h>
++
+ #include <bfdglue.h>
+ #include <signal.h>
+ #include <string.h>
+@@ -246,7 +248,11 @@ bfd_glue_get_errormsg (void)
+ guint32
+ bfd_glue_get_section_size (asection *p)
+ {
++#ifdef HAVE_ASECTION_RAWSIZE
++ return p->rawsize ? p->rawsize : p->size;
++#else
+ return p->_raw_size;
++#endif
+ }
+
+ BfdGlueSectionFlags
+@@ -350,4 +356,4 @@ guint64
+ bfd_glue_get_start_address (bfd *abfd)
+ {
+ return bfd_get_start_address (abfd);
+-}
+\ No newline at end of file
++}
+diff --git a/configure.in b/configure.in
+index ce0b609..6df7f05 100644
+--- a/configure.in
++++ b/configure.in
+@@ -64,6 +64,20 @@ case "$host" in
+ esac
+ AC_MSG_RESULT(ok)
+
++AC_ARG_WITH([system-libbfd],
++ AS_HELP_STRING([--with-system-libbfd], [Use the system copy of libbfd and libopcodes.]))
++
++AS_IF([test "x$with_system_libbfd" = "xyes"],
++ [
++ AC_CHECK_HEADERS([bfd.h], [], [AC_MSG_ERROR([Missing bfd.h header])])
++ AC_CHECK_LIB([bfd], [bfd_init], [:], [AC_MSG_ERROR([Missing libbfd library])])
++ AC_CHECK_LIB([opcodes], [init_disassemble_info], [:], [AC_MSG_ERROR([Missing libopcodes library])])
++ AC_CHECK_MEMBERS([asection.rawsize], [], [], [[#include <bfd.h>]])
++ ])
++
++AM_CONDITIONAL([SYSTEM_LIBBFD], [test "x$with_system_libbfd" = "xyes"])
++
++
+ AC_ARG_WITH(bfd-target,
+ [ --with-bfd-target Manually override the BFD target],
+ if test x$with_bfd_target != "x"; then
+--
+1.7.0
+
diff --git a/dev-util/mono-debugger/files/mono-debugger-2.6-system-libedit.patch b/dev-util/mono-debugger/files/mono-debugger-2.6-system-libedit.patch
new file mode 100644
index 000000000000..f7bdc22bd81a
--- /dev/null
+++ b/dev-util/mono-debugger/files/mono-debugger-2.6-system-libedit.patch
@@ -0,0 +1,91 @@
+From a857a6fb50605d6f3dddf814081dbbff59d64ba7 Mon Sep 17 00:00:00 2001
+From: Priit Laes <plaes@plaes.org>
+Date: Sun, 21 Feb 2010 14:01:49 +0200
+Subject: [PATCH 1/3] Use system-wide libedit library when requested.
+
+---
+ configure.in | 15 ++++++++++++++-
+ frontend/libedit/Makefile.am | 11 +++++++++--
+ frontend/libedit/mono-debugger-readline.h | 10 +++++++++-
+ 3 files changed, 32 insertions(+), 4 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 256afa9..e8ec185 100644
+--- a/configure.in
++++ b/configure.in
+@@ -262,7 +262,20 @@ AC_HEADER_DIRENT
+ AC_CHECK_FUNCS(fcntl getpagesize setitimer sysconf fdopen getuid getgid)
+ AC_CHECK_FUNCS(strlcpy strlcat fgetln)
+
+-CHECK_READLINE
++AC_ARG_WITH([system-libedit],
++ AS_HELP_STRING([--with-system-libedit], [Use the system copy of libedit.]))
++
++AS_IF([test "x$with_system_libedit" = "xyes"],
++ [
++ AC_CHECK_HEADERS([editline/readline.h libedit/readline.h], [found_libedit_header=yes; break;])
++ AS_IF([test "$found_libedit_header" != "yes"], [AC_MSG_ERROR([Missing libedit/readline.h header])])
++ AC_CHECK_LIB([edit], [el_init], [:], [AC_MSG_ERROR([Missing libedit library])])
++ ], [
++ CHECK_READLINE
++ ])
++
++AM_CONDITIONAL([SYSTEM_LIBEDIT], [test "x$with_system_libedit" = "xyes"])
++
+
+ min_mono_version=72
+ symfile_major_version=50
+diff --git a/frontend/libedit/Makefile.am b/frontend/libedit/Makefile.am
+index 9e03757..100cb88 100644
+--- a/frontend/libedit/Makefile.am
++++ b/frontend/libedit/Makefile.am
+@@ -1,14 +1,21 @@
+ lib_LTLIBRARIES = libmonodebuggerreadline.la
+
+ libmonodebuggerreadline_la_SOURCES = \
+- mono-debugger-readline.c mono-debugger-readline.h readline.c readline.h \
++ mono-debugger-readline.c mono-debugger-readline.h
++
++if SYSTEM_LIBEDIT
++libedit_libs = -ledit
++else
++libedit_libs = @READLINE_DEPLIBS@
++libmonodebuggerreadline_la_SOURCES += readline.c readline.h \
+ chared.c common.c el.c emacs.c fcns.c help.c hist.c history.c key.c map.c \
+ parse.c prompt.c read.c refresh.c search.c sig.c term.c tty.c vi.c vis.c unvis.c \
+ strlcpy.c strlcat.c chared.h common.h el.h emacs.h fcns.h help.h histedit.h hist.h \
+ key.h map.h parse.h prompt.h read.h refresh.h search.h sig.h sys.h term.h tty.h \
+ vi.h vis.h el_term.h filecomplete.h tokenizer.c filecomplete.c
++endif
+
+-libmonodebuggerreadline_la_LIBADD = @BASE_DEPENDENCIES_LIBS@ @READLINE_DEPLIBS@
++libmonodebuggerreadline_la_LIBADD = @BASE_DEPENDENCIES_LIBS@ $(libedit_libs)
+ if PLATFORM_X86_DARWIN
+ libmonodebuggerreadline_la_LDFLAGS = -no-undefined -shared -Wl
+ else
+diff --git a/frontend/libedit/mono-debugger-readline.h b/frontend/libedit/mono-debugger-readline.h
+index c547c75..1a854cc 100644
+--- a/frontend/libedit/mono-debugger-readline.h
++++ b/frontend/libedit/mono-debugger-readline.h
+@@ -1,9 +1,17 @@
+ #ifndef __MONO_DEBUGGER_READLINE_H__
+ #define __MONO_DEBUGGER_READLINE_H__
+
++#include <config.h>
++
+ #include <glib.h>
+ #include <stdio.h>
+-#include <readline.h>
++#if defined(HAVE_LIBEDIT_READLINE_H)
++# include <libedit/readline.h>
++#elif defined(HAVE_LIBEDIT_READLINE_H)
++# include <libedit/readline.h>
++#else
++# include "readline.h"
++#endif
+
+ G_BEGIN_DECLS
+
+--
+1.7.0
+
diff --git a/dev-util/mono-debugger/mono-debugger-2.6.ebuild b/dev-util/mono-debugger/mono-debugger-2.6.ebuild
new file mode 100644
index 000000000000..1e65c0540240
--- /dev/null
+++ b/dev-util/mono-debugger/mono-debugger-2.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-debugger/mono-debugger-2.6.ebuild,v 1.1 2010/02/21 12:41:45 patrick Exp $
+
+# bah, tests fail. Needs to be fixed ...
+RESTRICT="test"
+
+EAPI=2
+
+PATCHLEVEL=1
+
+inherit go-mono mono autotools flag-o-matic eutils
+
+DESCRIPTION="Debugger for .NET managed and unmanaged applications"
+HOMEPAGE="http://www.go-mono.com"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+IUSE=""
+
+# Binutils is needed for libbfd
+RDEPEND="!!=dev-lang/mono-2.2
+ >=dev-libs/libedit-20090111
+ sys-devel/binutils
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ !dev-lang/mercury"
+
+src_prepare() {
+ go-mono_src_prepare
+
+ epatch "${FILESDIR}/${P}-respect-cflags.patch" \
+ "${FILESDIR}/${P}-system-bfd.patch" \
+ "${FILESDIR}/${P}-system-libedit.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ # Let's go for extra safety to avoid runtime errors, until
+ # upstream applies it.
+ append-ldflags -Wl,--no-undefined
+
+ go-mono_src_configure \
+ --with-system-libbfd \
+ --with-system-libedit \
+ --disable-static
+}
+
+src_compile() {
+ emake -j1 || die "Failed to build"
+}