summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-09-13 19:39:26 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-09-13 19:39:26 +0000
commit4ad95e255ed47570dd96d6596a9afbc59672d454 (patch)
treebdfb17493ebede95cac7a43366c95df88765614f /dev-util
parentMask monolithic XOrg. (diff)
downloadgentoo-2-4ad95e255ed47570dd96d6596a9afbc59672d454.tar.gz
gentoo-2-4ad95e255ed47570dd96d6596a9afbc59672d454.tar.bz2
gentoo-2-4ad95e255ed47570dd96d6596a9afbc59672d454.zip
New upstream version.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog7
-rw-r--r--dev-util/git/files/digest-git-1.4.2.19
-rw-r--r--dev-util/git/git-1.4.2.1.ebuild151
3 files changed, 166 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 03385af3d101..50ea1cf7ad73 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/git
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.120 2006/09/11 08:09:32 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.121 2006/09/13 19:39:26 ferdy Exp $
+
+*git-1.4.2.1 (13 Sep 2006)
+
+ 13 Sep 2006; Fernando J. Pereda <ferdy@gentoo.org> +git-1.4.2.1.ebuild:
+ New upstream version.
11 Sep 2006; Fernando J. Pereda <ferdy@gentoo.org>
+files/git-daemon.xinetd, git-1.4.2.ebuild:
diff --git a/dev-util/git/files/digest-git-1.4.2.1 b/dev-util/git/files/digest-git-1.4.2.1
new file mode 100644
index 000000000000..bf27255fa69f
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.4.2.1
@@ -0,0 +1,9 @@
+MD5 f37cd32f0ded29419ceb3d79c169acf5 git-1.4.2.1.tar.bz2 788009
+RMD160 87e08d45d27ccea9c5b55fab42089f08b73f33ed git-1.4.2.1.tar.bz2 788009
+SHA256 751469b75c2db3c551f0dedee78502d0f746031a2091d64cb69c06e8ca34cdaf git-1.4.2.1.tar.bz2 788009
+MD5 3eab7c8243236cbbf288d01e9195b8a0 git-htmldocs-1.4.2.1.tar.bz2 284106
+RMD160 f732ba75aab41a66809cb77736094188011a7f27 git-htmldocs-1.4.2.1.tar.bz2 284106
+SHA256 9205111032c68e45f000755c61077d6a99225c287d16f3ad4b21ccf72c22e5e7 git-htmldocs-1.4.2.1.tar.bz2 284106
+MD5 272014b78bd3566a6099f87a6859887f git-manpages-1.4.2.1.tar.bz2 90423
+RMD160 61c469d24caa25a535fe985aa3716280c73e1f5d git-manpages-1.4.2.1.tar.bz2 90423
+SHA256 86acc0acb5ed81acde3a995a826d208a66e6662f6182f3cdae76c2c5007e630b git-manpages-1.4.2.1.tar.bz2 90423
diff --git a/dev-util/git/git-1.4.2.1.ebuild b/dev-util/git/git-1.4.2.1.ebuild
new file mode 100644
index 000000000000..7e4e3b61c9aa
--- /dev/null
+++ b/dev-util/git/git-1.4.2.1.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.4.2.1.ebuild,v 1.1 2006/09/13 19:39:26 ferdy Exp $
+
+inherit python toolchain-funcs eutils elisp-common
+
+DOC_VER=${PV}
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="mirror://kernel/software/scm/git/${P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="curl doc emacs gtk mozsha1 ppcsha1 tk webdav"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !app-misc/git
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ >=dev-lang/python-2.3
+ app-text/rcs
+ tk? ( dev-lang/tk )
+ gtk? ( >=dev-python/pygtk-2.6 )"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ # Older python versions need own subproccess.py
+ python_version
+ [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
+
+ use elibc_uclibc && myopts="${myopts} NO_ICONV=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || die "make install failed"
+
+ use tk || rm "${D}"/usr/bin/gitk
+
+ doman "${WORKDIR}"/man?/*
+
+ dodoc README COPYING Documentation/SubmittingPatches
+ if use doc ; then
+ dodoc Documentation/technical/*
+ dodir /usr/share/doc/${PF}/html
+ cp -r "${WORKDIR}"/{*.html,howto} "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ if use emacs ; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/{,vc-}git.el*
+ elisp-site-file-install "${FILESDIR}"/70git-gentoo.el
+ fi
+
+ if use gtk ; then
+ dobin contrib/gitview/gitview
+ use doc && dodoc contrib/gitview/gitview.txt
+ fi
+
+ insinto /etc/xinet.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+}
+
+src_test() {
+ cd "${S}"
+
+ has_version dev-util/subversion || \
+ MY_MAKEOPTS="${MY_MAKEOPTS} NO_SVN_TESTS=YesPlease"
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ einfo
+ einfo "If you want to import arch repositories into git, consider using the"
+ einfo "git-archimport command. You should install dev-util/tla before."
+ einfo
+ einfo "If you want to import cvs repositories into git, consider using the"
+ einfo "git-cvsimport command. You should install >=dev-util/cvsps-2.1 before."
+ einfo
+ einfo "If you want to import svn repositories into git, consider using the"
+ einfo "git-svnimport command. You should install dev-util/subversion before."
+ einfo
+ einfo "If you want to manage subversion repositories using git, consider"
+ einfo "using git-svn. You should install dev-util/subversion and dev-perl/libwww-perl."
+ einfo
+ einfo "If you want to import a quilt series into git, consider using the"
+ einfo "git-quiltimport command. You should install dev-util/quilt before."
+ einfo
+ einfo "If you want to use the included CVS server you will need to install"
+ einfo "dev-perl/DBI and dev-perl/DBD-SQLite."
+ einfo
+}
+
+pkg_postrm() {
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}