summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Gaffney <agaffney@gentoo.org>2008-12-07 22:31:31 +0000
committerAndrew Gaffney <agaffney@gentoo.org>2008-12-07 22:31:31 +0000
commit37818a02d884793b88436f1b4d2475aad67ad81d (patch)
treebf5cde05b46272811205d1deb1daacdfd19fea88 /dev-util
parentVersion bump to testing version 3.4.10.902 (diff)
downloadgentoo-2-37818a02d884793b88436f1b4d2475aad67ad81d.tar.gz
gentoo-2-37818a02d884793b88436f1b4d2475aad67ad81d.tar.bz2
gentoo-2-37818a02d884793b88436f1b4d2475aad67ad81d.zip
Version bump to testing version 2.0.6.902
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.22-gentoo-r6 x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catalyst/ChangeLog8
-rw-r--r--dev-util/catalyst/catalyst-2.0.6.902.ebuild94
2 files changed, 101 insertions, 1 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index 07a1ebb67a32..49589f286d26 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/catalyst
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.205 2008/10/11 03:01:54 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.206 2008/12/07 22:31:31 agaffney Exp $
+
+*catalyst-2.0.6.902 (07 Dec 2008)
+
+ 07 Dec 2008; Andrew Gaffney <agaffney@gentoo.org>
+ +catalyst-2.0.6.902.ebuild:
+ Version bump to testing version 2.0.6.902
11 Oct 2008; Robin H. Johnson <robbat2@gentoo.org> catalyst-9999.ebuild:
Move live ebuild to using new Git per bug #236145
diff --git a/dev-util/catalyst/catalyst-2.0.6.902.ebuild b/dev-util/catalyst/catalyst-2.0.6.902.ebuild
new file mode 100644
index 000000000000..043e487384e3
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.6.902.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.902.ebuild,v 1.1 2008/12/07 22:31:31 agaffney Exp $
+
+# catalyst-9999 -> latest SVN
+# catalyst-9999.REV -> use SVN REV
+# catalyst-VER -> normal catalyst release
+
+if [[ ${PV} == 9999* ]]
+then
+ [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999./}"
+ ESVN_REPO_URI="svn://anonsvn.gentoo.org/catalyst/trunk"
+ inherit subversion eutils multilib
+ SRC_URI=""
+ S=${WORKDIR}/trunk
+else
+ inherit eutils multilib
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://wolf31o2.org/sources/${PN}/${P}.tar.bz2"
+fi
+
+DESCRIPTION="release metatool used for creating Gentoo releases"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+#KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+#KEYWORDS=""
+RESTRICT=""
+IUSE="ccache"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
+ ia64? ( sys-fs/dosfstools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+}
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ cd "${S}"
+ fi
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/${PN}
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe catalyst || die "copying catalyst"
+ doins -r arch modules livecd || die "copying files"
+ for x in targets/*; do
+ exeinto /usr/$(get_libdir)/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README ChangeLog AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+ dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}