summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-06-06 14:57:39 +0000
committerRémi Cardona <remi@gentoo.org>2008-06-06 14:57:39 +0000
commit1f80e0d18fd6dd2744d7749ec0ffa55208819343 (patch)
tree7f8bbcc5ddf18f2fea01c2645d9005139b09c170 /dev-util
parentRemove useless DLZ_VERSION (diff)
downloadgentoo-2-1f80e0d18fd6dd2744d7749ec0ffa55208819343.tar.gz
gentoo-2-1f80e0d18fd6dd2744d7749ec0ffa55208819343.tar.bz2
gentoo-2-1f80e0d18fd6dd2744d7749ec0ffa55208819343.zip
dev-util/gtk-doc: Don't install the gnome/yelp help files (bug #224519)
(Portage version: 2.1.5.4, RepoMan options: --force)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gtk-doc/ChangeLog7
-rw-r--r--dev-util/gtk-doc/gtk-doc-1.10-r2.ebuild83
2 files changed, 89 insertions, 1 deletions
diff --git a/dev-util/gtk-doc/ChangeLog b/dev-util/gtk-doc/ChangeLog
index fdd23c06f13f..afff1ac846a4 100644
--- a/dev-util/gtk-doc/ChangeLog
+++ b/dev-util/gtk-doc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/gtk-doc
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/ChangeLog,v 1.96 2008/05/25 12:34:51 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/ChangeLog,v 1.97 2008/06/06 14:57:39 remi Exp $
+
+*gtk-doc-1.10-r2 (06 Jun 2008)
+
+ 06 Jun 2008; Rémi Cardona <remi@gentoo.org> +gtk-doc-1.10-r2.ebuild:
+ Don't install the gnome/yelp help files (bug #224519)
25 May 2008; Markus Meier <maekke@gentoo.org> gtk-doc-1.10-r1.ebuild:
amd64/x86 stable, bug #223297
diff --git a/dev-util/gtk-doc/gtk-doc-1.10-r2.ebuild b/dev-util/gtk-doc/gtk-doc-1.10-r2.ebuild
new file mode 100644
index 000000000000..4f755c5e2e70
--- /dev/null
+++ b/dev-util/gtk-doc/gtk-doc-1.10-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/gtk-doc-1.10-r2.ebuild,v 1.1 2008/06/06 14:57:39 remi Exp $
+
+inherit eutils elisp-common gnome2
+
+DESCRIPTION="GTK+ Documentation Generator"
+HOMEPAGE="http://www.gtk.org/gtk-doc/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~hppa ~ia64 ~m68k ~mips ppc ~ppc64 ~s390 ~sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE="doc emacs"
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=app-text/openjade-1.3.1
+ dev-libs/libxslt
+ >=dev-libs/libxml2-2.3.6
+ ~app-text/docbook-xml-dtd-4.1.2
+ app-text/docbook-xsl-stylesheets
+ ~app-text/docbook-sgml-dtd-3.0
+ >=app-text/docbook-dsssl-stylesheets-1.40
+ emacs? ( virtual/emacs )"
+
+DEPEND="${RDEPEND}
+ =dev-util/gtk-doc-am-${PV}*
+ >=dev-util/pkgconfig-0.19
+ >=app-text/scrollkeeper-0.3.5"
+
+SITEFILE=61${PN}-gentoo.el
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+
+# Revisit this in next version. Might be related to upstream bug 521784 and/or 485806
+RESTRICT="test"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Remove global Emacs keybindings.
+ epatch "${FILESDIR}"/${PN}-1.8-emacs-keybindings.patch
+
+ # Don't install gtk-doc.m4; it's in gtk-doc-am now
+ epatch "${FILESDIR}"/${PN}-1.10-no-m4.patch
+
+ # Don't install the gnome/yelp help files (bug #224519)
+ sed -e "s/SUBDIRS = manual//" -i help/Makefile.in
+}
+
+src_compile() {
+ gnome2_src_compile
+
+ use emacs && elisp-compile tools/gtk-doc.el
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc; then
+ docinto doc
+ dodoc doc/*
+ docinto examples
+ dodoc examples/*
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} tools/gtk-doc.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ elog "gtk-doc does no longer define global key bindings for Emacs."
+ elog "You may set your own key bindings for \"gtk-doc-insert\" and"
+ elog "\"gtk-doc-insert-section\" in your ~/.emacs file."
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}