summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-03-29 09:24:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-03-29 09:24:42 +0000
commitbd6d0e1b607c066588d8a8399547177d0efe7328 (patch)
treef05523fdd0c33583dc8fc3f1d84583b06ccdeaef /dev-util/setconf
parentRequire kernel 3.7 temporarily due to unconditional use of newer defines. (diff)
downloadgentoo-2-bd6d0e1b607c066588d8a8399547177d0efe7328.tar.gz
gentoo-2-bd6d0e1b607c066588d8a8399547177d0efe7328.tar.bz2
gentoo-2-bd6d0e1b607c066588d8a8399547177d0efe7328.zip
Version bump. Use python 3.x exclusively wrt #462326 by James Rowe
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-util/setconf')
-rw-r--r--dev-util/setconf/ChangeLog10
-rw-r--r--dev-util/setconf/setconf-0.6.2.ebuild32
2 files changed, 39 insertions, 3 deletions
diff --git a/dev-util/setconf/ChangeLog b/dev-util/setconf/ChangeLog
index cbb1f57a2b53..3a10a5174c12 100644
--- a/dev-util/setconf/ChangeLog
+++ b/dev-util/setconf/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for dev-util/setconf
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/setconf/ChangeLog,v 1.1 2013/03/16 18:51:02 ssuominen Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/setconf/ChangeLog,v 1.2 2014/03/29 09:24:42 ssuominen Exp $
+
+*setconf-0.6.2 (29 Mar 2014)
+
+ 29 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> +setconf-0.6.2.ebuild:
+ Version bump. Use python 3.x exclusively wrt #462326 by James Rowe
*setconf-0.5.3 (16 Mar 2013)
16 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> +setconf-0.5.3.ebuild:
Initial commit.
-
diff --git a/dev-util/setconf/setconf-0.6.2.ebuild b/dev-util/setconf/setconf-0.6.2.ebuild
new file mode 100644
index 000000000000..98a815f7db7b
--- /dev/null
+++ b/dev-util/setconf/setconf-0.6.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/setconf/setconf-0.6.2.ebuild,v 1.1 2014/03/29 09:24:42 ssuominen Exp $
+
+EAPI=5
+
+DESCRIPTION="A small python based utility that can be used to change configuration files"
+HOMEPAGE="http://setconf.roboticoverlords.org/"
+SRC_URI="http://${PN}.roboticoverlords.org/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/python-3*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unpack ./${PN}.1.gz
+}
+
+src_prepare() {
+ sed -i -e 's:/usr/bin/python:/usr/bin/python3:' ${PN}.py || die #462326
+}
+
+src_install() {
+ dobin ${PN}.py
+ ln -s ${PN}.py "${ED}"/usr/bin/${PN}
+ doman ${PN}.1
+}