summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-03-30 00:15:04 +0000
committerJeroen Roovers <jer@gentoo.org>2010-03-30 00:15:04 +0000
commitc06c4ab8a8547826f8c438e8f691c602ec03ffdc (patch)
tree3a70380c296ea6215cdad7787e6cfed80d781529 /dev-util/rootstrap/rootstrap-0.3.24_p5.ebuild
parentNew gnome- and kde-only USE flags (diff)
downloadgentoo-2-c06c4ab8a8547826f8c438e8f691c602ec03ffdc.tar.gz
gentoo-2-c06c4ab8a8547826f8c438e8f691c602ec03ffdc.tar.bz2
gentoo-2-c06c4ab8a8547826f8c438e8f691c602ec03ffdc.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'dev-util/rootstrap/rootstrap-0.3.24_p5.ebuild')
-rw-r--r--dev-util/rootstrap/rootstrap-0.3.24_p5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/rootstrap/rootstrap-0.3.24_p5.ebuild b/dev-util/rootstrap/rootstrap-0.3.24_p5.ebuild
new file mode 100644
index 000000000000..beab0fd6793e
--- /dev/null
+++ b/dev-util/rootstrap/rootstrap-0.3.24_p5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rootstrap/rootstrap-0.3.24_p5.ebuild,v 1.1 2010/03/30 00:15:04 jer Exp $
+
+inherit eutils
+
+DESCRIPTION="A tool for building complete Linux filesystem images"
+HOMEPAGE="http://packages.qa.debian.org/rootstrap"
+SRC_URI="mirror://debian/pool/main/r/${PN}/${PN}_${PV/_p*}.orig.tar.gz
+ mirror://debian/pool/main/r/${PN}/${PN}_${PV/_p/-}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-util/debootstrap
+ dev-lang/python
+ app-arch/dpkg"
+DEPEND="${RDEPEND}
+ app-text/docbook-sgml-utils"
+
+RESTRICT="test"
+
+S="${WORKDIR}"/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${PN}_${PV/_p/-}.diff
+ sed -i -e 's:docbook-to-man:docbook2man:' Makefile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ newdoc debian/changelog ChangeLog
+}