summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-11 12:28:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-11 12:28:28 +0000
commitff6f9c9fa57ca13f36ede468f7b15bc55741efd5 (patch)
tree754daec24304b7ba18ba0e3287ca58f43ca42796 /dev-util/pkgconfig
parentstable x86, bug 323471 (diff)
downloadgentoo-2-ff6f9c9fa57ca13f36ede468f7b15bc55741efd5.tar.gz
gentoo-2-ff6f9c9fa57ca13f36ede468f7b15bc55741efd5.tar.bz2
gentoo-2-ff6f9c9fa57ca13f36ede468f7b15bc55741efd5.zip
Fix for sys-devel/autoconf-2.66 compat (but commit unkeyworded until it's sorted out).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/pkgconfig')
-rw-r--r--dev-util/pkgconfig/ChangeLog9
-rw-r--r--dev-util/pkgconfig/files/pkgconfig-0.25-dnl.patch22
-rw-r--r--dev-util/pkgconfig/pkgconfig-0.25-r2.ebuild46
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-util/pkgconfig/ChangeLog b/dev-util/pkgconfig/ChangeLog
index cc09dce36bc7..9d81d6ed8a05 100644
--- a/dev-util/pkgconfig/ChangeLog
+++ b/dev-util/pkgconfig/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/pkgconfig
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.81 2010/06/17 12:49:27 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.82 2010/07/11 12:28:28 ssuominen Exp $
+
+*pkgconfig-0.25-r2 (11 Jul 2010)
+
+ 11 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +pkgconfig-0.25-r2.ebuild, +files/pkgconfig-0.25-dnl.patch:
+ Fix for sys-devel/autoconf-2.66 compat (but commit unkeyworded until it's
+ sorted out).
*pkgconfig-0.25-r1 (17 Jun 2010)
diff --git a/dev-util/pkgconfig/files/pkgconfig-0.25-dnl.patch b/dev-util/pkgconfig/files/pkgconfig-0.25-dnl.patch
new file mode 100644
index 000000000000..3dc6b6e22a5c
--- /dev/null
+++ b/dev-util/pkgconfig/files/pkgconfig-0.25-dnl.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/326939
+
+--- pkg.m4
++++ pkg.m4
+@@ -135,7 +135,7 @@
+ Consider adjusting the PKG_CONFIG_PATH environment variable if you
+ installed software in a non-standard prefix.
+
+-_PKG_TEXT])dnl
++_PKG_TEXT])
+ ])
+ elif test $pkg_failed = untried; then
+ AC_MSG_RESULT([no])
+@@ -146,7 +146,7 @@
+
+ _PKG_TEXT
+
+-To get pkg-config, see <http://pkg-config.freedesktop.org/>.])dnl
++To get pkg-config, see <http://pkg-config.freedesktop.org/>.])
+ ])
+ else
+ $1[]_CFLAGS=$pkg_cv_[]$1[]_CFLAGS
diff --git a/dev-util/pkgconfig/pkgconfig-0.25-r2.ebuild b/dev-util/pkgconfig/pkgconfig-0.25-r2.ebuild
new file mode 100644
index 000000000000..7978378de8fc
--- /dev/null
+++ b/dev-util/pkgconfig/pkgconfig-0.25-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.25-r2.ebuild,v 1.1 2010/07/11 12:28:28 ssuominen Exp $
+
+EAPI=2
+inherit eutils flag-o-matic
+
+MY_P=pkg-config-${PV}
+
+DESCRIPTION="Package config system that manages compile/link flags"
+HOMEPAGE="http://pkgconfig.freedesktop.org/wiki/"
+SRC_URI="http://pkgconfig.freedesktop.org/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="elibc_FreeBSD hardened"
+
+DEPEND=">=dev-libs/popt-1.15"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # XXX: Bug in autoconf 2.66, or pkg-config?
+ epatch "${FILESDIR}"/${P}-dnl.patch
+}
+
+src_configure() {
+ use ppc64 && use hardened && replace-flags -O[2-3] -O1
+
+ # Force using all the requirements when linking, so that needed -pthread
+ # lines are inherited between libraries
+ local myconf
+ use elibc_FreeBSD && myconf="--enable-indirect-deps"
+
+ econf \
+ --docdir=/usr/share/doc/${PF}/html \
+ --with-installed-popt \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}