summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2005-12-22 01:20:01 +0000
committerJoe McCann <joem@gentoo.org>2005-12-22 01:20:01 +0000
commit0745369fa99cb0e80909016ebca04f58373cbe68 (patch)
tree55b3767833777e995ab7eecc295b7872db4c6b20 /dev-util/pkgconfig/pkgconfig-0.20.ebuild
parentAdd patch to fix build on PPC systems. (diff)
downloadgentoo-2-0745369fa99cb0e80909016ebca04f58373cbe68.tar.gz
gentoo-2-0745369fa99cb0e80909016ebca04f58373cbe68.tar.bz2
gentoo-2-0745369fa99cb0e80909016ebca04f58373cbe68.zip
version bump, closes bug 113290
(Portage version: 2.1_pre1)
Diffstat (limited to 'dev-util/pkgconfig/pkgconfig-0.20.ebuild')
-rw-r--r--dev-util/pkgconfig/pkgconfig-0.20.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/pkgconfig/pkgconfig-0.20.ebuild b/dev-util/pkgconfig/pkgconfig-0.20.ebuild
new file mode 100644
index 000000000000..5a69ed29710a
--- /dev/null
+++ b/dev-util/pkgconfig/pkgconfig-0.20.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.20.ebuild,v 1.1 2005/12/22 01:20:01 joem Exp $
+
+inherit flag-o-matic
+
+MY_P="pkg-config"-${PV}
+DESCRIPTION="Package config system that manages compile/link flags"
+HOMEPAGE="http://pkgconfig.freedesktop.org/wiki/"
+
+SRC_URI="http://pkgconfig.freedesktop.org/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="hardened"
+
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+
+src_unpack() {
+ unpack "${A}"
+
+ use ppc64 && use hardened && replace-flags -O[2-3] -O1
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+}