summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-12-10 20:58:08 +0000
committerMike Frysinger <vapier@gentoo.org>2011-12-10 20:58:08 +0000
commit14986d8254b6e7983a079e79e3ae9f1482f00fe4 (patch)
treea2551d07b2fb9e83f027c886db230754c13ca406 /dev-util/mingw-runtime
parentStabilize for amd64/x86. (diff)
downloadgentoo-2-14986d8254b6e7983a079e79e3ae9f1482f00fe4.tar.gz
gentoo-2-14986d8254b6e7983a079e79e3ae9f1482f00fe4.tar.bz2
gentoo-2-14986d8254b6e7983a079e79e3ae9f1482f00fe4.zip
Version bump.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/mingw-runtime')
-rw-r--r--dev-util/mingw-runtime/ChangeLog9
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-3.20.ebuild76
2 files changed, 83 insertions, 2 deletions
diff --git a/dev-util/mingw-runtime/ChangeLog b/dev-util/mingw-runtime/ChangeLog
index 83f08b59d42e..b89cf92f9863 100644
--- a/dev-util/mingw-runtime/ChangeLog
+++ b/dev-util/mingw-runtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/mingw-runtime
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/ChangeLog,v 1.21 2010/09/22 22:22:49 vapier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/ChangeLog,v 1.22 2011/12/10 20:58:08 vapier Exp $
+
+*mingw-runtime-3.20 (10 Dec 2011)
+
+ 10 Dec 2011; Mike Frysinger <vapier@gentoo.org> +mingw-runtime-3.20.ebuild:
+ Version bump.
22 Sep 2010; Mike Frysinger <vapier@gentoo.org> mingw-runtime-3.18.ebuild:
Mark amd64/x86 stable.
diff --git a/dev-util/mingw-runtime/mingw-runtime-3.20.ebuild b/dev-util/mingw-runtime/mingw-runtime-3.20.ebuild
new file mode 100644
index 000000000000..b78d963998db
--- /dev/null
+++ b/dev-util/mingw-runtime/mingw-runtime-3.20.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/mingw-runtime-3.20.ebuild,v 1.1 2011/12/10 20:58:08 vapier Exp $
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+inherit flag-o-matic
+
+MY_P="mingwrt-${PV}-mingw32"
+DESCRIPTION="Free Win32 runtime and import library definitions"
+HOMEPAGE="http://www.mingw.org/"
+# http://sourceforge.net/projects/mingw/files/MinGW/Base/mingw-rt/
+SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="crosscompile_opts_headers-only"
+RESTRICT="strip"
+
+S=${WORKDIR}/${MY_P}
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+just_headers() {
+ use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
+}
+
+pkg_setup() {
+ if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
+ die "Invalid configuration"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/W32API_INCLUDE/s:=.*:='-I /usr/${CTARGET}/usr/include':" \
+ $(find -name configure) || die
+ sed -i \
+ -e '/^install_dlls_host:/s:$: install-dirs:' \
+ Makefile.in || die # fix parallel install
+}
+
+src_compile() {
+ just_headers && return 0
+
+ CHOST=${CTARGET} strip-unsupported-flags
+ econf --host=${CTARGET} || die
+ emake || die
+}
+
+src_install() {
+ if just_headers ; then
+ insinto /usr/${CTARGET}/usr/include
+ doins -r include/* || die
+ else
+ local insdir
+ is_crosscompile \
+ && insdir="${D}/usr/${CTARGET}" \
+ || insdir="${D}"
+ emake install DESTDIR="${insdir}" || die
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ rm -rf "${insdir}"/usr/doc
+ dodoc CONTRIBUTORS ChangeLog README TODO readme.txt
+ fi
+ is_crosscompile && dosym usr /usr/${CTARGET}/mingw
+}