summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-09-06 21:28:40 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-09-06 21:28:40 +0000
commitca068075cd43594f3fdfa3466f3dbabc791f62de (patch)
tree09b92bc65a1bfc7cd015b291a24542c3637f91a4 /dev-util/guile/guile-1.6.4-r1.ebuild
parentclosing bug #23493 (GUILE_LOAD_PATH in env now) (diff)
downloadgentoo-2-ca068075cd43594f3fdfa3466f3dbabc791f62de.tar.gz
gentoo-2-ca068075cd43594f3fdfa3466f3dbabc791f62de.tar.bz2
gentoo-2-ca068075cd43594f3fdfa3466f3dbabc791f62de.zip
closing bug #23493 (GUILE_LOAD_PATH in env now)
Diffstat (limited to 'dev-util/guile/guile-1.6.4-r1.ebuild')
-rw-r--r--dev-util/guile/guile-1.6.4-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/guile/guile-1.6.4-r1.ebuild b/dev-util/guile/guile-1.6.4-r1.ebuild
new file mode 100644
index 000000000000..02a11ce2f419
--- /dev/null
+++ b/dev-util/guile/guile-1.6.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.6.4-r1.ebuild,v 1.1 2003/09/06 21:28:37 drobbins Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Scheme interpreter"
+SRC_URI="mirror://gnu/guile/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/guile/"
+
+IUSE=""
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~alpha hppa"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ >=sys-libs/readline-4.1"
+
+# NOTE: in README-PACKAGERS, guile recommends different versions be installed
+# in parallel. They're talking about LIBRARY MAJOR versions and not
+# the actual guile version that was used in the past.
+#
+# So I'm slotting this as 12 beacuse of the library major version
+
+SLOT="12"
+MAJOR="1.6"
+
+src_compile() {
+ # Fix for bug 26484: This package fails to build when built with
+ # -g3, at least on some architectures. (19 Aug 2003 agriffis)
+ filter-flags -g3
+
+ econf \
+ --with-threads \
+ --with-modules || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README SNAPSHOTS THANKS
+ #texmacs needs this, closing bug #23493
+ dodir /etc/env.d
+ #We don't slot the env.d entry because /usr/bin/guile-config is there anyway,
+ #and will only match the last guile installed. so the GUILE_LOAD_PATH will
+ #match the data available from guile-config.
+ echo "GUILE_LOAD_PATH=\"/usr/share/guile/${MAJOR}\"" > ${D}/etc/env.d/50guile
+}