summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-04-06 01:02:28 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-04-06 01:02:28 +0000
commitd06b6e2c65262a290ebed82e59830f57970920d2 (patch)
treef889216ae74725acbcb96958e5cbdbe39e4a84ad /dev-util/gtk-doc/gtk-doc-1.3-r1.ebuild
parentupdated gcc4 patch (diff)
downloadgentoo-2-d06b6e2c65262a290ebed82e59830f57970920d2.tar.gz
gentoo-2-d06b6e2c65262a290ebed82e59830f57970920d2.tar.bz2
gentoo-2-d06b6e2c65262a290ebed82e59830f57970920d2.zip
New revision, with a patch that resolves bug #86716 et.al.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-util/gtk-doc/gtk-doc-1.3-r1.ebuild')
-rw-r--r--dev-util/gtk-doc/gtk-doc-1.3-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/gtk-doc/gtk-doc-1.3-r1.ebuild b/dev-util/gtk-doc/gtk-doc-1.3-r1.ebuild
new file mode 100644
index 000000000000..24daef221bea
--- /dev/null
+++ b/dev-util/gtk-doc/gtk-doc-1.3-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/gtk-doc-1.3-r1.ebuild,v 1.1 2005/04/06 01:02:28 leonardop Exp $
+
+inherit eutils elisp-common gnome.org
+
+DESCRIPTION="GTK+ Documentation Generator"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64 ~s390"
+IUSE="emacs"
+
+DEPEND=">=app-text/openjade-1.3.1
+ =app-text/docbook-sgml-dtd-3.0*
+ =app-text/docbook-xml-dtd-4.1.2*
+ app-text/docbook-xsl-stylesheets
+ >=app-text/docbook-dsssl-stylesheets-1.40
+ >=dev-lang/perl-5.6
+ >=dev-libs/libxml2-2.3.6
+ dev-libs/libxslt
+ !app-text/xhtml1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix SGML declaration that was breaking compilation in some packages. See
+ # bug #86716.
+ epatch ${FILESDIR}/${P}-declaration.patch
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog MAINTAINERS NEWS README TODO
+ docinto doc
+ dodoc doc/*
+ docinto examples
+ dodoc examples/*
+
+ if use emacs
+ then
+ elisp-compile tools/gtk-doc.el
+ elisp-install ${PN} tools/gtk-doc.el*
+ fi
+}