summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-04-11 22:29:16 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-04-11 22:29:16 +0000
commitc14e1c161d56ccaf9815ca8021dc9d96c933149a (patch)
tree4ae69aeec8be9c78ae2ab5915336cec3200f6649 /dev-util/gruntspud
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-c14e1c161d56ccaf9815ca8021dc9d96c933149a.tar.gz
gentoo-2-c14e1c161d56ccaf9815ca8021dc9d96c933149a.tar.bz2
gentoo-2-c14e1c161d56ccaf9815ca8021dc9d96c933149a.zip
Initial Import. Closes #46024
Diffstat (limited to 'dev-util/gruntspud')
-rw-r--r--dev-util/gruntspud/ChangeLog10
-rw-r--r--dev-util/gruntspud/Manifest3
-rw-r--r--dev-util/gruntspud/files/digest-gruntspud-0.4.5_beta1
-rw-r--r--dev-util/gruntspud/gruntspud-0.4.5_beta.ebuild44
-rw-r--r--dev-util/gruntspud/metadata.xml5
5 files changed, 63 insertions, 0 deletions
diff --git a/dev-util/gruntspud/ChangeLog b/dev-util/gruntspud/ChangeLog
new file mode 100644
index 000000000000..ea3e16213cfe
--- /dev/null
+++ b/dev-util/gruntspud/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/gruntspud
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gruntspud/ChangeLog,v 1.1 2004/04/11 22:29:16 zx Exp $
+
+*gruntspud-0.4.5_beta (11 Apr 2004)
+
+ 11 Apr 2004; Chris Aniszczyk <zx@gentoo.org> gruntspud-0.4.5_beta.ebuild,
+ metadata.xml:
+ Initial Import. Closes #46024
+
diff --git a/dev-util/gruntspud/Manifest b/dev-util/gruntspud/Manifest
new file mode 100644
index 000000000000..08a28001f2de
--- /dev/null
+++ b/dev-util/gruntspud/Manifest
@@ -0,0 +1,3 @@
+MD5 f9d23219beb42b3a5c85c7aa19b8e3e7 gruntspud-0.4.5_beta.ebuild 968
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 33dd5837dbf873a7453024f763729f64 files/digest-gruntspud-0.4.5_beta 74
diff --git a/dev-util/gruntspud/files/digest-gruntspud-0.4.5_beta b/dev-util/gruntspud/files/digest-gruntspud-0.4.5_beta
new file mode 100644
index 000000000000..30688c140c53
--- /dev/null
+++ b/dev-util/gruntspud/files/digest-gruntspud-0.4.5_beta
@@ -0,0 +1 @@
+MD5 3fd9ae53b42fb263208e20530c689273 gruntspud-0.4.5-beta-src.tgz 1993165
diff --git a/dev-util/gruntspud/gruntspud-0.4.5_beta.ebuild b/dev-util/gruntspud/gruntspud-0.4.5_beta.ebuild
new file mode 100644
index 000000000000..cb10c1463bb1
--- /dev/null
+++ b/dev-util/gruntspud/gruntspud-0.4.5_beta.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gruntspud/gruntspud-0.4.5_beta.ebuild,v 1.1 2004/04/11 22:29:16 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Gruntspud is a graphical CVS client written in Java."
+HOMEPAGE="http://gruntspud.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${PV/_/-}-src.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=virtual/jdk-1.3
+ dev-java/ant
+ sys-apps/sed
+ jikes? ( dev-java/jikes )"
+RDEPEND=">=virtual/jre-1.3"
+
+S="${WORKDIR}/${PN}-${PV/_/-}"
+
+src_unpack() {
+ unpack ${A}
+ # Dirty workaround
+ cd ${S}
+ sed -i 's:compile_standalone,javahelp:compile_standalone:' build.xml
+}
+
+src_compile() {
+ local antflags="dist_standalone"
+ ant ${antflags} || die "compilation problem"
+}
+
+src_install() {
+ cd ${S}/dist/lib
+ mv GruntspudSA.jar ${PN}.jar
+ java-pkg_dojar ${PN}.jar
+
+ echo "#!/bin/sh" > ${PN}
+ echo "cd /usr/share/${PN}" >> ${PN}
+ echo "java -jar lib/${PN}.jar" >> ${PN}
+ dobin ${PN}
+}
+
diff --git a/dev-util/gruntspud/metadata.xml b/dev-util/gruntspud/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-util/gruntspud/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>