summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-06-24 02:40:06 +0000
committerMarius Mauch <genone@gentoo.org>2004-06-24 02:40:06 +0000
commit7c69bdc7b5f4fd7d64395db0e20fc47320abe6c3 (patch)
tree493b8bf86b79028c5331b9d55b393c7e3e65608e /dev-util/gambas
parentQA - fix use invocation (Manifest recommit) (diff)
downloadgentoo-2-7c69bdc7b5f4fd7d64395db0e20fc47320abe6c3.tar.gz
gentoo-2-7c69bdc7b5f4fd7d64395db0e20fc47320abe6c3.tar.bz2
gentoo-2-7c69bdc7b5f4fd7d64395db0e20fc47320abe6c3.zip
version bump, disable preloading
Diffstat (limited to 'dev-util/gambas')
-rw-r--r--dev-util/gambas/ChangeLog6
-rw-r--r--dev-util/gambas/files/Makefile.am-0.9442
-rw-r--r--dev-util/gambas/files/digest-gambas-0.941
-rw-r--r--dev-util/gambas/gambas-0.94.ebuild80
4 files changed, 128 insertions, 1 deletions
diff --git a/dev-util/gambas/ChangeLog b/dev-util/gambas/ChangeLog
index 5d635bb04c77..6441499d0e66 100644
--- a/dev-util/gambas/ChangeLog
+++ b/dev-util/gambas/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/gambas
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.12 2004/05/21 19:29:15 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.13 2004/06/24 02:40:06 genone Exp $
+
+ 24 Jun 2004; Marius Mauch <genone@gentoo.org> :
+ version bump, disable preloading in the Makefile as some people reported
+ segfaults when it's on.
*gambas-0.93b (21 May 2004)
diff --git a/dev-util/gambas/files/Makefile.am-0.94 b/dev-util/gambas/files/Makefile.am-0.94
new file mode 100644
index 000000000000..2c84c2c6005d
--- /dev/null
+++ b/dev-util/gambas/files/Makefile.am-0.94
@@ -0,0 +1,42 @@
+SUBDIRS = libltdl src
+EXTRA_DIST = TODO reconf app examples help README README.REDHAT README.DEBIAN
+##AUTOMAKE_OPTIONS = dist-bzip2
+
+install-exec-local:
+ @echo
+ @echo "Creating the library info files..."
+ @$(INSTALL) -d $(pkgdatadir)/info
+ @$(bindir)/gbi -a -p
+ @rm -f $(pkglibdir)/lib.gb.la
+ @rm -f $(pkglibdir)/lib.gb.so*
+
+ @echo
+ @echo "Installing the development environment..."
+ @(cd $(srcdir)/app; d=`pwd`; for p in *; do echo "Compiling $$p..."; cd $$d/$$p; \
+ gbc -ag; gba; rm -rf .gambas; $(INSTALL) $$p $(bindir); done)
+
+ @echo
+ @echo "Installing the gambas help files..."
+ @$(INSTALL) -d $(pkgdatadir)/help
+ @rm -rf $(pkgdatadir)/help
+ @cp -R $(srcdir)/help $(pkgdatadir)
+
+ @echo
+ @echo "Installing the gambas examples..."
+ @rm -rf $(pkgdatadir)/examples
+ @$(INSTALL) -d $(pkgdatadir)/examples
+ @cp -R $(srcdir)/examples $(pkgdatadir)
+ @(cd $(pkgdatadir)/examples; d=`pwd`; for p in */ */*/; do cd $$d/$$p; \
+ if test -e .project; then \
+ echo "Compiling $$p..."; cd $$d/$$p; gbc -ag; gba; \
+ fi \
+ done)
+
+dist-hook:
+ @(cd $(distdir)/app; for p in *; do rm -rf $$p/.gambas $$p/.xvpics $$p/*/.xvpics $$p/*/*/.xvpics $$p/*~ $$p/*/*~ $$p/*/*/*~ $$p/.*.out $$p/*.out $$p/.lang/*.pot $$p/$$p; done)
+ @(cd $(distdir)/examples; for p in */ */*/; do \
+ if test -e $$p/.project; then \
+ rm -rf $$p/.gambas $$p/.xvpics $$p/*/.xvpics $$p/*/*/.xvpics $$p/*~ $$p/*/*~ $$p/.*.out $$p/*.out $$p/.lang/*.pot $$p/$$p; \
+ fi \
+ done)
+
diff --git a/dev-util/gambas/files/digest-gambas-0.94 b/dev-util/gambas/files/digest-gambas-0.94
new file mode 100644
index 000000000000..3444423deeed
--- /dev/null
+++ b/dev-util/gambas/files/digest-gambas-0.94
@@ -0,0 +1 @@
+MD5 538f603bd7561c4a078393002cd3c47d gambas-0.94.tar.bz2 3692414
diff --git a/dev-util/gambas/gambas-0.94.ebuild b/dev-util/gambas/gambas-0.94.ebuild
new file mode 100644
index 000000000000..4c879142652c
--- /dev/null
+++ b/dev-util/gambas/gambas-0.94.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-0.94.ebuild,v 1.1 2004/06/24 02:40:06 genone Exp $
+
+inherit eutils
+
+DESCRIPTION="a RAD tool for BASIC"
+HOMEPAGE="http://gambas.sourceforge.net"
+SRC_URI="http://gambas.sourceforge.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="postgres mysql sdl doc curl debug"
+
+DEPEND=">=sys-devel/automake-1.7.5
+ >=x11-libs/qt-3.2
+ >=kde-base/kdelibs-3.2
+ sdl? ( media-libs/libsdl )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ curl? ( net-misc/curl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:-Os::' configure
+ # replace braindead Makefile
+ rm Makefile*
+ cp "${FILESDIR}/Makefile.am-0.94" ./Makefile.am
+ automake
+ # patches against hardcoded paths
+ epatch ${FILESDIR}/non-symlink-0.90.patch
+ #epatch ${FILESDIR}/html-files-location-0.93.patch
+ #epatch ${FILESDIR}/info-location-0.90.patch
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} --enable-kde --enable-qt"
+ myconf="${myconf} `use_enable mysql`"
+ myconf="${myconf} `use_enable postgres`"
+ myconf="${myconf} `use_enable sdl`"
+ myconf="${myconf} `use_enable curl`"
+
+ if use debug ; then
+ myconf="${myconf} --disable-optimization --enable-debug"
+ else
+ myconf="${myconf} --enable-optimization --disable-debug"
+ fi
+
+ econf ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ export PATH="${D}/usr/bin:${PATH}"
+ einstall || die
+
+ dodoc README INSTALL NEWS AUTHORS ChangeLog TODO
+
+ # only install the API docs and examples with USE=doc
+ if use doc; then
+ mv ${D}/usr/share/${PN}/help ${D}/usr/share/doc/${PF}/html
+ mv ${D}/usr/share/${PN}/examples ${D}/usr/share/doc/${PF}/examples
+ einfo "Compiling examples ..."
+ cd ${D}/usr/share/doc/${PF}/examples
+ for p in *; do
+ cd $p
+ gbc -ag
+ gba
+ cd ..
+ done
+ fi
+ rm -rf ${D}/usr/share/${PN}/help ${D}/usr/share/${PN}/examples
+ dosym /usr/share/doc/${PF}/html /usr/share/${PN}/help
+ dosym /usr/share/doc/${PF}/examples /usr/share/${PN}/examples
+}