summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-03-09 15:36:08 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-03-09 15:36:08 +0000
commit6537ea61af0f0384310d7281de820681cf891f42 (patch)
treecdbde3d6c8c664fc9455c216b313f88b699ac905 /dev-util/fatrace
parentVersion Bump (diff)
downloadgentoo-2-6537ea61af0f0384310d7281de820681cf891f42.tar.gz
gentoo-2-6537ea61af0f0384310d7281de820681cf891f42.tar.bz2
gentoo-2-6537ea61af0f0384310d7281de820681cf891f42.zip
Version bump courtesy of Jorge Nerin <nerin@gmail.com>. Fix bug 542686.
(Portage version: 2.2.14/cvs/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'dev-util/fatrace')
-rw-r--r--dev-util/fatrace/ChangeLog9
-rw-r--r--dev-util/fatrace/fatrace-0.9.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-util/fatrace/ChangeLog b/dev-util/fatrace/ChangeLog
index 72a7b3e2ca5a..9b77e6460abd 100644
--- a/dev-util/fatrace/ChangeLog
+++ b/dev-util/fatrace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/fatrace
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/fatrace/ChangeLog,v 1.4 2014/11/28 13:05:13 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/fatrace/ChangeLog,v 1.5 2015/03/09 15:36:08 monsieurp Exp $
+
+*fatrace-0.9 (09 Mar 2015)
+
+ 09 Mar 2015; Patrice Clement <monsieurp@gentoo.org> +fatrace-0.9.ebuild:
+ Version bump courtesy of Jorge Nerin <nerin@gmail.com>. Fix bug 542686.
28 Nov 2014; Pacho Ramos <pacho@gentoo.org> fatrace-0.5.ebuild:
Support python 3.4
diff --git a/dev-util/fatrace/fatrace-0.9.ebuild b/dev-util/fatrace/fatrace-0.9.ebuild
new file mode 100644
index 000000000000..e0b2084e281c
--- /dev/null
+++ b/dev-util/fatrace/fatrace-0.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/fatrace/fatrace-0.9.ebuild,v 1.1 2015/03/09 15:36:08 monsieurp Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_2,3_3,3_4} )
+
+inherit linux-info python-r1 toolchain-funcs
+
+DESCRIPTION="report file access events from all running processes"
+HOMEPAGE="https://launchpad.net/fatrace"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="powertop"
+
+RDEPEND="powertop? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="powertop? ( ${PYTHON_REQUIRED_USE} )"
+
+CONFIG_CHECK="~FANOTIFY"
+
+src_prepare() {
+ tc-export CC
+}
+
+src_install() {
+ dosbin fatrace
+ use powertop && dosbin power-usage-report
+
+ doman fatrace.1
+ dodoc NEWS
+}