summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-23 10:38:07 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-23 10:38:07 +0000
commitbcd827920a2b94cb2786b41482714b033a7275d0 (patch)
tree2a6d4d31d11f183f99b87e6fd4211618748466e7 /dev-util/dmake/dmake-4.1-r1.ebuild
parentAdded GNU GPL version 1 (diff)
downloadgentoo-2-bcd827920a2b94cb2786b41482714b033a7275d0.tar.gz
gentoo-2-bcd827920a2b94cb2786b41482714b033a7275d0.tar.bz2
gentoo-2-bcd827920a2b94cb2786b41482714b033a7275d0.zip
repoman'd
Diffstat (limited to 'dev-util/dmake/dmake-4.1-r1.ebuild')
-rw-r--r--dev-util/dmake/dmake-4.1-r1.ebuild39
1 files changed, 19 insertions, 20 deletions
diff --git a/dev-util/dmake/dmake-4.1-r1.ebuild b/dev-util/dmake/dmake-4.1-r1.ebuild
index 4938709cf610..e10c174dde48 100644
--- a/dev-util/dmake/dmake-4.1-r1.ebuild
+++ b/dev-util/dmake/dmake-4.1-r1.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/dmake/dmake-4.1-r1.ebuild,v 1.2 2002/07/11 06:30:25 drobbins Exp $
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dmake/dmake-4.1-r1.ebuild,v 1.3 2002/07/23 10:38:07 seemant Exp $
S=${WORKDIR}/${P}
-
DESCRIPTION="Improved make"
-
SRC_URI="http://plg.uwaterloo.ca/~ftp/dmake/dmake-v4.1-src-export.all-unknown-all.tar.gz"
+HOMEPAGE="http://www.scri.fsu.edu/~dwyer/dmake.html"
-HOMEPAGE=""
+SLOT="0"
+LICENSE="GPL-1"
+KEYWORDS="x86"
-DEPEND="virtual/glibc
- sys-apps/groff"
+DEPEND="sys-apps/groff"
src_unpack() {
@@ -19,25 +19,25 @@ src_unpack() {
unpack dmake-v4.1-src-export.all-unknown-all.tar.gz
mv dmake ${P}
- cp ${S}/unix/runargv.c ${S}/unix/runargv.c.orig
-
- cat ${S}/unix/runargv.c.orig | \
- sed -e "s:extern.*char \*sys_errlist\[\];::" \
- > ${S}/unix/runargv.c
- cp ${S}/unix/startup.h ${S}/unix/startup.h.orig
+ cd ${S}
+ cp unix/runargv.c unix/runargv.c.orig
+ cat unix/runargv.c.orig | \
+ sed -e "s:extern.*char \*sys_errlist\[\];::" \
+ > unix/runargv.c
+
+ cp unix/startup.h unix/startup.h.orig
- cat ${S}/unix/startup.h | \
- sed -e "s:usr/local/lib/dmake:usr/share/dmake:" \
- > ${S}/unix/startup.h
+ cat unix/startup.h | \
+ sed -e "s:usr/local/lib/dmake:usr/share/dmake:" \
+ > unix/startup.h
}
src_compile() {
sh unix/linux/gnu/make.sh
-
- cat man/dmake.tf > man/dmake.1
+ cp man/dmake.tf man/dmake.1
}
@@ -52,4 +52,3 @@ src_install () {
doins startup/{startup.mk,config.mk} startup/unix
}
-