summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-02-15 12:45:45 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-02-15 12:45:45 +0000
commit430331047444efb9f72c81840b3153d409afbc60 (patch)
tree9d884006ca36d6d87b2703d9b9d4da20c04e099f /dev-util/darcs/darcs-1.0.5.ebuild
parentversion bump (diff)
downloadgentoo-2-430331047444efb9f72c81840b3153d409afbc60.tar.gz
gentoo-2-430331047444efb9f72c81840b3153d409afbc60.tar.bz2
gentoo-2-430331047444efb9f72c81840b3153d409afbc60.zip
Marked ~sparc. Fixed use of CFLAGS which casued problems on sparc.
(Portage version: 2.0.54)
Diffstat (limited to 'dev-util/darcs/darcs-1.0.5.ebuild')
-rw-r--r--dev-util/darcs/darcs-1.0.5.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-util/darcs/darcs-1.0.5.ebuild b/dev-util/darcs/darcs-1.0.5.ebuild
index 027c1483f27b..b309adade6cc 100644
--- a/dev-util/darcs/darcs-1.0.5.ebuild
+++ b/dev-util/darcs/darcs-1.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/darcs-1.0.5.ebuild,v 1.3 2006/01/11 05:36:18 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/darcs-1.0.5.ebuild,v 1.4 2006/02/15 12:45:45 dcoutts Exp $
inherit base fixheadtails
@@ -12,7 +12,7 @@ SRC_URI="http://abridgegame.org/darcs/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ppc x86"
+KEYWORDS="~amd64 ppc x86 ~sparc"
IUSE="doc"
# disabled wxwindows use flag for now, as I got build errors
@@ -32,6 +32,11 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
base_src_unpack
ht_fix_all
+
+ # If we're going to use the CFLAGS with GHC's -optc flag then we'd better
+ # use it with -opta too or it'll break with some CFLAGS, eg -mcpu on sparc
+ sed -i 's:\($(addprefix -optc,$(CFLAGS))\):\1 $(addprefix -opta,$(CFLAGS)):' \
+ ${S}/autoconf.mk.in
}
src_compile() {