summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2002-09-29 07:48:13 +0000
committerMatthew Turk <satai@gentoo.org>2002-09-29 07:48:13 +0000
commit0569d3913474a4e71a7efd6c76e62d421bba3a6e (patch)
tree6778bd6e53d5e74314a8f202ea36c5a2b11258e7 /dev-util/cweb/cweb-3.63-r1.ebuild
parentChanged econf to econf || die (diff)
downloadgentoo-2-0569d3913474a4e71a7efd6c76e62d421bba3a6e.tar.gz
gentoo-2-0569d3913474a4e71a7efd6c76e62d421bba3a6e.tar.bz2
gentoo-2-0569d3913474a4e71a7efd6c76e62d421bba3a6e.zip
Bumping portrevision to install all files; closing #7931.
Diffstat (limited to 'dev-util/cweb/cweb-3.63-r1.ebuild')
-rw-r--r--dev-util/cweb/cweb-3.63-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/cweb/cweb-3.63-r1.ebuild b/dev-util/cweb/cweb-3.63-r1.ebuild
new file mode 100644
index 000000000000..376e8a1d8b9f
--- /dev/null
+++ b/dev-util/cweb/cweb-3.63-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cweb/cweb-3.63-r1.ebuild,v 1.1 2002/09/29 07:48:13 satai Exp $
+
+S=${WORKDIR}
+DESCRIPTION="Knuth's and Levy's C/C++ documenting system"
+SRC_URI="ftp://labrea.stanford.edu/pub/cweb/cweb.tar.gz"
+HOMEPAGE="http://www-cs-faculty.stanford.edu/~knuth/cweb.html"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ #emake won't work, because cweave needs ctangle to compile
+ make all CFLAGS="${CFLAGS}" LINKFLAGS="-s" || die
+}
+
+src_install () {
+ dobin ctangle cweave
+ doman cweb.1
+ dodoc README cwebman.tex
+ dodir /usr/share/texmf/tex/generic
+ insinto /usr/share/texmf/tex/generic
+ doins cwebmac.tex
+ dodir /usr/lib/cweb
+ insinto /usr/lib/cweb
+ doins c++lib.w
+ dodir /usr/share/emacs/site-lisp/
+ insinto /usr/share/emacs/site-lisp/
+ doins cweb.el
+}
+
+# Going to use this, just to make sure. May convert to a latex-package later.
+pkg_postinst() {
+ texconfig rehash
+}