summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-01-08 14:36:17 +0000
committerPeter Volkov <pva@gentoo.org>2009-01-08 14:36:17 +0000
commit2935460d2d931940459ac4996ed85bf0ec104bc0 (patch)
treee4406cf56a4d17089b354411a8fe7b71d15e60a5 /dev-util/cunit
parentAdd ~ia64 wrt #253448 (diff)
downloadgentoo-2-2935460d2d931940459ac4996ed85bf0ec104bc0.tar.gz
gentoo-2-2935460d2d931940459ac4996ed85bf0ec104bc0.tar.bz2
gentoo-2-2935460d2d931940459ac4996ed85bf0ec104bc0.zip
Don't install documentation into /usr/doc, bug #247234, don't call eautoreconf in src_compile, bug #241348, thank Diego E. 'Flameeyes' Pettenò for reports.
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-openvz.git-89451f9 i686)
Diffstat (limited to 'dev-util/cunit')
-rw-r--r--dev-util/cunit/ChangeLog11
-rw-r--r--dev-util/cunit/cunit-2.1-r1.ebuild40
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-util/cunit/ChangeLog b/dev-util/cunit/ChangeLog
index b99c002b6846..52bf4c0b6263 100644
--- a/dev-util/cunit/ChangeLog
+++ b/dev-util/cunit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/cunit
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/ChangeLog,v 1.23 2008/10/27 07:25:02 pva Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/ChangeLog,v 1.24 2009/01/08 14:36:17 pva Exp $
+
+*cunit-2.1-r1 (08 Jan 2009)
+
+ 08 Jan 2009; Peter Volkov <pva@gentoo.org> +cunit-2.1-r1.ebuild:
+ Don't install documentation into /usr/doc, bug #247234, don't call
+ eautoreconf in src_compile, bug #241348, thank Diego E. 'Flameeyes'
+ Pettenò for reports.
27 Oct 2008; Peter Volkov <pva@gentoo.org> cunit-2.1.ebuild:
~mips keyworded, bug #242546
diff --git a/dev-util/cunit/cunit-2.1-r1.ebuild b/dev-util/cunit/cunit-2.1-r1.ebuild
new file mode 100644
index 000000000000..6a04f6b2bd14
--- /dev/null
+++ b/dev-util/cunit/cunit-2.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/cunit-2.1-r1.ebuild,v 1.1 2009/01/08 14:36:17 pva Exp $
+
+inherit eutils autotools
+
+MY_PN='CUnit'
+MY_PV="${PV}-0"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="CUnit - C Unit Test Framework"
+SRC_URI="mirror://sourceforge/cunit/${MY_P}-src.tar.gz"
+HOMEPAGE="http://cunit.sourceforge.net"
+
+DEPEND="virtual/libc"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "/^docdir/d" -i doc/Makefile.am
+ sed -e '/^dochdrdir/{s:$(prefix)/doc/@PACKAGE@:$(docdir):}' \
+ -i doc/headers/Makefile.am
+ eautoreconf
+}
+
+src_compile() {
+ econf --docdir=/usr/share/doc/${PF}
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README ChangeLog
+}