summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-27 11:05:48 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-27 11:05:48 +0000
commit6e4c920be7abc503149e6920d880e28697fd4015 (patch)
treeac84bdf495dc36ecb638902e3e9574845c0ab1d0 /dev-util/cppunit
parentversion bump (diff)
downloadgentoo-2-6e4c920be7abc503149e6920d880e28697fd4015.tar.gz
gentoo-2-6e4c920be7abc503149e6920d880e28697fd4015.tar.bz2
gentoo-2-6e4c920be7abc503149e6920d880e28697fd4015.zip
Bump to latest version.
(Portage version: 2.2.0_alpha132/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cppunit')
-rw-r--r--dev-util/cppunit/ChangeLog8
-rw-r--r--dev-util/cppunit/cppunit-1.13.1.ebuild56
-rw-r--r--dev-util/cppunit/cppunit-9999.ebuild8
3 files changed, 67 insertions, 5 deletions
diff --git a/dev-util/cppunit/ChangeLog b/dev-util/cppunit/ChangeLog
index 044a89e6c098..4ed7ffceb6f3 100644
--- a/dev-util/cppunit/ChangeLog
+++ b/dev-util/cppunit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cppunit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/ChangeLog,v 1.75 2012/09/13 15:36:01 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/ChangeLog,v 1.76 2012/09/27 11:05:48 scarabeus Exp $
+
+*cppunit-1.13.1 (27 Sep 2012)
+
+ 27 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org> +cppunit-1.13.1.ebuild,
+ cppunit-9999.ebuild:
+ Bump to latest version.
13 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org> -cppunit-1.12.1-r1.ebuild,
-files/cppunit-1.10.2-asneeded.patch,
diff --git a/dev-util/cppunit/cppunit-1.13.1.ebuild b/dev-util/cppunit/cppunit-1.13.1.ebuild
new file mode 100644
index 000000000000..59fd19fbb781
--- /dev/null
+++ b/dev-util/cppunit/cppunit-1.13.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-1.13.1.ebuild,v 1.1 2012/09/27 11:05:48 scarabeus Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/libreoffice/cppunit"
+[[ ${PV} = 9999 ]] && inherit git-2 autotools
+inherit eutils flag-o-matic
+
+DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/cppunit"
+[[ ${PV} = 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+[[ ${PV} = 9999 ]] || KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ media-gfx/graphviz
+ )"
+
+DOCS=( AUTHORS BUGS NEWS README THANKS TODO doc/FAQ )
+[[ ${PV} = 9999 ]] || DOCS+=( ChangeLog )
+
+src_prepare() {
+ [[ ${PV} = 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # Anything else than -O0 breaks on alpha
+ use alpha && replace-flags "-O?" -O0
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable doc doxygen) \
+ $(use_enable doc dot) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+
+ if use examples ; then
+ find examples -iname "*.o" -delete
+ insinto /usr/share/${PN}
+ doins -r examples
+ fi
+}
diff --git a/dev-util/cppunit/cppunit-9999.ebuild b/dev-util/cppunit/cppunit-9999.ebuild
index ec9c16ab6dd2..3b1464953a97 100644
--- a/dev-util/cppunit/cppunit-9999.ebuild
+++ b/dev-util/cppunit/cppunit-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-9999.ebuild,v 1.1 2012/08/11 09:29:13 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-9999.ebuild,v 1.2 2012/09/27 11:05:48 scarabeus Exp $
EAPI=4
@@ -25,7 +25,7 @@ DEPEND="${RDEPEND}
)"
DOCS=( AUTHORS BUGS NEWS README THANKS TODO doc/FAQ )
-[[ ${PV} = 9999 ]] || DOCS+=" ChangeLog"
+[[ ${PV} = 9999 ]] || DOCS+=( ChangeLog )
src_prepare() {
[[ ${PV} = 9999 ]] && eautoreconf
@@ -39,14 +39,14 @@ src_configure() {
$(use_enable static-libs static) \
$(use_enable doc doxygen) \
$(use_enable doc dot) \
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
--htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
}
src_install() {
default
- find "${ED}" -name '*.la' -exec rm -f {} +
+ prune_libtool_files --all
if use examples ; then
find examples -iname "*.o" -delete