summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-02-27 10:26:42 +0000
committerMichael Weber <xmw@gentoo.org>2015-02-27 10:26:42 +0000
commitdd5362677cbe39f0778769823255531904a7dd8b (patch)
treeec40bd49110a780b282b1cf7c803ad8d4f55e207 /dev-util/cppcheck
parentFix prefix installation (bug 531760, thanks Andrey Hippo) (diff)
downloadgentoo-2-dd5362677cbe39f0778769823255531904a7dd8b.tar.gz
gentoo-2-dd5362677cbe39f0778769823255531904a7dd8b.tar.bz2
gentoo-2-dd5362677cbe39f0778769823255531904a7dd8b.zip
Version bump (bug 524674, thanks Christian Strahl).
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'dev-util/cppcheck')
-rw-r--r--dev-util/cppcheck/ChangeLog9
-rw-r--r--dev-util/cppcheck/cppcheck-1.65-r1.ebuild99
-rw-r--r--dev-util/cppcheck/cppcheck-1.68.ebuild (renamed from dev-util/cppcheck/cppcheck-1.66.ebuild)7
-rw-r--r--dev-util/cppcheck/files/cppcheck-1.65-tinyxml2.patch67
4 files changed, 12 insertions, 170 deletions
diff --git a/dev-util/cppcheck/ChangeLog b/dev-util/cppcheck/ChangeLog
index 2b4e4aa0a27a..a71184db69f5 100644
--- a/dev-util/cppcheck/ChangeLog
+++ b/dev-util/cppcheck/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/cppcheck
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.61 2015/02/27 10:14:25 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.62 2015/02/27 10:26:42 xmw Exp $
+
+*cppcheck-1.68 (27 Feb 2015)
+
+ 27 Feb 2015; Michael Weber <xmw@gentoo.org> +cppcheck-1.68.ebuild,
+ -cppcheck-1.65-r1.ebuild, -cppcheck-1.66.ebuild,
+ -files/cppcheck-1.65-tinyxml2.patch:
+ Version bump (bug 524674, thanks Christian Strahl).
27 Feb 2015; Michael Weber <xmw@gentoo.org> cppcheck-1.66.ebuild,
cppcheck-1.67.ebuild:
diff --git a/dev-util/cppcheck/cppcheck-1.65-r1.ebuild b/dev-util/cppcheck/cppcheck-1.65-r1.ebuild
deleted file mode 100644
index 1c31f01f613e..000000000000
--- a/dev-util/cppcheck/cppcheck-1.65-r1.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.65-r1.ebuild,v 1.3 2014/10/10 13:23:54 xmw Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1 eutils flag-o-matic qt4-r2 toolchain-funcs
-
-DESCRIPTION="static analyzer of C/C++ code"
-HOMEPAGE="http://cppcheck.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="htmlreport pcre qt4"
-
-RDEPEND="htmlreport? ( ${PYTHON_DEPS} )
- >=dev-libs/tinyxml2-2
- qt4? ( dev-qt/qtgui:4 )
- pcre? ( dev-libs/libpcre )"
-DEPEND="${RDEPEND}
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- virtual/pkgconfig"
-
-src_prepare() {
- # Drop bundled libs, patch Makefile generator and re-run it
- rm -r externals || die
- epatch "${FILESDIR}"/${P}-tinyxml2.patch
- tc-export CXX
- emake dmake
- ./dmake || die
-
- epatch "${FILESDIR}"/${P}-c++0x.patch
-}
-
-src_configure() {
- if use pcre ; then
- sed -e '/HAVE_RULES=/s:=no:=yes:' \
- -i Makefile
- fi
- if use qt4 ; then
- pushd gui
- qt4-r2_src_configure
- popd
- fi
-}
-
-src_compile() {
- export LIBS="$(pkg-config --libs tinyxml2)"
- emake ${PN} man \
- CFGDIR="${EROOT}usr/share/${PN}/cfg" \
- DB2MAN="${EROOT}usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl"
-
- if use qt4 ; then
- pushd gui
- qt4-r2_src_compile
- popd
- fi
- if use htmlreport ; then
- pushd htmlreport
- distutils-r1_src_compile
- popd
- fi
-}
-
-src_test() {
- # safe final version
- mv -v ${PN}{,.final}
- mv -v lib/library.o{,.final}
- mv -v cli/cppcheckexecutor.o{,.final}
- #trigger recompile with CFGDIR inside ${S}
- emake check CFGDIR="${S}/cfg"
- # restore
- mv -v ${PN}{.final,}
- mv -v lib/library.o{.final,}
- mv -v cli/cppcheckexecutor.o{.final,}
-}
-
-src_install() {
- emake install DESTDIR="${D}"
- insinto "/usr/share/${PN}/cfg"
- doins cfg/*.cfg
- if use qt4 ; then
- dobin gui/${PN}-gui
- dodoc readme_gui.txt gui/{projectfile.txt,gui.${PN}}
- fi
- if use htmlreport ; then
- pushd htmlreport
- distutils-r1_src_install
- popd
- find "${D}" -name "*.egg-info" -delete
- fi
- doman ${PN}.1
- dodoc readme.txt
-}
diff --git a/dev-util/cppcheck/cppcheck-1.66.ebuild b/dev-util/cppcheck/cppcheck-1.68.ebuild
index 71aaebb74a67..286959dba481 100644
--- a/dev-util/cppcheck/cppcheck-1.66.ebuild
+++ b/dev-util/cppcheck/cppcheck-1.68.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.66.ebuild,v 1.3 2015/02/27 10:14:25 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.68.ebuild,v 1.1 2015/02/27 10:26:42 xmw Exp $
EAPI=5
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~arm ~x86"
IUSE="htmlreport pcre qt4"
RDEPEND="htmlreport? ( ${PYTHON_DEPS} )
@@ -29,7 +29,7 @@ DEPEND="${RDEPEND}
src_prepare() {
# Drop bundled libs, patch Makefile generator and re-run it
rm -r externals || die
- epatch "${FILESDIR}"/${P}-tinyxml2.patch
+ epatch "${FILESDIR}"/${PN}-1.66-tinyxml2.patch
tc-export CXX
emake dmake
./dmake || die
@@ -98,4 +98,5 @@ src_install() {
fi
doman ${PN}.1
dodoc readme.txt
+ dodoc -r triage
}
diff --git a/dev-util/cppcheck/files/cppcheck-1.65-tinyxml2.patch b/dev-util/cppcheck/files/cppcheck-1.65-tinyxml2.patch
deleted file mode 100644
index cb5a4ae401e2..000000000000
--- a/dev-util/cppcheck/files/cppcheck-1.65-tinyxml2.patch
+++ /dev/null
@@ -1,67 +0,0 @@
---- cppcheck-1.65/tools/dmake.cpp
-+++ cppcheck-1.65/tools/dmake.cpp
-@@ -170,7 +170,6 @@
- }
-
- std::vector<std::string> externalfiles;
-- getCppFiles(externalfiles, "externals/");
-
-
- // QMAKE - lib/lib.pri
-@@ -179,10 +178,6 @@
- if (fout1.is_open()) {
- fout1 << "# no manual edits - this file is autogenerated by dmake\n\n";
- fout1 << "include($$PWD/pcrerules.pri)\n";
-- fout1 << "BASEPATH = ../externals/tinyxml/\n";
-- fout1 << "include($$PWD/../externals/tinyxml/tinyxml.pri)\n";
-- fout1 << "BASEPATH = ../lib/\n";
-- fout1 << "INCLUDEPATH += ../externals/tinyxml\n";
- fout1 << "HEADERS += $${BASEPATH}check.h \\\n";
- for (unsigned int i = 0; i < libfiles.size(); ++i) {
- std::string fname(libfiles[i].substr(4));
-@@ -208,7 +203,6 @@
- std::ofstream fout1("test/testfiles.pri");
- if (fout1.is_open()) {
- fout1 << "# no manual edits - this file is autogenerated by dmake\n\n";
-- fout1 << "INCLUDEPATH += ../externals/tinyxml\n";
- fout1 << "\n\nSOURCES += ";
- for (unsigned int i = 0; i < testfiles.size(); ++i) {
- const std::string filename(testfiles[i].substr(5));
-@@ -354,9 +348,9 @@
-
- makeConditionalVariable(fout, "CXX", "g++");
- makeConditionalVariable(fout, "PREFIX", "/usr");
-- makeConditionalVariable(fout, "INCLUDE_FOR_LIB", "-Ilib -Iexternals/tinyxml");
-- makeConditionalVariable(fout, "INCLUDE_FOR_CLI", "-Ilib -Iexternals/tinyxml");
-- makeConditionalVariable(fout, "INCLUDE_FOR_TEST", "-Ilib -Icli -Iexternals/tinyxml");
-+ makeConditionalVariable(fout, "INCLUDE_FOR_LIB", "-Ilib");
-+ makeConditionalVariable(fout, "INCLUDE_FOR_CLI", "-Ilib");
-+ makeConditionalVariable(fout, "INCLUDE_FOR_TEST", "-Ilib -Icli");
-
- fout << "BIN=$(DESTDIR)$(PREFIX)/bin\n\n";
- fout << "# For 'make man': sudo apt-get install xsltproc docbook-xsl docbook-xml on Linux\n";
-@@ -394,10 +388,10 @@
- fout << "dmake:\ttools/dmake.o cli/filelister.o lib/path.o\n";
- fout << "\t$(CXX) $(CXXFLAGS) -std=c++0x -o dmake tools/dmake.o cli/filelister.o lib/path.o -Ilib $(LDFLAGS)\n";
- fout << "\t./dmake\n\n";
-- fout << "reduce:\ttools/reduce.o externals/tinyxml/tinyxml2.o $(LIBOBJ)\n";
-- fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -std=c++0x -g -o reduce tools/reduce.o -Ilib -Iexternals/tinyxml $(LIBOBJ) $(LIBS) externals/tinyxml/tinyxml2.o $(LDFLAGS) $(RDYNAMIC)\n\n";
-+ fout << "reduce:\ttools/reduce.o $(LIBOBJ)\n";
-+ fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -std=c++0x -g -o reduce tools/reduce.o -Ilib $(LIBOBJ) $(LIBS) $(LDFLAGS) $(RDYNAMIC)\n\n";
- fout << "clean:\n";
-- fout << "\trm -f build/*.o lib/*.o cli/*.o test/*.o externals/tinyxml/*.o testrunner reduce dmake cppcheck cppcheck.1\n\n";
-+ fout << "\trm -f build/*.o lib/*.o cli/*.o test/*.o testrunner reduce dmake cppcheck cppcheck.1\n\n";
- fout << "man:\tman/cppcheck.1\n\n";
- fout << "man/cppcheck.1:\t$(MAN_SOURCE)\n\n";
- fout << "\t$(XP) $(DB2MAN) $(MAN_SOURCE)\n\n";
---- cppcheck-1.65/gui/gui.pro
-+++ cppcheck-1.65/gui/gui.pro
-@@ -15,7 +15,7 @@
- LIBS += -l../bin/cppcheck-core
- DEFINES += CPPCHECKLIB_IMPORT
- }
--LIBS += -L../externals
-+LIBS += `pkg-config --libs tinyxml2`
-
- DESTDIR = .
- RCC_DIR = temp