summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-06-24 04:00:02 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-06-24 04:00:02 +0000
commitf076d8858338f73e1fc86dc55b987749aaea4b68 (patch)
tree677c2a0dbefb2eba865dddca850f9a3702487447 /dev-util/cook/cook-2.31.ebuild
parentAdd USE=iconv #229125 by Fabian Groffen. (diff)
downloadgentoo-2-f076d8858338f73e1fc86dc55b987749aaea4b68.tar.gz
gentoo-2-f076d8858338f73e1fc86dc55b987749aaea4b68.tar.bz2
gentoo-2-f076d8858338f73e1fc86dc55b987749aaea4b68.zip
Remove old versions. Version bump for bug #214538 (drop existing kws to ~ARCH). Also, add RDEPEND= to fix bug #221595
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util/cook/cook-2.31.ebuild')
-rw-r--r--dev-util/cook/cook-2.31.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/cook/cook-2.31.ebuild b/dev-util/cook/cook-2.31.ebuild
new file mode 100644
index 000000000000..783e0fc8a39c
--- /dev/null
+++ b/dev-util/cook/cook-2.31.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cook/cook-2.31.ebuild,v 1.1 2008/06/24 04:00:02 darkside Exp $
+
+inherit eutils
+
+DESCRIPTION="tool for constructing files; a drop in replacement for make"
+HOMEPAGE="http://www.canb.auug.org.au/~millerp/cook/cook.html"
+SRC_URI="http://miller.emu.id.au/pmiller/software/cook/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-devel/bison"
+RDEPEND=""
+
+src_compile() {
+ econf || die "./configure failed"
+ # doesn't seem to like parallel
+ emake -j1 || die
+}
+
+src_install() {
+ # we'll hijack the RPM_BUILD_ROOT variable which is intended for a
+ # similiar purpose anyway
+ make RPM_BUILD_ROOT="${D}" install || die
+}