summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-08-11 15:35:02 +0000
committerJeroen Roovers <jer@gentoo.org>2012-08-11 15:35:02 +0000
commit06a9f36bfba7bf593e9c899ce026a4bd5e3d2b89 (patch)
treed192caad8a68da138b0c40b3474ecd05d1fb7613 /dev-util/complexity
parentVersion bump, bug 430802, thanks creffett (diff)
downloadgentoo-2-06a9f36bfba7bf593e9c899ce026a4bd5e3d2b89.tar.gz
gentoo-2-06a9f36bfba7bf593e9c899ce026a4bd5e3d2b89.tar.bz2
gentoo-2-06a9f36bfba7bf593e9c899ce026a4bd5e3d2b89.zip
Fix building against sys-libs/glibc-2.16 by Diego Elio Pettenò (bug #430826).
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/complexity')
-rw-r--r--dev-util/complexity/ChangeLog7
-rw-r--r--dev-util/complexity/complexity-0.4.ebuild7
-rw-r--r--dev-util/complexity/files/complexity-0.4-gets.patch22
3 files changed, 34 insertions, 2 deletions
diff --git a/dev-util/complexity/ChangeLog b/dev-util/complexity/ChangeLog
index 5c116e5c0239..106e72331e3f 100644
--- a/dev-util/complexity/ChangeLog
+++ b/dev-util/complexity/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/complexity
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/complexity/ChangeLog,v 1.4 2012/04/25 00:29:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/complexity/ChangeLog,v 1.5 2012/08/11 15:35:02 jer Exp $
+
+ 11 Aug 2012; Jeroen Roovers <jer@gentoo.org> complexity-0.4.ebuild,
+ +files/complexity-0.4-gets.patch:
+ Fix building against sys-libs/glibc-2.16 by Diego Elio Pettenò (bug
+ #430826).
25 Apr 2012; Jeroen Roovers <jer@gentoo.org> complexity-0.4.ebuild:
Add RDEPEND on sys-devel/autogen for libopts.
diff --git a/dev-util/complexity/complexity-0.4.ebuild b/dev-util/complexity/complexity-0.4.ebuild
index 488823fe1b99..18c7aba9d9e1 100644
--- a/dev-util/complexity/complexity-0.4.ebuild
+++ b/dev-util/complexity/complexity-0.4.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/complexity/complexity-0.4.ebuild,v 1.4 2012/04/25 00:29:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/complexity/complexity-0.4.ebuild,v 1.5 2012/08/11 15:35:02 jer Exp $
EAPI=4
+inherit eutils
DESCRIPTION="a tool designed for analyzing the complexity of C program
functions"
@@ -23,3 +24,7 @@ DEPEND="
"
DOCS=( ChangeLog )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gets.patch
+}
diff --git a/dev-util/complexity/files/complexity-0.4-gets.patch b/dev-util/complexity/files/complexity-0.4-gets.patch
new file mode 100644
index 000000000000..4f35df60f28f
--- /dev/null
+++ b/dev-util/complexity/files/complexity-0.4-gets.patch
@@ -0,0 +1,22 @@
+--- a/lib/stdio.in.h
++++ b/lib/stdio.in.h
+@@ -720,8 +720,9 @@
+ #if @GNULIB_GETS@
+ # if @REPLACE_STDIO_READ_FUNCS@ && @GNULIB_STDIO_H_NONBLOCKING@
+ # if !(defined __cplusplus && defined GNULIB_NAMESPACE)
+-# undef gets
+-# define gets rpl_gets
++# ifdef gets
++# undef gets
++# define gets rpl_gets
+ # endif
+ _GL_FUNCDECL_RPL (gets, char *, (char *s) _GL_ARG_NONNULL ((1)));
+ _GL_CXXALIAS_RPL (gets, char *, (char *s));
+@@ -734,6 +735,7 @@
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
++# endif
+ #endif
+
+